This Course Covers:

- How to customize forms and reports
CustomGuide.com granted to Computer and Telecommunication Services a license agreement to print an unlimited number of copies of the CustomGuide Courseware materials within Stockton College of New Jersey for training staff, faculty and students.

End users who receive this handout may not reproduce or distribute these materials without permission. Please refer to the copyright notice below for more information.

Written by Jonathan High, CustomGuide, Minneapolis. Thanks to my wife, Sue for her enduring support, patience, and love.

© 2000 by CustomGuide, Inc. 4941 Columbus Avenue, Minneapolis, MN 55417

This material is copyrighted and all rights are reserved by CustomGuide, Inc. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical, manual, or otherwise, without the prior written permission of CustomGuide, Inc.

We make a sincere effort to ensure the accuracy of the material described herein; however, CustomGuide makes no warranty, express or implied, with respect to the quality, correctness, reliability, accuracy, or freedom from error of this document or the products it describes. Data used in examples and sample data files are intended to be fictional. Any resemblance to real persons or companies is entirely coincidental.

The names of software products referred to in this manual are claimed as trademarks of their respective companies. CustomGuide is a registered trademark of CustomGuide, Inc.
# Table of Contents

Chapter One: Working with Forms

- Lesson 1-1: Creating a Form with AutoForm ................................................................. 5
- Lesson 1-2: Modifying a Form ......................................................................................... 6
- Lesson 1-3: Adding and Deleting Fields .......................................................................... 8
- Lesson 1-4: Moving and Sizing Controls ........................................................................ 10
- Lesson 1-5: Changing the Tab Order .............................................................................. 12
- Lesson 1-6: Working with Control Properties ................................................................. 14
- Lesson 1-7: Control Property Reference ........................................................................... 16
- Lesson 1-8: Working with Form Properties ..................................................................... 18
- Lesson 1-9: Form and Report Property Reference ........................................................... 20
- Lesson 1-10: Working with Multiple Controls ................................................................. 22
- Lesson 1-11: Adding, Cutting, Copying, and Pasting Controls ......................................... 24
- Lesson 1-12: Changing a Control’s Data Source .............................................................. 25
- Lesson 1-13: Creating a Calculated Control ...................................................................... 26
- Lesson 1-14: Changing a Control’s Default Value ........................................................... 28
- Lesson 1-15: Using the Control Wizard .......................................................................... 30
- Chapter One Review ........................................................................................................ 32

Chapter Two: Working with Reports

- Lesson 2-1: Creating a Report with AutoReport .............................................................. 37
- Lesson 2-2: Modifying a Report ....................................................................................... 38
- Lesson 2-3: Adding and Deleting Fields ........................................................................... 40
- Lesson 2-4: Moving and Sizing Controls ........................................................................ 42
- Lesson 2-5: Adjusting Page Margins and Orientation ..................................................... 44
- Lesson 2-6: Adding Page Numbers and Dates ................................................................. 46
- Lesson 2-7: Understanding Report Sections .................................................................. 48
- Chapter Two Review ....................................................................................................... 50

Chapter Three: Formatting Forms and Reports

- Lesson 3-1: Formatting Fonts with the Formatting Toolbar .............................................. 55
- Lesson 3-2: Changing Text Alignment .............................................................................. 56
- Lesson 3-3: Using AutoFormat ....................................................................................... 58
- Lesson 3-4: Changing Colors ......................................................................................... 59
- Lesson 3-5: Applying Special Effects .............................................................................. 60
- Lesson 3-6: Using the Format Painter .............................................................................. 61
- Lesson 3-7: Adding Pictures and Lines ............................................................................ 62
- Lesson 3-8: Aligning Controls with One Another ........................................................... 64
- Lesson 3-9: Changing a Control’s Formatting Properties ................................................ 66
- Chapter Three Review .................................................................................................... 68
Chapter One: Working with Forms

Chapter Objectives:

- Create and modify a form
- Add, delete, move, and size controls
- Change a form’s tab order
- Work with control properties and settings
- Work with form properties and settings
- Use the Control Wizard to create interactive forms
- Create subforms to display information from a one-to-many relationship

Chapter Task: Create and work with several types of forms

A form created in Access is similar to the ordinary paper forms that you fill out with a pen or pencil—only you don’t have to worry about trying to read bad penmanship. In Access, forms provide an easy way to enter and view data in a table. Here are just a few examples of how forms make working with data easier.

- **Easier to View and Use:** Instead of scrolling back and forth in a table’s Datasheet, a form lets you focus on one record at a time.
- **See Data any Way You Want:** You can design forms to present information any way you like.
- **Combine Data from Linked Tables:** One form can display data from several related tables or queries—and your users will never know that they are working with 2 sources!

And that’s just for starters. No doubt about it—forms make your database easier to use. Just like a Windows dialog box (which is really what a form is), Access forms can include fill-in-the-blank fields, check boxes, drop-down lists, and more.

This chapter explains everything you have ever wanted to know about forms—and maybe a few things you didn’t want to know.
Lesson 1-1: Creating a Form with AutoForm

The fastest and easiest way to create a form in Access is with one of the AutoForm Wizards. The AutoForm Wizard automatically creates a form by arranging all the fields from a table or query.

The AutoForm Wizards are fast and easy to use but limited: There are only three AutoForm Wizards and each can only create one type of form, as shown in Table 1-1: Available Form Layouts. Of course, you can always modify a form created by an AutoForm Wizard.

In this lesson you will learn how to create a form using an AutoForm Wizard.

1. **Open the Lesson 8 database.**
   First you need to go to the Forms tab in the Database window.
2. **Click the Forms icon in the Objects bar then click the New button.**
   The New Form dialog box appears, as shown in [Figure 1-1](#). You create a form with the AutoForm Wizard by selecting one of the three AutoForm Wizards...

3. **Select AutoForm: Columnar from the list.**
   … and the table or query you want to use in your form.

4. **Click the Choose the table or query where the object’s data comes from: arrow and select qryCustomers from the list.**
   That’s all the information the AutoForm Wizard needs to create your form.

5. **Click OK to create the columnar form.**
   Access takes all the fields in the qryCustomers query, arranges them, and creates a report similar to the one shown in [Figure 1-2](#).

6. **Close the form without saving your changes.**
   AutoForm Wizards forms aren’t really very pretty to look at but they can give you good start at creating the form you really want since it’s a lot easier to modify an existing form than it is to create one from scratch.

### Table 1-1: Available Form Layouts

<table>
<thead>
<tr>
<th>Form Layout</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Columnar</strong></td>
<td>Only one record is displayed at a time. Data for each record is displayed vertically. Technically speaking, Columnar form’s Default View property is set to Single.</td>
</tr>
<tr>
<td><strong>Tabular</strong></td>
<td>Several records are displayed at once. Data for the records is displayed horizontally. Technically speaking, Columnar form’s Default View property is set to Continuous.</td>
</tr>
<tr>
<td><strong>Datasheet</strong></td>
<td>Displays the records in Datasheet view (several records at the same time). Technically speaking, Columnar form’s Default View property is set to Datasheet.</td>
</tr>
</tbody>
</table>

### Quick Reference

To Create a Form with AutoForm:

1. From the Database window, click the Forms icon in the Objects bar and click the New button.

2. Select one of the following: AutoForm: Columnar AutoForm: Tabular AutoForm: Datasheet.

3. Click the table or query you want to use for the form from the drop-down list.

4. Click OK.
Lesson 1-2: Modifying a Form

After you create a form, you may decide to modify it to add additional features or make it easier to use. For example, you might want to add or delete a field, or change the location of a field on the form. You modify a form in Design View, which you can get to in two different ways:

- **From the database window:** Click the Forms tab to list the forms in the database. Click on the form you want to modify and click the Design button.

- **From a form window:** Click the View button on the toolbar or select **View → Form Design** from the menu.

This lesson will introduce you to Form Design View.

1. **From the Database window**, click the **Forms icon** in the Objects bar if it already isn’t selected, then select the **frmCustomers form** and click the **Design button**.

   The frmCustomers form appears in Design View, as shown in Figure 1-3.

Don’t let Design View scare you. It looks more complicated than it really is. In some ways, Form Design View is similar to many Paint programs. Think of the form as your canvas and the Toolbox and Field List as the paint brushes you use to add fields, text boxes, and buttons to the form.

Any graphic object that appears on forms and reports are called **controls**. A text box used to enter and display information, a text label, and a button you click to print a report would all be examples of controls. You add controls to a form by clicking the control you want to use and then by clicking and dragging it on the form to draw the control.
Chapter One: Working with Forms

Table 1-2: Toolbox Buttons and Controls

<table>
<thead>
<tr>
<th>Toolbox Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Select Objects" /></td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the &lt;Shift&gt; key as you click each control, or drag a rectangle around all controls you want to select.</td>
</tr>
<tr>
<td><img src="image" alt="Control Wizard" /></td>
<td>Click to use Control Wizards when you add controls to your form.</td>
</tr>
<tr>
<td><img src="image" alt="Label" /></td>
<td>Creates a static text label that is the same for every record, such as a heading. Most controls already have a text label attached.</td>
</tr>
<tr>
<td><img src="image" alt="Text Box" /></td>
<td>Creates a text box that displays information from a table and query. You can also use text boxes to enter text.</td>
</tr>
<tr>
<td><img src="image" alt="Option Group" /></td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle Button" /></td>
<td>Creates a toggled button that allows you to display and enter data from a Yes/No field.</td>
</tr>
<tr>
<td><img src="image" alt="Option Button" /></td>
<td>Creates an option button (or radio button) that allows the user to make a single selection from two or more choices. Option Buttons are normally used with a Group Box control.</td>
</tr>
<tr>
<td><img src="image" alt="Check Box" /></td>
<td>Creates a box that is checked or unchecked. Use with to enter data from a Yes/No field.</td>
</tr>
<tr>
<td><img src="image" alt="Combo Box" /></td>
<td>Creates a drop-down box that lets the user enter text or select an item from a list of options.</td>
</tr>
<tr>
<td><img src="image" alt="List Box" /></td>
<td>Creates a box that lets the user select an item from a list of options.</td>
</tr>
<tr>
<td><img src="image" alt="Command Button" /></td>
<td>Creates a button that runs a macro or Visual Basic function.</td>
</tr>
<tr>
<td><img src="image" alt="Image" /></td>
<td>Displays a picture or graphic file that you specify.</td>
</tr>
<tr>
<td><img src="image" alt="Unbound Object Frame" /></td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td><img src="image" alt="Bound Object Frame" /></td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database. Normally used with OLE Object fields.</td>
</tr>
<tr>
<td><img src="image" alt="Page Break" /></td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td><img src="image" alt="Tab Control" /></td>
<td>Enables you to create tabs (like the ones found in some dialog boxes) to include more than one page of controls on the form.</td>
</tr>
<tr>
<td><img src="image" alt="Subform/Subreport" /></td>
<td>Inserts another form within the main form. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td><img src="image" alt="Line" /></td>
<td>Enables you to draw a line.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle" /></td>
<td>Enables you to draw a rectangle.</td>
</tr>
<tr>
<td><img src="image" alt="More Controls" /></td>
<td>Click to display other OLE objects.</td>
</tr>
</tbody>
</table>

Quick Reference

To Modify a Form:
1. From the Database window, click the **Forms** icon in the Objects bar.
2. Click the table you want to modify and click **Design**.
   Or...
   Open the form and click the **View** button on the toolbar.
Lesson 1-3: Adding and Deleting Fields

Once you have created a form, you can delete unnecessary fields or add more fields to display additional information. You add fields to a form by dragging the fields from the Field List onto the form. The Field List lists all the fields from the table or query you used to create the form.

In this lesson you will modify an existing form by adding and deleting fields.

1. Make sure you have the frmCustomers form open in Design View.
   First you click the control you want to delete.
2. Click the **DOB** text box to select it.
   Handles (■) appear around the control, indicating that it is selected.
   
   **NOTE:** Selecting a label will select only the label. Selecting a text box will select both the text box and the corresponding label.

3. Press the <Delete> key to delete the DOB text box.
   Poof! The DOB text box disappears without any fuss.
   So much for deleting fields. Here’s how to add a field:

4. **If the Field List isn’t displayed, click the Field List button on the toolbar.**
   The Field List displays all the fields from the table or query you used to create the form—although you will usually have to scroll down the Field List to find the field that you want. Once the Field List is displayed you can click and drag the field you want to add from the Field List to where you want the field to appear on your form.
   Move on to the next step and add the DOB field you had previously deleted from the form.

5. **Scroll down the Field List until you find the DOB field. Click and drag the DOB field just above the Phone field, as shown in Figure 1-5, then release the mouse button.**
   The DOB field appears above the Phone field, as shown in Figure 1-6. Don’t worry if the DOB field isn’t positioned perfectly—you’ll learn how to move controls in the next lesson.
   See how your form looks in Form view.

6. **Click the View button on the toolbar to display the form in Form view.**
   Compare your form with the one in Figure 1-6.

7. **Click the Save button on the toolbar. Save the form as frmFirstForm.**

---

**Quick Reference**

To Add a Field to a Form:
1. Display the form in **Design view** and click the **Field List button** on the toolbar if necessary.
2. Find the field you want to add to the form in the **Field List**, then click and drag the field to the desired location on the form.

To Delete a Field or Control:
1. Click the field or control to select it.
2. Press <Delete>. 

---

The Richard Stockton College of New Jersey
Lesson 1-4: Moving and Sizing Controls

It's easy to change the location and size of a control on a form. Moving a control allows you to change the order that information appears on the form. When you size a control, you increase or decrease the amount of information the control can display. Once you have selected a control on a form, sizing handles appear around the edges of the control. Now you can drag its sizing handles to adjust the size of the control or move the control to a new location on the form.

This lesson will give you some experience moving and sizing the controls on the form you created in the previous lesson.

1. **Make sure that you have the frmFirstForm form open in Design View.**
   You need to select a control before you can move or size it.

2. **Click the Phone text box to select it.**
   Sizing handles appear around the selected phone field. Here’s how to move a control:

3. **Position the pointer on any border of the Phone text box (but not over a sizing handle) until it changes to a .**
   When the mouse pointer changes to a , it means that you can drag and drop the control to a location.

   **NOTE:** It takes a good deal of precision to position the pointer over the tiny border of a control. Move the pointer very slowly and wait until it turns into a control before you try to move the control.
4. Click and hold down the mouse button while the 🖱️ pointer is still over the border of the Phone text box. Drag the field directly to the left of the FirstName text box and directly above the SSN text box, as shown in Figure 1-7, then release the mouse button.

By simply dragging and dropping with the mouse, you can move any object on a form or report—any shapes, lines, pictures, or text boxes.

Sometimes, you may want to move the object just a smidgen. You can use the keyboard to move or nudge controls with greater precision. To select the control, simply hold down the <Ctrl> key as you press any of the arrow keys on the keyboard.

5. With the Phone field still selected, hold down the <Ctrl> + ← (left arrow) key.

The Phone field moves to the left a smidgen. Go to the next step and try moving the DOB field.

6. Follow the procedure you learned in Step 5 and move the DOB text box directly to the left of the LastName text box and directly above the Phone text box.

Don’t worry if the DOB field isn’t the same size or aligned with the other controls—we’ll fix that in a minute.

Notice that the DOB text box moves with its label control. You can move labels and control, independently of one another by dragging it by their upper-left sizing handle.

7. Position the pointer over the upper-left sizing handle of the DOB label until it changes to a ▶️.

When the mouse pointer changes to a ▶️, it means that you can drag and drop the text box or label independently of one another.

**NOTE:** Most controls have a corresponding label, as shown in Figure 1-8. Make sure that you position the mouse over the DOB label and not the DOB text box.

8. Click and hold down the mouse button while the 🖱️ pointer is still over the upper-left sizing handle of the DOB label. Drag the DOB label so that the DOB label is left-aligned with the Phone label below it.

Enough about moving controls—here’s how to change their size.

When you select a control sizing handles appear around its edge. You can use these sizing handles to change the size and proportions of the selected control. Move on to the next step to see how we can reduce the size of the selected DOB label.

9. With the control still selected, position the pointer over the middle-left sizing handle until it changes to a ▶️. Click and hold down the mouse button and drag down and to the right until the label is the same width as the other labels on the form, then release the mouse button.

As you drag a control’s sizing handle, a dotted outline appears to help you resize it.

10. Click the DOB text box. Follow the procedure you learned in Step 10 and resize the DOB text box so that it is the same width as the other text boxes in the form.

That’s all there is to moving and sizing controls on a form.

11. Click the Save button on the Form Design toolbar to save your changes.
Lesson 1-5: Changing the Tab Order

If you add, remove, or move fields on a form, you’ll want to change the form’s tab order. A form’s tab order determines the order in which you advance from one field to the next when you press <Tab>. The order of the fields when a form is first created determines the initial tab order. Even when you reposition the fields on a form the tab order remains the same. For example, the Tab order shown in Figure 1-9 is from when the form was originally created. Because you have rearranged several controls, the tab order no longer reflects the order in which the fields appear on the form, as shown in Figure 1-10. This isn’t really a big problem, since it’s easy to change the tab order.

To change the tab order for a form select View → Tab Order from the menu. The Tab Order dialog box will appear, as shown in Figure 1-9. From here all you have to do is click and drag the field in the order you want. Or you can click the Auto Order button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.

1. Make sure that you have the frmFirstForm form open.

First let’s see the current tab order of the frmFirst form.

Figure 1-9

The tab order determines the order in which you advance from one field to the next when you press <Tab>.

Figure 1-10

Even when you reposition fields on a form the tab order remains the same.

Figure 1-11

Changing the tab order.
Chapter One: Working with Forms

2. **Switch to Form view by clicking the View button on the Form Design toolbar.**
   
   Go to the next step and see what happens when you try tabbing through the fields on the form.

3. **Press the <Tab> key several times.**
   
   When you press the <Tab> key the cursor jumps from the CustomerID field to the LastName field to the… Phone field? The tab order for the frmFirstForm form was determined when the form was created. You may have moved the Phone name field in the previous lesson, but its position in the tab order hasn’t changed.
   
   You can view and change the tab order by opening the Tab Order dialog box. First you need to be in Design View.

4. **Click the View button on the Form Design toolbar to switch to Design View.**
   
   Here’s how to display the Tab Order dialog box.

5. **Select View → Tab Order from the menu.**
   
   The Tab Order dialog box appears, as shown in Figure 1-9. The order of the fields in the list is the order in which you will advance from one field to the next when you press the <Tab> key. There are a couple of ways to change the tab order. The fast and easy way is to click the Auto Order button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.
   
   **NOTE:** The initial tab order of a form and the Auto Order option both create a tab order from left-to-right, top-to-bottom.

6. **Click the Auto Order button.**
   
   Access looks at the order in which fields appear on the form and adjusts the tab order accordingly.
   
   Sometimes the tab order may not be intuitive for data entry and you may want to manually change it. For example, you may want to modify the tab order so that the address, city, state, and zip code fields are together. Here’s how to manually change a field’s position in the tab order.

7. **Click the City row selector in the Custom Order list.**
   
   Now that you have selected the City row you can change its order by dragging it to a new location in the list.

8. **Drag the City row until it is below the Address row, then release the mouse button, as shown in Figure 1-11.**
   
   Move on to the next step and finish arranging the fields in the tab order.

9. **Drag the State row below the Address row and drag the ZipCode row below the State row.**
   
   You’re finished changing the tab order for the frmFirstForm form.

10. **Click OK to close the Tab Order dialog box.**
    
    Let’s test the new tab order.

11. **Switch to Form view by clicking the View button on the Form Design toolbar.** Press the <Tab> key several times and notice the order in which the cursor moves from field to field.
    
    You’ve finished this lesson so…

12. **Save your changes and then close the frmFirstForm form.**

---

Quick Reference

To Change a Form's Tab Order:

1. Display the form in Design View.
2. Select View → Tab Order from the menu.
3. Click the Auto Order button to automatically reorder the form controls, based on their position in the form.

To Automatically Change the Tab Order:

1. Display the form in Design View.
2. Select View → Tab Order from the menu.
3. Click the Auto Order button to automatically reorder the form controls, based on their position in the form.
Lesson 1-6: Working with Control Properties

Every control on a form—every text box, every label, and every check box—has a set of properties that you can modify. A property is an attribute that defines an object’s appearance, behavior, or characteristics. For example, the properties of a house would be its color, square footage, and shape. A property for a field on a form might be the number of decimal places displayed and the default value for the field. Because you can almost always change an object’s properties, you can think them as the object’s settings.

Different types of controls have different properties. For example, label controls have a Caption property that determines the text that is displayed in the label, while text box controls have a Control Source property that determines which field is displayed in the control. Most controls have several dozen different properties or settings. Fortunately, Access organizes these properties into different categories, as shown in Table 1-3: Tabs in the Properties Dialog Box.

There are several ways to view the properties for any object:

- Right-click the control and select Properties from the shortcut menu.
- Select the control and click the Properties button on the toolbar.
- Select the control and select View → Properties from the menu.

This lesson explains how to view and change a control’s properties.

1. **Open the frmCustomers form in Design View.**

   Here’s one way to view the properties for a control:
2. Select the LastName text box control and display its properties by clicking the Properties button on the Form Design toolbar.

The Properties dialog box appears and displays the properties for the LastName text box control, as shown in Figure 1-12. To change a property simply find and click the appropriate property box and make the changes. Some properties boxes will display one of the following buttons when clicked:

- Click to display a list of options to change the settings for selected property.
- Click to invoke a Wizard or display a dialog box that you use to change the settings for selected property.

Move on to the next step and we’ll try changing one of the LastName text box control’s properties.

3. Click the Format tab if necessary, then find and click in the Back Style box, click its Down Arrow and select Transparent.

The back of the LastName text box control becomes transparent and displays the gray background of the underlying form.

NOTE: Most controls have dozens and dozens of properties and you will often have to click the appropriate tab and then do some scrolling to find the property box that you’re looking for.

The transparent Back Style property of the LastName text box control looks out of place, so let’s change it back.

4. Change the Back Style property of the LastName text box control back to Normal.

Once the Properties dialog box is open you can simply click any control to display its properties—watch…

5. Click the LastName label (NOT the LastName text box.)

The Properties dialog box now displays the properties for the LastName label. You can tell which control’s properties are being displayed by looking at the Title bar of the Properties dialog box.

6. Close the Properties dialog box.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Properties that determine the object’s appearance, such as color, text formatting, line and border color/thickness, and special effects. The purpose of many Formatting properties should be pretty obvious—for example Font Size determines the font size of the control.</td>
</tr>
<tr>
<td>Data</td>
<td>Properties that determine where a control get its data, its default value (if any), and data validation rules for the control.</td>
</tr>
<tr>
<td>Event</td>
<td>Actions to which you can assign a macro or Visual Basic procedure. For example, clicking a button or entering information in a particular field could trigger a macro to run.</td>
</tr>
<tr>
<td>Other</td>
<td>Miscellaneous but important properties, such as the name of the control, if tabbing to the control is allowed, and if a message should appear in the Status bar when the control is selected.</td>
</tr>
<tr>
<td>All</td>
<td>Displays all the properties for the control.</td>
</tr>
</tbody>
</table>
Lesson 1-7: Control Property Reference

Every control on a form or report has dozens of different control properties or settings—so how do you keep them all straight? Here’s how—this lesson is really a cheat sheet that you can use whenever you’re not sure what exactly a particular control property is or does. The more important properties are marked with a ★.

<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption for a form or text label.</td>
</tr>
<tr>
<td>Format ★</td>
<td>Format</td>
<td>Customize the way numbers, dates, times, and text are displayed and printed.</td>
</tr>
<tr>
<td>Decimal Places ★</td>
<td>Format</td>
<td>Determines the number of decimal places displayed.</td>
</tr>
<tr>
<td>Visible ★</td>
<td>Format</td>
<td>Used to show or hide a control. Useful if you want to use information on the form without it being visible. For example, you could use the value in a hidden control as the criteria for a query.</td>
</tr>
<tr>
<td>Display When</td>
<td>Format</td>
<td>Specify if you want a section or control to always appear, or only when it is displayed on-screen or printed.</td>
</tr>
<tr>
<td>Scroll Bars</td>
<td>Format</td>
<td>Determines whether scroll bars appear in the control.</td>
</tr>
<tr>
<td>Left ★</td>
<td>Format</td>
<td>The horizontal position of the control.</td>
</tr>
<tr>
<td>Top ★</td>
<td>Format</td>
<td>The vertical position of the control.</td>
</tr>
<tr>
<td>Width ★</td>
<td>Format</td>
<td>The width of a control.</td>
</tr>
<tr>
<td>Height ★</td>
<td>Format</td>
<td>The height of a control.</td>
</tr>
<tr>
<td>Back Style</td>
<td>Format</td>
<td>Determines whether a control is transparent or not.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Format</td>
<td>Determines the color of a control. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Format</td>
<td>Applies a 3-D effect to a control.</td>
</tr>
<tr>
<td>Border Style</td>
<td>Format</td>
<td>Determines the line style of a control’s border—select from transparent lines, solid lines, dashed lines, etc.</td>
</tr>
<tr>
<td>Border Color</td>
<td>Format</td>
<td>Determines the color of a control’s border. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Border Width</td>
<td>Format</td>
<td>Determines the width of a control’s border (in points).</td>
</tr>
<tr>
<td>Fore Color</td>
<td>Format</td>
<td>Determines the color of text in a control or the fill color of an object. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Format</td>
<td>Determines the font used in a control (such as Arial or Times New Roman.)</td>
</tr>
<tr>
<td>Font Weight</td>
<td>Format</td>
<td>Determines the thickness (boldface) of text in a control.</td>
</tr>
<tr>
<td><strong>Property</strong></td>
<td><strong>Tab</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>----------------------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Font Italic</td>
<td>Format</td>
<td>Specify if you want the text in a control to appear in italics.</td>
</tr>
<tr>
<td>Font Underline</td>
<td>Format</td>
<td>Specify if you want the text in a control to be underlined.</td>
</tr>
<tr>
<td>Alignment</td>
<td>Format</td>
<td>Specify how text should be aligned in a control.</td>
</tr>
<tr>
<td>Control Source</td>
<td>Data</td>
<td>Specify the data that appears in the control.</td>
</tr>
<tr>
<td>Input Mask</td>
<td>Data</td>
<td>Limits the amount and type of information that can be entered in a field, such as ( ___ ) <strong><strong>-</strong></strong>__ for a phone number. Click the button to create an input mask using the Input Mask Wizard.</td>
</tr>
<tr>
<td>Default Value</td>
<td>Data</td>
<td>A value that is automatically entered in this field for new records.</td>
</tr>
<tr>
<td>Validation Rule</td>
<td>Data</td>
<td>Enter an expression that is evaluated when data in the field is added or changed.</td>
</tr>
<tr>
<td>Validation Text</td>
<td>Data</td>
<td>Enter a message that is displayed when data doesn't meet the Validation Rule property.</td>
</tr>
<tr>
<td>Locked</td>
<td>Data</td>
<td>Specify whether changes can be made to a field's data.</td>
</tr>
<tr>
<td>Events Tab</td>
<td>Events</td>
<td>Allow you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Name</td>
<td>Other</td>
<td>The name of the control that identifies it in expressions, macros, and Visual Basic procedures.</td>
</tr>
<tr>
<td>Status Bar Text</td>
<td>Other</td>
<td>Specify a message to display in the Status bar when the control is selected.</td>
</tr>
<tr>
<td>Tab Stop</td>
<td>Other</td>
<td>Specify if you want users to be able to tab to the control.</td>
</tr>
<tr>
<td>Enter Key Behavior</td>
<td>Other</td>
<td>Determines if pressing the &lt;Enter&gt; key adds a new line of text in a control or if it moves to the next field.</td>
</tr>
<tr>
<td>Allow AutoCorrect</td>
<td>Other</td>
<td>Determines if AutoCorrect (i.e. teh → the) is used in a control.</td>
</tr>
<tr>
<td>AutoTab</td>
<td>Other</td>
<td>Used with the Input Mask property. Determines whether an automatic tab to the next field occurs when the last character permitted by a text box control's input mask is entered.</td>
</tr>
<tr>
<td>Tab Stop</td>
<td>Other</td>
<td>Used with the Input Mask property. Determines whether an automatic tab to the next</td>
</tr>
<tr>
<td>Tab Index</td>
<td>Other</td>
<td>Determines the tab order.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specify a user-created shortcut menu that appears when the control is right-clicked.</td>
</tr>
<tr>
<td>ControlTip Message</td>
<td>Other</td>
<td>Specify a brief message that appears when a user points at the control for a couple of seconds.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specify an identifier number for a user-created help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Extra, user-defined information that is stored in the object.</td>
</tr>
</tbody>
</table>
Lesson 1-8: Working with Form Properties

In the previous few lessons, you’ve been learning how to view and change the properties for form controls. In this lesson you will learn how to view and change the properties and settings the form itself. That’s right—just like controls, forms also have their own set of properties that you can view and manipulate. So why would you want to change a form’s properties? Modifying a form’s properties can be especially important if you are creating a database that will be used by novice users. For example, by modifying a form’s properties you can:

- Allow users to edit exiting records in a table or query—but not add any additional records.
- Display one record at a time on each form, or display many records at once.
- Determine the size and location of the form.

To view the properties for a form or report, simply double-click the Form Selector, as shown in Figure 1-13. In this lesson you will learn how to work with a form’s properties.

1. **Open the frmCustomers form in Form View.**
   
   In its current state, the frmCustomers form displays one record one record at a time and has a rather confusing caption in the title bar: frmEmployees. These are form properties that you can change. You must be in Design View in order to view and change a form’s properties.

2. **Click the View button on the toolbar to switch to Design View.**

   To view the properties for a form, double-click the Form Selector, as shown in Figure 1-13. Move on to the next step and try it!

3. **Double-click the Form Selector.**

   Microsoft Access displays the properties for the form. First, let’s give the frmCustomers title bar a more descriptive name.
4. **Click the Format tab if necessary, click in the Caption box and replace its text with Employees.**

   One of the most important form properties is the Default View property, which determines how many records a form can display at once. Let’s take a closer look at this property…

5. **Click the Format tab, click the Default View box and click the Down Arrow.**

   You have three options. They are:
   - **Datasheet**: Displays multiple records in a table, using one line per record. Tables and queries display information in Datasheets.
   - **Single Form**: Displays one record at a time on a form.
   - **Continuous Form**: Displays multiple records on a form. The main difference between a Datasheet and a Continuous Form is Continuous Forms can be customized.

6. **Select Datasheet from the list.**

   That’s enough changes for now.

7. **Close the Properties dialog box.**

   Let’s see how the form looks with its new properties.

8. **Click the View button on the toolbar to display the form in Form View.**

    Access displays the frmEmployees form in Form View. Notice that the form now appears as a Datasheet and has a new caption in the title bar.

9. **Click the frmEmployees form without saving any changes.**

    You’re probably wondering how you are going to get a handle on all these form properties. Don’t worry—you will probably never touch ninety-five percent of them. And when you actually do have to roll up your sleeves and tackle form properties, you’ll find the cheat sheet in the next lesson invaluable.

---

### Quick Reference

<table>
<thead>
<tr>
<th>To View and Change Form Properties:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Display the form in <strong>Design View</strong>.</td>
</tr>
<tr>
<td>2. Double-click the <strong>Form or Report Selector</strong>.</td>
</tr>
<tr>
<td>3. Click the appropriate property tab and property box and make the desired changes.</td>
</tr>
</tbody>
</table>
Lesson 1-9: Form and Report Property Reference

If you thought controls had lots of properties, wait until you see how many properties form and reports have! Here’s another “cheat sheet” that lists the various form properties. Some of the more important properties are marked with a ⭐.

Table 1-5: Important Form Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ⭐</td>
<td>Format</td>
<td>Displays a descriptive caption in the form’s title bar.</td>
</tr>
<tr>
<td>Default View ⭐</td>
<td>Format</td>
<td>Specify the view the form is in when opened.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Single Form:</strong> Displays one record at a time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Continuous Forms:</strong> Displays multiple records in a form.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Datasheet:</strong> Displays multiple records in a Datasheet.</td>
</tr>
<tr>
<td>Views Allowed</td>
<td>Format</td>
<td>Determines the view users can switch to: Form, Datasheet, or Both.</td>
</tr>
<tr>
<td>Scroll Bars ⭐</td>
<td>Format</td>
<td>Determines whether scroll bars appear on the form.</td>
</tr>
<tr>
<td>Record Selectors ⭐</td>
<td>Format</td>
<td>Specify whether a form contains a record selector.</td>
</tr>
<tr>
<td>Navigation Buttons ⭐</td>
<td>Format</td>
<td>Determines whether a form has navigation buttons.</td>
</tr>
<tr>
<td>Dividing Lines</td>
<td>Format</td>
<td>Determines if lines appear between records in continuous forms.</td>
</tr>
<tr>
<td>Auto Resize</td>
<td>Format</td>
<td>Resizes the form automatically to display a complete record.</td>
</tr>
<tr>
<td>Border Style ⭐</td>
<td>Format</td>
<td>Determines the type of window the form appears in: None, Thin, Sizable, or Dialog.</td>
</tr>
<tr>
<td>Control Box</td>
<td>Format</td>
<td>Determines if a control menu appears in the form.</td>
</tr>
<tr>
<td>Min Max Buttons</td>
<td>Format</td>
<td>Determines if minimize and/or maximize buttons appear in the form.</td>
</tr>
<tr>
<td>Close Button</td>
<td>Format</td>
<td>Determines if a close button appears on the form.</td>
</tr>
<tr>
<td>Width ⭐</td>
<td>Format</td>
<td>Determines the width of the form.</td>
</tr>
<tr>
<td>Height ⭐</td>
<td>Format</td>
<td>Determines the height of the form.</td>
</tr>
<tr>
<td>Picture</td>
<td>Format</td>
<td>Adds a graphic or picture for the form or report background. Click the Build button to browse for the folder and file.</td>
</tr>
<tr>
<td>Picture Type</td>
<td>Format</td>
<td>Determines if the picture is embedded or linked.</td>
</tr>
<tr>
<td>Picture Size Mode</td>
<td>Format</td>
<td>Determines how the contents of a picture frame are displayed: Clip, Stretch, or Zoom.</td>
</tr>
<tr>
<td>Picture Alignment</td>
<td>Format</td>
<td>Determines the alignment of a picture within a frame.</td>
</tr>
<tr>
<td>Picture Tiling</td>
<td>Format</td>
<td>Determines whether a picture is tilled within a frame.</td>
</tr>
<tr>
<td>Grid X</td>
<td>Format</td>
<td>Determines the number subdivisions (horizontal) in a grid.</td>
</tr>
<tr>
<td>Grid Y</td>
<td>Format</td>
<td>Determines the number subdivisions (vertical) in a grid.</td>
</tr>
<tr>
<td>Property</td>
<td>Tab</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Layout for Print</td>
<td>Format</td>
<td>Determines whether the form uses printer fonts.</td>
</tr>
<tr>
<td>Palette Source</td>
<td>Format</td>
<td>Specify the path and file name for the graphic file used as a palette.</td>
</tr>
<tr>
<td>Record Source</td>
<td>Data</td>
<td>Specify the table or query whose data you want to use in the form.</td>
</tr>
<tr>
<td>Filter</td>
<td>Data</td>
<td>Specify a filter that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Order By</td>
<td>Data</td>
<td>Specify a sort order that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Allow Filters</td>
<td>Data</td>
<td>Determines whether filters may be applied to the form.</td>
</tr>
<tr>
<td>Allow Edits</td>
<td>Data</td>
<td>Specify whether records can be modified in the form.</td>
</tr>
<tr>
<td>Allow Deletions</td>
<td>Data</td>
<td>Specify whether records can be deleted in the form.</td>
</tr>
<tr>
<td>Allow Additions</td>
<td>Data</td>
<td>Specify whether records can be added in the form.</td>
</tr>
<tr>
<td>Data Entry</td>
<td>Data</td>
<td>Select Yes if you only want to use the form for to add new records.</td>
</tr>
<tr>
<td>Events Tab</td>
<td>Events</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Pop Up</td>
<td>Other</td>
<td>Specify if the form appears in a pop up window that remains on top of all other windows.</td>
</tr>
<tr>
<td>Modal</td>
<td>Other</td>
<td>Specify if the form keeps the focus (you can’t switch to any other windows or forms) until it is closed.</td>
</tr>
<tr>
<td>Cycle</td>
<td></td>
<td>Determines how the tab key should cycle.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>Other</td>
<td>Select a custom Menu Bar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Other</td>
<td>Select a custom Toolbar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Shortcut Menu</td>
<td>Other</td>
<td>Determines if right-mouse button shortcut menus are permitted in the form.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specify a user-created shortcut menu that appears when a user clicks the right-mouse button.</td>
</tr>
<tr>
<td>Fast Laser Printing</td>
<td>Other</td>
<td>Print the form using optimized laser printer formatting.</td>
</tr>
<tr>
<td>Help File</td>
<td>Other</td>
<td>Specify the name of the custom help file for the form.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specify an identifier number for a user-created help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Extra, user-defined information that is stored in the form.</td>
</tr>
<tr>
<td>Has Module</td>
<td>Other</td>
<td>Specify if the form has Visual Basic code behind it.</td>
</tr>
</tbody>
</table>
Lesson 1-10: Working with Multiple Controls

The advantage of selecting multiple controls in a form or report is that you can edit, delete, move, format, or resize a whole bunch of controls at once, instead of having to edit each control individually. In this lesson you will learn how to select multiple controls on a form.

1. **Open the frmCustomers form in Design View.**

   To delete a control you have to select it and press the <Delete> key. Sometimes you will want to delete several controls; instead of selecting and deleting each individual control you can select and delete several controls at the same time. There are several ways to can select more than one control:

   - Press and hold down the <Shift> key as you click each control that you want to select.
   - If necessary, click the Select Object button on the Toolbox toolbar. Then use the arrow pointer ( ) to draw a box around the controls that you want to select, as shown in Figure 1-15. The disadvantage of this method is it’s not as selective as using the <Shift> + click method.
   - If the controls you want to select are aligned along a horizontal line, click to the left of the objects in the vertical ruler to select every control to the right of the ruler.

2. **Hold down the <Shift> key as you click the Smoker and First Class text boxes as shown in Figure 1-14.**

   Handles ( ■ ) appear around the controls, indicating that they are selected.

3. **Press the <Delete> key to delete the selected controls.**

   The Smoker and First Class text box controls are both deleted.
Lesson 1-11: Adding, Cutting, Copying, and Pasting Controls

In this lesson you will learn how to add control by clicking and dragging and by copying and pasting.

1. Click the **Check Box button** on the Toolbox.
   
   **NOTE:** If the Toolbox isn’t displayed, click the **Toolbox button** on the Form Design toolbar.
   
   The mouse pointer changes to a \( \checkmark \), indicating that you can click and drag a check box control on the form.

2. Place the \( \checkmark \) pointer below the **SSN text box**. Click and drag the \( \checkmark \) pointer down and to the right about and release the mouse button, as shown in **Figure 1-16**.
   
   Congratulations! You’ve just added a check box control to your form.
   
   If your form already has a control that’s similar to the one you want to add, it’s often easier to add the new control by copying and pasting the similar control than it is to add a control using the Toolbox. Once you have pasted the control, you can easily modify its properties, such as its text label data source. Here’s how to copy a control.

3. Select the check box control you just added and click the **Copy button** on the Form Design toolbar.
   
   Access copies the selected check box control to the Windows clipboard. You can also cut controls on a form by selecting them and clicking the Cut button on the Form Design toolbar or by pressing \( <\text{Ctrl}> + <\text{X}> \). Now let’s paste the copied control.

4. Click the **Paste button** on the Form Design toolbar.
   
   Access pastes the copied check box onto the form as a new check box with its own name and label. We’ll modify the two new check box controls in the next lesson.
Lesson 1-12: Changing a Control’s Data Source

There are three types of controls that you can add to your forms, as illustrated in Figure 1-17. They are:

- **Bound Controls:** Bound controls are bound or connected to an underlying field in a table or query. You use bound controls to display, enter, and update field values in your database. The fields that you can add to a form using the Field List are all examples of bound controls.

- **Unbound Controls:** Unbound controls are not bound or connected to an underlying field in a table or query. You use unbound controls to display information. Labels, text boxes, and buttons can all be inserted on a form as unbound controls. The two check boxes you added to the form in the previous lessons are both examples of unbound controls, because they aren’t connected to an underlying field in a table or query.

- **Calculated Controls:** Controls that are based on an expression and that are used to calculate values in a form, such as arithmetic problems. Technically speaking, calculated controls are unbound controls because they do not update any table fields.
A control’s *Control Source property* determines what is displayed in a control – here’s how:

- A bound control’s Control Source property contains the name of the underlying database field to which it is bound.
- An unbound control’s Control Source property does not contain the name of an underlying database field.
- A calculated control’s Control Source property contains an expression that calculates the values displayed in the control.

This lesson explains how you can change a control’s Control Source property.

1. **Select the first check box control** you added in the previous lesson, and display its properties by clicking the *Properties button* on the Form Design toolbar.
   The Properties dialog box appears. You can find the Control Source property on the Data Tab.

2. **Click the Data Tab.**
   The Data Tab appears, as shown in Figure 1-18. You can determine what is displayed in the control by setting the Control Source property. You can select bind the control to a field in the form’s underlying query or table by clicking the button, or you can type text or an expression directly into the Control Source box. We want to bind the selected check box to the Smoker field.

3. **Click in the Control Source box, click the button and select Smoker from the list.**
   The check box is now bound to the Smoker field in the tblCustomers table. Next let’s bind the other check box control you added to the First Class field.

4. **With the properties dialog box still open, click the second check box control** you added in the previous lesson.
   The Properties dialog box is updated and displays the settings for the selected check box control.

5. **Click in the Control Source box, click the button and select First Class from the list.**
   You’re done specifying the data sources for the two check boxes, so you can close the Properties dialog box.

6. **Close the Properties dialog box.**
   Before we’re finished, we have to give the two check boxes more meaningful text labels. Here’s how:

7. **Click the first check box control to select it.**
   Once you have selected a control you can change its text label.

8. **Position the pointer over the check box text label, until it changes into a , and then click inside the text label.**
   Now you can edit the check box text label.

9. **Replace the text label text with Smoker.**
   Now move on to the next step and change the text label for the second check box.

10. **Following the same procedures as steps 7-9, rename the second check box text label First Class.**
    That’s it! You’re done binding the check boxes to two underlying database fields.

11. **Save your changes and close the frmCustomer form.**

---

**Quick Reference**

To Change a Control’s Data Source:
1. Display the Form in **Design View**.
2. Select the control and click the **Properties button** on the toolbar.
   Or...
   Right-click the control and select Properties from the shortcut menu.
3. Click the **Data tab**.
4. Click the **Control Source box**, click the arrow and select the field that you want to bind the control to.
   Or...
   Select the control and select **View → Properties** from the menu.
5. Close the Properties dialog box.

---

**Properties button**

Other Ways to View a Control’s Properties:
- Right-click the control and select Properties from the shortcut menu.
- Select the control and select **View → Properties** from the menu.

---

The Richard Stockton College of New Jersey
Lesson 1-13: Creating a Calculated Control

To Create a Calculated Control:
1. Display the Form in Design View.
2. Select the control and click the Properties button on the toolbar.
3. Click the Data tab and click in the Control Source box.
4. Type the expression, using proper Access syntax.
Or...
Click the Build button and use the Expression Builder to create the expression.

A calculated control is an unbound control that displays totals and other arithmetic computations on a form. You create calculated controls by entering an expression (or formula) to perform the calculation in the control’s Control Source property.

In forms, expressions start with the equal sign (=), which tells Access that you want to perform a calculation. After the equal sign, you must specify two more types of information: the values you want to calculate and the arithmetic operator(s) or function name(s) you want to use to calculate the values. Expressions can contain explicit values, such as the numbers 4 or 5 or can reference the values contained in database fields. For example, the formula =Cost*Commission would multiply the values in the Cost and Commissions fields. To enter fields in an expression, type the field name in brackets ([ ]). If a field name exists in more than one table you will need to enter the name of the table that contains the field followed by an exclamation mark (!), such as [Customer Tours].

1. Open the frmTours form in Design View.
   You want the Totals text box to be a calculated control that finds the total cost of each tour by multiplying the Number of Tickets field by the Cost field.
2. Select the Total text box, click the Properties button on the Form Design toolbar and click the Data Tab.
   You need to enter the expression in the Control Source box.
3. Click in the Control Source box and type the expression =Number of Tickets*Cost as shown in Figure 1-22.
   Let’s see how our new calculated control works.
4. Close the Properties dialog box and click the View button on the Form Design toolbar to switch to Form View.
   The Totals field displays the results of the expression you entered in Step 3.
5. Save your changes and close the frmTours form.

Although you worked on a form in this lesson, you can also use expressions to create calculated controls and fields in queries and reports.
Lesson 1-14: Changing a Control’s Default Value

You can enter a Default Value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to “TX”. When a user adds a record using a form, they can either accept the TX default value for the State field or enter their own value.

1. **Open the frmCustomers form in Design View.**
   Since the majority of your customers are from Minnesota you decide to add MN as the default value for the State field.

2. **Click the State field, display its properties by clicking the Properties button on the Form Design toolbar and click the Data tab.**
   Now you can add a default value to the State field.

3. **Click the Default Value box and type MN, as shown in Figure 1-23.**
   Let’s see how the new default value property works.

4. **Close the properties dialog box and click the View button on the Form Design toolbar to switch to Form View.**
   You will need to add a new record in order to see any default values.

5. **Click the New Record button on the Record Navigation bar.**
   Access adds a new blank record to the form. Notice the State field already contains the MN default value. If the customer is from another state you can simply replace the default value with your own data.

6. **Save your changes and close the frmTours form.**

   One more important note about form control properties: Control properties in a form are inherited, or passed down from the original properties in the underlying table or query. So for example, if you set the Default Value property for a table’s State field to TX. The TX Default Value property will be passed on to a related State control on a form by default.
Lesson 1-15: Using the Control Wizard

The Control Wizard (no relation to Merlin) helps you add powerful, interactive controls on your form. Some examples include:

- List and combo box controls that can look up values in a table and then display the corresponding record on a form.
- Buttons that can open, print, or close tables, forms, queries, and reports.
- Subforms, subreports, and charts that display related data from different tables.

When you add a control using the Control Wizard, you are asked a series of questions about what you want the control to do. The Control Wizard then creates the control, making the appropriate property settings and even adding several lines of Visual Basic code to the control for you.

1. **Open the frmCustomers form in Design View.**

To use the Control Wizard, simply make sure that the Control Wizards button on the Toolbox is pressed in, and then add the control. The Control Wizard will appear anytime you try to create a list box, combo box, option group, button, chart, subreport, or subform.
2. Make sure the Control Wizard button on the Toolbox is pressed in. 

The Control Wizard is so incredibly cool and useful that you are strongly recommended to always keep it on.

NOTE: If the Toolbox isn’t displayed, click the Toolbox button on the Form Design toolbar.

First let’s add a combo box control to the form.

3. Click the Combo Box button on the Toolbox.

The mouse pointer changes to a , indicating that you can click and drag a combo box control on the form.

4. Place the pointer in the form header, about one inch to the right of the Customer label. Click and drag the pointer to the right about an inch and release the mouse button.

Because the Control Wizard is on, the Combo Box Wizard dialog box appears, as shown in Figure 1-26. Each type of control will have its own Control Wizard and its own set of options. For this exercise you want to select the third option.

5. Select the Find a record on my form based on the value I selected from my combo box option and click Next.

Next the Control Wizard asks which values you want to add to your combo box control

6. Click the button three times to add the CustomerID, LastName and FirstName fields to the combo box and click Next.

Next the Control Wizard asks how wide you want the columns in your combo box control and if you want to hide the key column. Everything looks OK here so…

7. Click Next.

Finally you are asked to give your combo box a name. You can accept the default name provided by the Control Wizard or you can provide your own name.

8. Type Lookup Name and click Finish.

Poof! The Control Wizard adds the combo box. Next let’s add a command button that will print the current record when clicked.

9. Click the Command Button button on the Toolbox and add a button to the right of the CustomerID text box by clicking and dragging.

Because the Control Wizard is on, the Command Button Wizard appears. Command Buttons have lots of options that you can choose from, broken down by categories.

10. Select Record Operations from the Categories list and select Print Record from the Actions list.

This will make the command button print the current record when clicked.

11. Click Next.

Here you can specify the text or picture that will appear in the button.

12. Click Finish.

Access adds the command button to the form.

13. Click the View button on the Form Design toolbar.

Let’s see how our new controls work.

14. Select a name from the new Lookup Name combo box.

Access finds and displays the record that you select from the combo box.

15. Save your changes and close the frmCustomers form.

Try experimenting and adding controls to your forms using the Control Wizard. You’ll be amazed at how much you can accomplish without knowing any programming!
Chapter One Review

Lesson Summary

Creating a Form with AutoForm

- To Create a Form with AutoForm: From the Database window, click the Forms icon in the Objects bar and click the New button. Select the type of form you want to create: Columnar, Tabular, or Datasheet. Click the table or query you want to use for the form from the drop-down list and Click OK.

Modifying a Form

- To Modify a Form: From the Database window, click the Forms icon in the Objects bar, click the form you want to modify and click Design or open the form and click the View button on the toolbar.

Adding and Deleting Fields

- To Add a Field to a Form: Display the form in Design View and click the Field List button on the toolbar if necessary, find the field you want to add to the form in the Field List, then click and drag the field to the desired location on the form.
- To Delete a Field or Control: Click the field or control to select it and then press <Delete>.

Moving and Sizing Controls

- To Resize an Object: Click the object to select it, grab one of its sizing handles, drag and release the mouse button when the object reaches the desired size. Hold down the <Shift> key while dragging to maintain the object’s proportions while resizing it.
- To Move a Control: Click the control and hold down the mouse button, drag the object to a new location and then release the mouse button to drop the object.
- To Move a Text Box or Text Label Independently of Each Other: Position the pointer over the upper-left sizing handle of the control until it changes to a ‼️, then click and drag the control.

Changing the Tab Order

- To Change a Form’s Tab Order: Display the form in Design View and select View → Tab Order from the menu. Click the row selector for the control you want to move and click and drag the row selector to the desired location. Repeat as needed to change the tab order of additional controls.
- To Automatically Change the Tab Order: Display the form in Design View and select View → Tab Order from the menu. Click the Auto Order button to automatically reorder the form controls, based on their position in the form.
Working with Control Properties

• To Display the Properties for any Control: Display the form in Design View and do any of following:
  - Select the control and click the Properties button on the toolbar.
  - Right-click the control and select Properties from the shortcut menu.
  - Select the control and select View → Properties from the menu.

Working with Form Properties

• To View and Change Form Properties: Display the form in Design View and double-click the Form or Report Selector. Click the appropriate property tab and property box and make the desired changes.

Working with Multiple Controls

• To Select Multiple Controls: Do any of following:
  - Press and hold down the <Shift> key as you click each object that you want to select.
  - User the arrow pointer (▲) to draw a box around the object that you want to select.
  - If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.

Adding, Cutting, Copying, and Pasting Controls

• To Add a Control: Click the Toolbox button on the toolbar if necessary, click the button on the Toolbox for the type of control you want to add, in the Form window, click and drag the pointer where you want the control to appear.

• To Cut a Control: Select the control and:
  - Click the Cut button on the toolbar or…
  - Press <Ctrl>+<X> or…
  - Select Edit → Cut from the menu.

• To Copy a Control: Select the control and:
  - Click the Copy button on the toolbar or…
  - Press <Ctrl>+<C> or…
  - Select Edit → Copy from the menu.

• To Paste a Control: Select the control and:
  - Click the Paste button on the toolbar or…
  - Press <Ctrl>+<V> or…
  - Select Edit → Paste from the menu.

Changing a Control's Data Source

• To Change a Control's Data Source: Display the Form in Design View, select the control and click the Properties button on the toolbar. Click the Data tab, click the Control Source box, click the arrow and select the field that you want to bind the control to or enter an expression. Close the Properties dialog box when you’re finished.

Creating Calculated Controls

• To Create a Calculated Control: Display the form in Design View, select the control and click the Properties button on the toolbar. Click the Data tab and click in the Control Source box, type the expression and then close the Properties dialog box.
Changing a Control’s Default Value

• **To Set a Control’s Default Value:** Display the form in Design View, display the properties for the desired control and click the Data tab. Click the Default Value box and type the default value you want to appear for new records. Close the Properties dialog box when you’re finished.

Using the Control Wizard

• **To Create a List Box or Combo Box:** Display the form in Design View, click the Toolbox button on the toolbar if necessary and make sure the Control Wizard button on the Toolbox is selected. Click the Combo box or List box button on the Toolbox. In the form window, click and drag where you want the control to appear. Specify whether you want the control to get its values from a table or query, or if you want the control to find a record on the form. Select the table that contains the fields you want to include in the list, click Next, select the fields you want to appear in your list and click Next. Adjust the column widths if necessary, click Next, if necessary, specify which column contains the value that will be stored and click Next. Specify whether Access should merely display the value or display it in a field. Enter a label and click Finish.

Quiz

1. **Which of the following statements about the AutoForm Wizard is NOT true?**
   A. The AutoForm Wizard is the fastest and easiest way to create a form in Microsoft Access
   B. The AutoForm Wizard can only create three types of forms: Datasheet, Columnar, or Tabular
   C. Forms created with the AutoForm Wizard usually come out looking sharp and professional and don’t require any further clean-up work
   D. The AutoForm Wizard can only create forms based on a single table or query

2. **Which of the following statements is NOT true?**
   A. The Field List displays all the fields from a form’s underlying table or query
   B. Click the Field List button on the Toolbar to display the Field List
   C. You can add fields to a form by dragging them from the Field List onto the form
   D. The Field List displays all the fields from every table in a database

3. Controls and their corresponding text labels cannot be moved independently of one another (True or False?)

4. If you move a control on a form, the Tab Order, in which you advance from one field to the next when you press the <Tab> key, is automatically updated (True or False?)

5. A form that has a Datasheet Default View property would display one record at a time in the form (True or False?)

6. **A calculated field... (Select all that Apply.)**
   A. ...is a bound control
   B. ...is a control that contains an expression
   C. ...can perform calculations on fields values, such as = [Cost]*[Commission]
   D. ...can perform calculations on explicit values, such as = 2+4
Chapter One: Working with Forms

Homework

1. Open the Homework database.
2. Use AutoForm to create and save a columnar form named Customers, using the Customers table as the underlying data source.
3. Add a label control with today’s date in the bottom-right corner of the Customers form. **Hint:** You will need to change the label control’s data source to the expression =today()
4. Rearrange the control fields on the form, so that the LastName and FirstName fields appear before the SSN field.
5. Change the Customer form’s tab order to reflect the new field order.
6. Delete the DOB field control from the form.

Quiz Answers

1. C. The AutoForm Wizard can create forms in record time, but they aren’t usually well organized or professional looking.
2. D. The Field List only displays fields from a form or form’s underlying table or query.
3. False. You can click and drag the upper-left sizing handle to move a label or control independently of one another.
4. False. If you add or move a control on a form, you would have to change the form’s tab order yourself—Microsoft Access won’t do it for you.
5. False. A form whose Default View property was set to Datasheet would display multiple records. A form whose Default View property was set to Single Form would display one record on the form at a time.
6. B, C, and D. All of these statements are true.
Blank Page
Chapter Two: Working with Reports

Chapter Objectives:

- Create and modify a report
- Add, delete, move, and size controls
- Adjust page margins and orientation
- Add page numbers and dates
- Work with report sections
- Use reports to group and sort records
- Create and work with report sections
- Add a chart to a report.

Chapter Task: Create and modify a variety of reports

It’s easy to print a simple list of records in a table or query—just click the Print button on the toolbar. But if you want your printed hardcopies to look professional, include calculations, graphics, or a customized header or footer, you’ll need to create a report. Reports present information in tables and queries in a format that looks great when printed.

Reports can also summarize and analyze the information in your database. For example, a report might tell you which of your employees had used the most sick days for the past year. Here are just a few examples of how reports work great for presenting information:

- **Attractive Formatting Options:** You can change the type, size, and color of the fonts used in a report to make it easier to read. You can also add lines, boxes, and graphics to your reports.

- **Sorting and Grouping Options:** Reports are great for summarizing and organizing information. For example, you could create a report to total sales by day, week, or month.

- **Combine Data from Linked Tables:** One report can display data from several related tables or queries.

This chapter explains all the ins and outs of creating and working with reports.
Lesson 2-1: Creating a Report with AutoReport

The fastest and easiest way to create a simple report in Access is with the AutoReport Wizard. The AutoReport Wizard can automatically creates a report by arranging all the fields from a table or query into a neatly formatted report.

The AutoReport Wizard is easy to use but limited—it only works with one table or query and there are only two types of reports that it can create, as shown in Figure 2-1. Of course you can always modify a report created by using the AutoReport Wizard.

In this lesson you will learn how to create a report using an AutoReport Wizard.

1. Open the Lesson 9 database.
   First you need to go to the Reports tab in the Database window.
2. **Click the Reports icon in the Objects bar then click the New button.**

The New Report dialog box appears, as shown in Figure 2-1. You create a report with the AutoReport Wizard by selecting one of the two AutoReport Wizards...

3. **Select AutoReport: Tabular from the list.**

…and and the table or query you want to use for your report.

4. **Click the Choose the table or query where the object’s data comes from: arrow and select qryCustomers from the list.**

That’s all the information the AutoReport Wizard needs to create your report.

5. **Click OK to create the tabular report.**

Access takes and arranges all the fields in the qryCustomers query, arranges them, and creates a report similar to the one shown in Figure 2-2. Yuck! Ugly-looking report isn’t it?

6. **Close the report without saving your changes.**

The reports created by the AutoForm Wizards aren’t very pretty to look at but they’re fast and easy to create. If you want to have more control over what appears on your report use the Report Wizard instead. Either way you will probably want to do some clean-up work, such as renaming the report’s column headings and moving/resizing its controls.

<table>
<thead>
<tr>
<th>Table 2-1: Available AutoReport Layouts</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Report Layout</strong></td>
</tr>
<tr>
<td><strong>Columnar</strong></td>
</tr>
<tr>
<td><strong>Tabular</strong></td>
</tr>
</tbody>
</table>

### Quick Reference

**To Create a Report with AutoReport:**

1. From the Database window, click the Forms icon in the Objects bar and click the **New button**.

2. Select one of the following:
   - **AutoForm: Columnar**
   - **AutoForm: Tabular**

3. Click the table or query you want to use for the report from the drop-down list.

4. Click **OK**.
Lesson 2-2: Modifying a Report

After you create a report, from scratch, using the Report Wizard, or using the AutoReport Wizard, you may decide to modify it to make it easier to read and understand. For example, you might want to add or delete a field, change a column heading or change the locations of the fields in the report. You modify a report in Design view, which you can get to from:

- The database window: Click the Reports tab to list the reports in the database. Click on the report you want to modify and click the Design button.
- Any report window: Click the View button on the toolbar or select View → Report Design from the menu.

This lesson will introduce you to Report Design view.

1. From the Database window, click the Reports icon in the Objects bar if it already isn’t selected, then select the rptCustomers form and click the Design button.

The rptCustomers form appears in Design view, as shown in Figure 2-3.

If you have already worked with forms in Design view you should be in somewhat familiar territory—Design view is remarkably similar for both forms and reports. Just as it is with forms, Report Design view is similar to many Paint programs: Think of the report as your canvas and the Toolbox and Field List as the paint brushes you use to add fields, headings, and lines to the report.

Any object that appears on a report is called a control. A text box used to display record information (usually fields from a table or query) or a column heading are both examples of controls. You add controls to a report by clicking the control you want to use and then by clicking and dragging them on the report to draw the control.
Table 2-2: Toolbox Buttons and Controls

<table>
<thead>
<tr>
<th>Toolbox Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Objects</td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the &lt;Shift&gt; key as you click each control, or drag a rectangle shape around all the controls you want to select.</td>
</tr>
<tr>
<td>Control Wizard</td>
<td>Click to use Control Wizards when you add controls to your report.</td>
</tr>
<tr>
<td>Label</td>
<td>Creates a text label that appears the same for every record, such as a heading. Most controls already include a text label.</td>
</tr>
<tr>
<td>Text Box</td>
<td>Creates a text box that displays information from tables and queries in a report.</td>
</tr>
<tr>
<td>Option Group</td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Toggle Button</td>
<td>Creates a toggle button. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Option Button</td>
<td>Creates an option button (or radio button) that display data from two or more options. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Check Box</td>
<td>Creates a box that is empty or contains a checkmark. Use to display data from a Yes/No field.</td>
</tr>
<tr>
<td>Combo Box</td>
<td>Creates a combo box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>List Box</td>
<td>Creates a list box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Command Button</td>
<td>Creates a button that runs a macro or Visual Basic function. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Image</td>
<td>Displays a picture by using a graphic file that you specify.</td>
</tr>
<tr>
<td>Unbound Object Frame</td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td>Bound Object Frame</td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database.</td>
</tr>
<tr>
<td>Page Break</td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td>Tab Control</td>
<td>Creates a tab control. Normally used in forms, not reports.</td>
</tr>
<tr>
<td>Subform/Subreport</td>
<td>Inserts another report within the main report. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td>Line</td>
<td>Enables you to draw a line in the report.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Enables you to draw a rectangle in the report.</td>
</tr>
<tr>
<td>More Controls</td>
<td>Click to display other toolboxes and OLE objects.</td>
</tr>
</tbody>
</table>

Quick Reference

To Modify a Report:

1. From the Database window, click the Forms icon in the Objects bar.
2. Click the report you want to modify and click Design.
   Or...
   Open the report and click the View button on the toolbar.
Lesson 2-3: Adding and Deleting Fields

Once you have created a report, you can delete a field that you don’t need or make a report more comprehensive by adding more fields to display additional information.

In this lesson you will modify an existing report by adding and deleting fields.
1. Make sure you have the rptCustomers report open in Design view. Maximize the report window.
   First you click the control you want to delete.

2. Click the DOB text box to select it.
   Handles (■) appear around the control, indicating that control is selected.

3. Press the <Delete> key to delete the DOB text box.
   The DOB text box disappears from the report screen.
   So much for deleting fields. Unfortunately, adding fields to a report isn’t quite as easy...

4. If the Field List isn’t displayed, click the Field List button on the toolbar.
   The Field List displays all the fields from the table or query you used to create the report—although you will often have to scroll down the Field List to find the field that you want. Once the Field List is displayed you can click and drag the field you want to add from the Field List onto the report.

5. Scroll down the Field List until you find the ZipCode field. Click and drag the ZipCode field to the right of the Phone field, as shown in Figure 2-4, then release the mouse button.
   The ZipCode field appears on the report with less than desirable results, as shown in Figure 2-5. An annoyance with adding controls to a report is that you almost always have to do some clean up work afterwards. For example, the ZipCode field has an unneeded text label, isn’t positioned correctly, and has enlarged the Detail section of the report. Don’t worry about the positioning for now—you’ll learn how to move controls in the next lesson. We can fix some of the other problems, however, starting with getting rid of the text label.

6. Click the ZipCode text label (NOT the actual ZipCode field or text box!) and press <Delete>.
   Before we’re finished, we have to give the ZipCode field a more meaningful text heading. Here’s how:

7. Click the DOB text label to select it.

8. Position the pointer over the check box DOB text label, until it changes into a †, and then click inside the text label.
   Now you can edit the check box text label.

9. Replace the text label text with Zip Code.
   Let’s see how the modified report looks.

10. Click the View button on the toolbar to display the report in Print Preview.
    Compare your report with the one in Figure 2-7.

11. Save your changes by clicking the Save button on the toolbar.

---

Quick Reference

To Add a Field to a Form:
1. Display the report in Design View and click the Field List button on the toolbar if necessary.
2. Find the field you want to add to the form in the Field List, then click and drag the field to the desired location on the report.

To Delete a Field or Control:
1. Click the field or control to select it.
2. Press <Delete>.
Lesson 2-4: Moving and Sizing Controls

It’s easy to change the location and size of a control on a report—and it’s something you will usually have to do whenever you add a control, since Access rarely places things exactly right in the first place. When you size a control, you increase or decrease the amount of information the control can display. When you select a control on a report, sizing handles appear around the edges of the control. Once you have selected a control you can drag its sizing handles to adjust the size of the control or move the control to a new location on the report.

This lesson will give you some experience moving and sizing the controls on the report you created in the previous lesson.

1. **Make sure that you have the rptCustomers report open.**
   You need to be in Design view to modify a report.

2. **If you’re not in Design view, click the View button on the toolbar.**
   You need to select a control before you can move or size it.

3. **Click the ZipCode text box to select it.**
   Sizing handles appear around the selected phone field. Here’s how to move a control:

4. **Position the pointer on any border of the ZipCode text box (but not over a sizing handle) until it changes to a .**
   When the mouse pointer changes to a , it means that you can drag and drop the control to a location.

**NOTE:** It takes a good deal of precision to position the pointer over the tiny border of a field. Move the pointer very slowly and wait until you see it turn into a before you try to move the control.
5. Click and hold down the mouse button while the pointer is still over the border of the ZipCode text box. Drag the field directly to the left of the State text box, as shown in Figure 2-8, then release the mouse button.

By simply dragging and dropping with the mouse, you can move any object on a report—any shapes, lines, pictures, or text boxes.

Sometimes, after moving an object, you’ll find you want to move the object just a smidgen. You can use the keyboard to move or nudge controls with greater precision. Simply hold down the <Ctrl> key as you press any of the arrow keys on the keyboard.

6. With the ZipCode field still selected, hold down the <Ctrl> key and press the ← (left arrow) key.

The ZipCode field moves to the left a smidgen.

7. Make sure the ZipCode text box is still selected. Position the pointer over the middle-left sizing handle until it changes to a →. Click and hold down the mouse button and drag to the right until the label is about two-thirds of its original size then release the mouse button.

As you drag a control’s sizing handle, a dotted outline appears to help you resize it. That’s all there is to moving and sizing controls on a report.

8. Click the Save button on the toolbar to save your changes.

---

**Quick Reference**

To Resize an Object:
- Click the object to select it, grab one of its sizing handles, drag and release the mouse button when the object reaches the desired size.
- Hold down the <Shift> key while dragging to maintain the object’s proportions while resizing it.

To Move an Object:
- Click the object and hold down the mouse button, drag the object to a new location and then release the mouse button to drop the object.

To Copy an Object using Drop and Drag:
- Follow the same procedures as moving an object, only hold down the <Ctrl> key while you drag the object.
Lesson 2-5: Adjusting Page Margins and Orientation

You’re probably already aware that margins are the empty space between the text and the left, right, top, and bottom edges of a printed page. The default margins for a report are 1 inch at the top, bottom, left, and right. There are many reasons to change a report’s margins: To make room for more data, to add some extra space if you’re binding a document, or to leave a blank space to write in notes. If you don’t already know how to adjust a page’s margins, you will after this lesson.

This lesson also explains how to change the page orientation. Everything you print uses one of two different types of paper orientations: Portrait and Landscape. In Portrait orientation, the paper is taller than it is wide—like a painting of a person’s portrait. In Landscape orientation, the paper is wider than it is tall—like a painting of a landscape.

1. Make sure that you have the rptCustomers report open in Design view.

Here’s how to modify the page setup for a report:
2. Click **File → Page Setup** from the menu and click the **Margins tab** if it is not already in front.

   The Margins tab of the Page Setup dialog box appears, as shown in Figure 2-9. Here you can view and adjust the margin sizes for the current worksheet. Notice there are margins settings in the Top, Left, Right, header, and footer boxes.

3. Click the **Top Margin box** and type **0.5**.

   This will change the size of the top margin from 1.0” to 0.5”.

4. Repeat Step 2 and change the **Bottom, Left, and Right margins** to **0.5** inches.

   Do you think you have a handle on changing a report’s margins? Good, because without further ado, we’ll move on to page orientation.

5. Click the **Page tab**.

   The Page tab appears, as shown in Figure 2-11.

6. In the Orientation area, click the **Landscape option button**.

   This will change the worksheet’s orientation to Landscape when it is printed.

7. Click **OK**.

   The Page setup dialog box closes, and the report’s margins and page orientation settings are changed.

   When you change a report’s margins you will usually want to resize the report itself—here’s how:

8. If necessary, scroll to the right edge of the report. Click and drag the right edge of the report to the right to the **7.5 inch mark** on the ruler.

   Let’s see how the newly formatted report looks.

9. Click the **View button** on the Form Design toolbar.

   The report is previewed on the screen. You can reduce or enlarge the display by clicking the report you want to magnify with the **pointer**.

10. Move the **pointer** over an area of the report and click the mouse button.

    Access displays the entire report—and it’s easy to see the new landscape orientation.

11. Save the changes you’ve made to the report.

---

Quick Reference

To Adjust Margins:
1. Select **File → Page Setup** from the menu and click the **Margins tab**.
2. Adjust the appropriate margins.

To Change a Page’s Orientation:
1. Select **File → Page Setup** from the menu, and click the **Page tab**.
2. In the Orientation section, select either the Portrait or Landscape option.
Lesson 2-6: Adding Page Numbers and Dates

Reports that are several pages long often have information such as the page number or the date located at the top (header) or bottom (footer) of every page. In this fast and easy lesson you will learn how to use the Page Number command and Date and Time command to add page numbers and/or the current date to your report.

1. **Make sure that you have the rptCustomers report open in Design view.**
   Here’s how to add page numbering to a report:

2. **Select Insert → Page Number from the menu.**
   The Page Numbers dialog box appears, as shown in Figure 2-13. The Page Numbers dialog box gives you several choices for how you want the page numbers to be formatted:
   - **Page N:** Prints only the page number, for example Page 5.
Chapter Two: Working with Reports

- **Page N of M**: Prints the page number and the total number of pages, for example Page 5 of 15.

3. **Select the Page N of M option.**
   Next you need to specify where on the page you want the page number to appear—at the top or bottom of the page—and how you want the page numbers aligned.

4. **Select the Bottom of Page option and select Right from the Alignment list.**
   That's all there is to adding page numbers to a report.

5. **Click OK to close the Page Numbers dialog box.**
   The Page Numbers dialog box closes and Access adds a text box with a page number expression ("Page " & [Page] & " of " & [Pages]) to the Page Footer.
   So much for add page numbers—here's how to add the date and time to your reports:

6. **Select Insert → Date and Time from the menu.**
   The Date and Time dialog box appears, as shown in Figure 2-14. You can specify to add the date, time, or both to your reports. For this exercise you only want the current date to appear on your report.

7. **Click the Include Time check box to remove its checkmark.**
   Just like the Page Number dialog box, the Date and Time dialog box gives you several choices for how you want the date and/or time to be formatted. The currently selected date format (the first option) will work fine here so you can close the Date and Time dialog box.

8. **Click OK to close the Page Numbers dialog box.**
   The Date and Time dialog box closes and Access adds a text box with a date number expression (=Format(Date(),"Long Date") to the Report Header.
   Microsoft Access isn’t particularly bright and may place the date, time, or page numbers on top of an existing control, as has happened here. To correct the problem you will have to move the new control to a different location on the report.

9. **Click and drag the Date control (=Format(Date(),"Long Date") to the far right side of the report header.**
   Let's see how our modified report looks.

10. **Click the View button on the Form Design toolbar.**
    The report is previewed on the screen and you can see the date and, if you scroll down, the page numbering.

11. **Save the changes you've made to the rptCustomers report.**
Lesson 2-7: Understanding Report Sections

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 2-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word processing program to create a report for school or work you’re familiar with section concept—you can add headers and footers to your documents that contain such information as the report name or page number.

1. **Double-click the rptAnnualSales report to open it in Print Preview.**
   
   A report’s sections aren’t as easy to see in Print Preview, but they’re still there. Let’s examine this report, from top to bottom…
   
   - First notice the “Annual Sales Report” title. In this report the title appears in the **Report Header section**, so it will appear at the top of the first page of the report.
   - Next take a look at the column headings (Tour, Date, etc.). These column headings are in the **Page Header section** and will appear on top of each page.
   - Next come the tour names, which appear in **Group Header section**. You use group header and group footer sections to group related records together. Reports may have more than one group section to create subgroups.
   - Here’s what the report’s all about: the **Details section**. The details section contains the actual records shown in the report.
Chapter Two: Working with Reports

51

The Richard Stockton College of New Jersey

Quick Reference

To Resize a Report Section:
1. Display the report in Design View.
2. Click and drag the Section line up or down.

Understanding Report Sections:
• Be familiar with the various report sections described in Table 2-3: Report Sections.

51

The Richard Stockton College of New Jersey

Quick Reference

To Resize a Report Section:
1. Display the report in Design View.
2. Click and drag the Section line up or down.

Understanding Report Sections:
• Be familiar with the various report sections described in Table 2-3: Report Sections.

51

The Richard Stockton College of New Jersey

Quick Reference

To Resize a Report Section:
1. Display the report in Design View.
2. Click and drag the Section line up or down.

Understanding Report Sections:
• Be familiar with the various report sections described in Table 2-3: Report Sections.
Chapter Two Review

Lesson Summary

Creating a Report with AutoReport

- To Create a Report with AutoReport: From the Database window, click the Forms icon in the Objects bar, click the New button and select one of the either AutoForm: Columnar or AutoForm: Tabular. Click the table or query you want to use for the report from the drop-down list and Click OK.

Modifying a Report

- To Modify a Report: From the Database window, click the Report icon in the Objects bar, click the report you want to modify and click Design or open the form and click the View button on the toolbar.

Adding and Deleting Fields

- To Add a Field to a Form: Display the report in Design View and click the Field List button on the toolbar if necessary, find the field you want to add to the form in the Field List, then click and drag the field to the desired location on the report.

- To Delete a Field or Control: Click the field or control to select it and then press <Delete>.

Moving and Sizing Controls

- To Resize a Control: Click the control to select it, grab one of its sizing handles, drag and release the mouse button when the control reaches the desired size. Hold down the <Shift> key while dragging to maintain the control’s proportions while resizing it.

- To Move a Control: Click the control and hold down the mouse button, drag the object to a new location and then release the mouse button to drop the object.

- To Move a Text Box or Text Label Independently of Each Other: Position the pointer over the upper-left sizing handle of the control until it changes to a , then click and drag the control.

Adjusting PageMargins and Orientation

- To Adjust Margins: Select File → Page Setup from the menu and click the Margins tab, adjust the appropriate margins.

- To Change a Page’s Orientation: Select File → Page Setup from the menu, and click the Page tab, In the Orientation section, select either the Portrait or Landscape option.

Adding Page Numbers and Dates

- To Add Page Numbers: Display the report in Design View, select Insert → Page Number from the menu, select the page format, position, and alignment options, and click OK.
To Insert the Date and/or Time: Display the report in Design View, select Insert → Date and Time from the menu, check or uncheck the Date box and select a formatting option. Check or uncheck the Time box and select a formatting option and click OK.

Understanding Report Sections

To Resize a Report Section: Display the report in Design View, click and drag the Section line up or down.

Quiz

1. Which of the following statements about the AutoReport Wizard is NOT true?
   A. The AutoReport Wizard is the fastest and easiest way to create a report in Microsoft Access
   B. The AutoReport Wizard can only create two types of reports: Columnar and Tabular
   C. Reports created with the AutoReport Wizard usually come out looking sharp and professional and don’t require further clean-up work
   D. The AutoReport Wizard can only create reports based on a single table or query

2. Which of the following statements is NOT true?
   A. The Field List displays all the fields from a report’s underlying table or query
   B. Click the Field List button on the Toolbar to display the Field List
   C. You can add fields to a report by dragging them from the Field List onto the report
   D. The Field List displays all the fields from every table in a database

3. Controls and their corresponding text labels cannot be moved independently of one another (True or False?)

4. Which of the following statements is NOT true?
   A. You can move a control to a different location on a report by clicking, dragging, and dropping the control
   B. To add a page number to a report, select View → Header/Footer from the menu and click the Page Number button on the Header/Footer toolbar
   C. You can resize a report by clicking and dragging the right edge of the report
   D. You can resize a control by clicking the control to select it, grabbing one of its sizing handles, dragging and releasing the mouse button when the control reaches the desired size

Homework

1. Open the Homework database
2. Use AutoReport to create and save a tabular report named Customers, using the Customers table as the underlying data source.
3. Delete the DOB field from the report.
4. Change all report’s margins to a half-inch.
5. Add page numbers and the current date to the bottom of the page.
6. Sort the information on the report by date.

7. Add a calculated control to the Page Footer section that counts the total number of customers.
   **Hint:** You will need to use the COUNT() function in the control’s expression.

8. Save your changes and close the Homework database.

---

**Quiz Answers**

1. C. The AutoReport Wizard can create reports in record time, but they aren’t usually well organized or professional looking.

2. D. The Field List only displays fields from a form or report’s underlying table or query.

3. False. You can click and drag the upper-left sizing handle to move a label or control independently of one another.

4. B. This procedure will let you add page numbers in Microsoft Word but not in Microsoft Access.

5. A. You would want the calculated control in the Month Group Footer section to total monthly sales.

6. C. Although you can summarize information in a report section, there actually a section called a Summary section.

7. False. Although you can sort a report using a query, you can also simply click the Sorting and Grouping button on the toolbar and specify the field you want to use to sort the report.

8. A. This expression is missing the quotation marks (") and the ampersand (&) symbol. The corrected expression would be ="Total for: \\
   \\

9. A. Line charts are used to illustrate trends. If you used the other three chart types to track the stock market, there would be too many data points.
Chapter Three: Formatting Forms and Reports

Chapter Objectives:

- Format fonts using the Formatting toolbar
- Change text alignment
- Use AutoFormat to quickly format forms and reports
- Change the color of text, objects, and borders
- Apply 3-D effects to the controls on forms and reports
- Use the Format Painter to copy control formatting options
- Add pictures and lines to forms and reports
- Align controls with one another
- Format a control by changing its Formatting Properties

Chapter Task: Apply formatting options to existing forms and reports

Forms and reports created with a Microsoft Access Wizard are informative and functional—but they are rarely well designed. Some of the forms and reports set up by the Form Wizard or Report Wizard are even downright ugly. Don’t worry—this chapter will help you fix the design of your forms and reports.

This chapter guides you through the process of creating sharp-looking forms and reports that have colorful fonts, neat-looking borders—even controls with 3-D effects. This chapter explains how to format your form and reports to make them more visually attractive and easier to read. You will learn how to change the appearance, size, and color of fonts and how to align text inside a control. This chapter also describes how you can add pictures and graphics to your forms and reports.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify forms and reports in Design View.
Lesson 3-1: Formatting Fonts with the Formatting Toolbar

You can emphasize text on a form or report by making the text darker and heavier (bold), slanted (italics), larger, or in a different typeface (or font). The Formatting toolbar makes it easy to apply character formatting. The Formatting toolbar includes buttons for applying the most common formatting options.

1. Start Microsoft Access, open the Lesson 9 database, click the Reports icon in the Objects bar and double-click the rptTourSales report.

   Access displays the rptTourSales report in Print Preview. A quick look at this report is all you need to realize that the Report Wizard could use a few remedial graphical design classes. Fortunately a little moving, resizing, and formatting will fix all of the report’s design problems.

2. Click the View button on the Report Design toolbar to switch to Design View.

   In order to format a control you must first select it. The Tour Name text box in the TourName Header needs to stand out a little more from the rest of the report.

3. Click the TourName text box control in the TourName Header to select it.

   Handles (■) appear around the text box control, indicating that the control is selected. Once you have selected a control you can format it.

4. Click the Font list arrow (▼) on the Formatting toolbar, then scroll to and select Arial from the list of fonts.

   The text in the Text Name text box control appears in Arial font. Arial and Times New Roman are two of the most commonly used fonts in Windows.
Chapter Three: Formatting Forms and Reports

You can also use the Formatting toolbar to change the size of a font. Font sizes are measured in points (pt.), which are 1/72 of an inch. The larger the number of points, the larger the font.

5. With the Tour Name text box still selected, click the Font Size list arrow (ﬁ) on the Formatting toolbar and select 14, as shown in Figure 3-2.

The Text Name text box appears in a larger font size (14 point type instead of the previous 11 point type.) Wow! That font formatting really makes the title stand out from the rest of the report, doesn’t it?

NOTE: When you change a control’s font size you will often have to resize the control so that it can properly display its contents.

All the column heading labels in the Page Header section need to be emphasized as well. You could select and format each label individually, but it’s much faster to select and format all of them at the same time. If the controls you want to format are arranged along a horizontal line, you can click to the left of the controls, in the vertical ruler, to select all of them.

6. Select all the labels in the Page Header section by clicking in the Vertical Ruler to the left of the TourName label.

Access selects everything to the right of where you clicked the mouse. Let’s apply boldface formatting to the selected text labels.

7. Click the Bold button on the Formatting toolbar.

The selected controls appear in bold.

8. Click the Save button to save your changes to the report.

Table 3-1: Examples of Common Font Types and Sizes

<table>
<thead>
<tr>
<th>Common Font Types</th>
<th>Common Font Sizes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial</td>
<td>Arial 8 point</td>
</tr>
<tr>
<td>Comic Sans MS</td>
<td>Arial 10 point</td>
</tr>
<tr>
<td>Courier New</td>
<td>Arial 12 point</td>
</tr>
<tr>
<td>Times New Roman</td>
<td>Arial 14 point</td>
</tr>
</tbody>
</table>

Quick Reference

To Change Font Size:
- Select the control and select the pt. size from the Font Size list on the Formatting toolbar.

To Change Font Type:
- Select the control and select the font from the Font Style list on the Formatting toolbar.

To Format Text with Bold, Italics, or Underlining:
- Select the control and click the Bold, Italics, or Underline button on the Formatting toolbar.

The Richard Stockton College of New Jersey
Lesson 3-2: Changing Text Alignment

Figure 3-3
Examples of different alignment options.

Figure 3-4
The Alignment buttons on the toolbar only affect how text is aligned inside a control. You have to manually align a control to the left, center, or right of a form or report by clicking and dragging.

Quick Reference
To Change Text Alignment:
• Select the control and click the Align Left, Center, or Align Right button.

Table 3-2: Alignment Formatting Buttons on the Formatting Toolbar

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align Left</td>
<td>Left</td>
<td>Aligns text to the left side of the control.</td>
</tr>
<tr>
<td>Center</td>
<td>Center</td>
<td>Centers text in a control.</td>
</tr>
<tr>
<td>Align Right</td>
<td>Right</td>
<td>Aligns text to the right side of the control.</td>
</tr>
</tbody>
</table>

This lesson explains how to align a control’s text to the left, center, or right. Figure 3-3 gives a better idea of what the various alignments look like. Alignment only affects what’s inside of a control: If you apply center formatting to a text box, Access will center the text inside the text box—it won’t center the text box control on the form or report. If you want to want to align a control to the left, center, or right of a form or report you’ll have to do it the old-fashioned way—by clicking and dragging the control.

1. Make sure that have the rptTourSales report open in Design View. Again, you first need to select the control you want to format.

2. Select the Date text label in the Page Header and click the Center button on the Formatting toolbar. Access centers the text inside the Date text label. Easy isn’t it? Let’s try aligning one more control.

3. Click the Tour text label in the Page Header and click the Align Right button on the Formatting toolbar. Access right-aligns the text inside the Tour text label.

4. Click the Save button to save your changes to the report.
Lesson 3-3: Using AutoFormat

You’ve just finishing creating a report using the Report Wizard when you suddenly realize that you hate how it looks! Don’t worry, you can apply a new design to your forms and templates at any time with the AutoFormat command. AutoFormat is a built-in collection of formats such as font sizes, patterns, and alignments you can quickly apply to form or report. AutoFormat is a great feature if you want your forms and reports to look sharp and professional but don’t have the time to format them yourself.

1. Make sure that have the rptTourSales report open in Design View.

   Here’s how to format a report using AutoFormat:

2. Click the AutoFormat button on the Formatting toolbar.

   The AutoFormat dialog box appears, as shown in Figure 3-5. The present formats are listed in the AutoFormat list. Yep, they’re the same choices as you get in the Report or Form Wizard. You can see what a format looks like by selecting it and looking at the sample area in the dialog box.

3. Click the Options button.

   The AutoFormat dialog box expands to show three check boxes. You can control the type of formatting that is applied by checking or unchecking any of the boxes. If you want AutoFormat to skip one of the formatting categories, simply uncheck the appropriate box.

4. Select the Corporate option from the AutoFormat format list and click OK.

   The dialog box closes and the report is formatted with the Corporate formatting options.

5. Click the Save button to save your changes and then close the rptTourSales report.
Lesson 3-4: Changing Colors

In this day of color laser and inkjet printers and high-resolution 21-inch monitors, choosing an appropriate color for your report or form is an important formatting decision. If used tastefully, colors can make your forms and reports look more visually attractive. You can add color to lines, text, rectangles—even the background of your headers and footers!

In this lesson, you will learn how to use the color buttons on the Formatting toolbar to apply color to your reports and forms.

1. Click the Forms tab and open the frmCustomers form in Design view.
   There are three color buttons on the Formatting toolbar—each color button applies color to a different element. It can be a little confusing knowing which color button to use at first, so you’ll want to refer to Table 3-3: Color Buttons on the Formatting Toolbar until you get the hang of it.

2. Click the Customers text label in the Form Header, click the Font/Fore Color button arrow on the Formatting toolbar and select a yellow color.
   You can also apply color to the sections of a report or form.

3. Click the Form Header section divider, click the Fill/Back Color button arrow on the Formatting toolbar and select a dark blue color.

<table>
<thead>
<tr>
<th>Color Button</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill/Back Color</td>
<td>Date: 5/1/1992</td>
<td>Applies color to the background of the selected control(s).</td>
</tr>
<tr>
<td>Font/Fore Color</td>
<td>Date: 5/1/1992</td>
<td>Applies color to the text in the selected control(s).</td>
</tr>
<tr>
<td>Line/Border Color</td>
<td>Date: 5/1/1992</td>
<td>Applies a color or makes transparent the line or border of the selected control(s).</td>
</tr>
</tbody>
</table>
Lesson 3-5: Applying Special Effects

You can apply special effect formatting to the controls in your forms and reports to give them a polished, high-tech appearance. For example, you can give a form a three-dimensional look by applying a sunken or raised effect to its controls. Applying special effect formatting is pretty straightforward: Simply select the controls you want to format and then select one of the six special effect options listed in Table 3-4: Available Special Effect Options from the Special Effect button list.

1. Make sure that have the frmCustomers form open in Design view.
   Normally you will want to apply special effect formatting to both a control and its corresponding text label, so you will have to select both controls using one of the multiple selection techniques you’ve (hopefully) learned.

2. Click the CustomerID text box control to select it, then hold down the <Shift> key as you click the CustomerID text label.
   You’re ready to apply a special effect to both controls.

3. Click the Special Effect button arrow on the Formatting toolbar and select the Raised effect.

<table>
<thead>
<tr>
<th>Special Effect</th>
<th>Example</th>
<th>Special Effect</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flat</td>
<td>Date: 5/1/1992</td>
<td>Raised</td>
<td>Date: 5/1/1992</td>
</tr>
<tr>
<td>Sunken</td>
<td>Date: 5/1/1992</td>
<td>Etched</td>
<td>Date: 5/1/1992</td>
</tr>
<tr>
<td>Shadowed</td>
<td>Date: 5/1/1992</td>
<td>Chiseled</td>
<td>Date: 5/1/1992</td>
</tr>
</tbody>
</table>
Lesson 3-6: Using the Format Painter

If you find yourself applying exactly the same formatting to several controls repeatedly, the Format Painter is the tool for you. The Format Painter allows you to copy the formatting attributes from one control and then apply them to another. Sound confusing? It won’t once you have finished this lesson.

1. Make sure that have the frmCustomers form open in Design view.
First you need to select the control whose formatting attributes you want to copy, or else format a control so that you can copy its formatting—and that’s what we’ll do in the next steps.
2. Click the **LastName text box control** to select it.

   We want to format this control so that we can copy its formatting attributes and paste them to other controls on the form.

3. **Click the Font/Fore Color button arrow** on the Formatting toolbar and select a **red** color, then click the **Bold button** on Formatting toolbar, and finally click the **Special Effect button arrow** on the Formatting toolbar and select the **Raised** effect.

   The control is now formatted with red text and a raised effect.

   It took a little of work to apply that formatting, didn’t it? Now imagine you want to format all the controls on the form with the same formatting options. Instead of doing all that formatting you can use the Format Painter tool to copy the formatting from LastName text box control and then paste or apply the copied formatting to the other controls on the form. First, you need to select the control with the formatting you want to copy and then do one of the following:

   - **Single Click the Format Painter Button**: Copy and apply the formatting to a single control.
   - **Double-Click the Format Painter Button**: Copy and apply the formatting to multiple controls. Click the Format Painter button when you’re finished pasting the formatting.

   Since we want to paste the LastName text box control’s formatting to several controls we’ll double-click the Format Painter button.

5. **With the LastName text box control still selected, double-click the Format Painter button on the toolbar.**

   Notice the pointer changes to a 

   Next, you need to paste, or apply the copied formatting.

6. **Click the Phone text box control with the Format Painter.**

   The Format Painter applies the copied formatting to the Phone text box control, saving you some time and work if you had you manually formatted the control. Since we double-clicked the Format Painter the pointer remains a so that we can paste the copied formatting to multiple controls.

7. **Click the FirstName text box control with the Format Painter.**

   When you’re finished with the Format Painter, click the Format Painter button to switch the pointer back to an ordinary selection arrow.

8. **Click the Format Painter button on the Formatting toolbar to stop pasting formatting attributes.**

   You’re finished with this lesson so…

9. Close the **frmCustomers form without saving any of your changes.**
Lesson 3-7: Adding Pictures and Lines

Pictures, graphics, and illustrations can make your reports more professional looking. This lesson explains how to insert clip art and graphics to your reports. You can insert graphics and pictures created with graphics programs such as Microsoft Paint (which comes with Windows), scanned pictures, or graphics from a clip art library.

1. **Make sure that you have the rptCustomers report open in Design view.**
   Here’s how to insert a picture or graphic onto a report (this works for forms too!)

2. **Click the Image button on the Toolbox.**
   The pointer changes to a . You use this pointer to determine where you want to place the image.

---

**Figure 3-9**
Inserting a picture onto a report.

**Figure 3-10**
The Insert Picture dialog box.

Other Ways to Insert a Picture:
- Select Insert → Picture from the menu.
3. Click and drag the \( \text{pointer} \) in the report heading down and to the right about an inch and a half, as shown in Figure 3-9. As soon as you finish clicking and dragging the Insert Picture dialog box appears, as shown in Figure 3-10. You need to specify the name and location of the graphic file you want to insert.

4. **Browse to your Practice folder.**
   All the graphic files located in your practice folder appear in the file window.

5. **Select the **Plane** file.**
   You can display a preview of the graphic in the left side of the Insert Picture dialog box by clicking the list and selecting Preview.

6. **Click the OK to insert the Plane graphic.**
   Access inserts the plane picture on the report.

7. **Click the Line button on the Toolbox.**
   The pointer changes to a line draw tool. Unless you actually want to draw a diagonal line, hold down the \(<\text{Shift}>\) key as you click and drag to draw a straight line.

8. **Position the \( \text{pointer} \) in the far left side of the bottom of the Report Header (just above the Last label).** Click and hold down the \(<\text{Shift}>\) key as you drag the \( \text{pointer} \) to the far right edge of the report.
   More than likely your screen will not be wide enough to display the entire report—don’t worry, simply drag the \( \text{pointer} \) past the right edge of the screen to automatically scroll to the right.
   Let’s see how our report looks.

9. **Click the View button to view the report in Print Preview.**
   Notice the line you added appears not once, but under every record! That’s because you added the line to the reports details section, which prints for every record in the report.
   We’ll learn more about report sections in the next lesson.

10. **Save your changes and close the report.**
    You can also use this technique to add pictures to your forms. Here’s a list of some of the types of graphic formats that you can use in Access:

<table>
<thead>
<tr>
<th>Format</th>
<th>File Size</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BMP</td>
<td>Large</td>
<td>Also known as a bitmap, this is a generic graphics format used by Paintbrush and many other programs.</td>
</tr>
<tr>
<td>CGM</td>
<td>Small</td>
<td>Clip art pictures often come in Computer Graphics Metafile format.</td>
</tr>
<tr>
<td>GIF</td>
<td>Small</td>
<td>Picture file format commonly used on the Internet.</td>
</tr>
<tr>
<td>JPG</td>
<td>Small</td>
<td>Digital photographs are usually saved as JPEG files. Because of its small size JPEG files are also commonly used on the Internet.</td>
</tr>
<tr>
<td>WMF</td>
<td>Small</td>
<td>Another file format used for clip art pictures</td>
</tr>
<tr>
<td>TIF</td>
<td>Large</td>
<td>A file format used by scanners, fax programs, and some drawing programs.</td>
</tr>
</tbody>
</table>

### Quick Reference

**To Insert a Graphic:**
1. Click the Image button on the Toolbox.
2. Move the \( \text{pointer} \) onto the form or report, then click and drag to draw a rectangle placeholder for the graphic.
3. Select the graphic file you want to insert and click OK.

**To Draw a Line:**
1. Click the Line button on the Toolbox.
2. Move the \( \text{pointer} \) onto the form or report, then click and drag to draw the line.
   - Hold down the \(<\text{Shift}>\) key as you drag to draw a straight line.
Lesson 3-8: Aligning Controls with One Another

Forms and reports that have controls scattered randomly about them look terrible. The Align command, located under the Format menu, aligns controls relative to one another. You can align controls so that they are lined up with one another or spaced equally apart from one another. This lesson will give you some practice aligning controls with the Align command.

Select more than one control by holding down the <Shift> key as you click each object.

1. Select the controls you want to align by holding down the <Shift> key as you click each control

2. Select Format → Align from the menu and select an alignment option

The objects are aligned with one another
1. Open the rptEmployeeSales report in Design view.

Someone sure was sloppy when they created this report—its controls are all over the place! You could manually move the controls and align them with one another by using the mouse and eyeballing it—but that would require a lot of time and unless you have eyes like a hawk, it would be difficult to align the controls perfectly. Instead we’ll align the controls using the alignment command.

First you need to select the controls you want to align with one another. There are three ways to select more than one control:

- Press and hold down the <Shift> key as you click each control that you want to select.
- Use the arrow pointer (↑) to draw a box around the controls that you want to select. Point to a location above and to the left of the controls that you want to select, and click and drag the mouse down and to the right until the box surrounds all the controls. When you release the mouse button, all the controls in the box will be selected. The disadvantage of this method is it’s not as selective as using the <Shift> + click method.
- If the controls you want to select are aligned along a horizontal line, click to the left of the object in the vertical ruler to select every control to the right of the ruler.

2. Hold down the <Shift> key as you select the Employee text label and Employee text box control as shown in Figure 3-11.

Now you can align the selected controls with each other. Here’s how:

3. Select Format → Align → Left from the menu.

The Employee text box control is left aligned with the Employee text label.

Next let’s try vertically aligning two controls—the procedure is almost the same.

4. Hold down the <Shift> key as you select the Employee text box control and Date text box control.

Now let’s vertically align the controls with each other.

5. Select Format → Align → Top from the menu.

Access vertically aligns the two controls with each other.

You can also quickly adjust the amount of horizontal or vertical space between controls by selecting the controls and then selecting a command from either the Horizontal Spacing or Vertical Spacing submenu under the Format menu.

Move on to the next step and we’ll adjust the amount of space between the controls on the report.

6. Hold down the <Shift> key as you click the Vertical Ruler to the left of the text labels in the Report Header. Keep holding the <Shift> key and click the Vertical Ruler to the left of the fields in the Details Section.

You’ve selected all the text labels in the Report Header and all the fields in the Details section. Here’s how to adjust the spacing between the selected controls with just a few quick clicks of the mouse.

7. Select Format → Horizontal Spacing → Make Equal from the menu.

Access evenly distributes the selected controls.

8. Click and drag the Page Footer divider up to reduce the amount of empty space in the Details section.

You’re finished!

9. Save your changes and close the form.

Give yourself a pat on the back when you have finished this lesson—probably less than ten percent of all Access users know this fast and easy method of aligning controls.
Lesson 3-9: Changing a Control’s Formatting Properties

The Formatting toolbar is great for quickly applying the most common formatting options to the controls on your forms and reports, but it doesn’t offer every formatting option available. To see and/or use every possible formatting option you need to view the control’s Formatting Properties. Each type of control has its own set of formatting properties—for example, a line control has a Border Style property, which determines if the line should be solid, dashed, or dotted.

To display the Formatting Properties for a control do one of the following:

- Select the control and click the Properties button on the toolbar.
- Right-click the control and select Properties from the shortcut menu.
- Double-click the control.
- Select the control and select View → Properties from the menu.

…and then click the Format tab if necessary. The more common Formatting Properties are listed in Table 3-6: Common Formatting Properties. You might want to review the Working with Tables and Fields chapter as well, which contains information on formatting fields.

This lesson will give you some practice working with a control’s Formatting Properties.

1. **Make sure that you have the rptTourSales report open in Design View.**
   For this exercise we’ll view and change the Formatting Properties of the dark red line in the report’s Page Header.

2. **Click the dark red line in the Page Header to select it, then click the Properties button on the toolbar. Click the Format tab if necessary.**
   The Formatting Properties for the red line appear, as shown in Figure 3-12. There’s not much to an ordinary line, so its Formatting Properties are rather limited. One Formatting Property that we can change is the line’s Border Style property.
3. **Click in the Border Style box** click the arrow and select **Dashes** from the list.
   The line changes from a solid line to a dashed line. Let’s make one more formatting change while the Properties dialog box is still open.

4. **With the red line still selected and the Properties dialog box still open, click the Line/Border Width button arrow** and select **3** from the list.
   The width of the line changes to 3 points. Notice the Border Width property in the Property dialog box also changes to 3 points.

5. **Exit Microsoft Access without saving any of your changes.**

---

**Table 3-6: Common Formatting Properties**

<table>
<thead>
<tr>
<th><strong>Property</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Use to customize the way numbers, dates, times, and text are displayed.</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>Specify the number of decimal places displayed (for numeric values).</td>
</tr>
<tr>
<td>Visible</td>
<td>Used to show or hide a control. Useful if you want to use information on a form without it being visible.</td>
</tr>
<tr>
<td>Hide Duplicates</td>
<td>Use to hide a control on a report when its value is the same as in the preceding record. For example, on a report listing suppliers and their products, each supplier’s name can appear once for each group of products, rather than once for each product.</td>
</tr>
<tr>
<td>Can Grow</td>
<td>Specify if a control on a report can expand vertically when printed to fit text.</td>
</tr>
<tr>
<td>Can Shrink</td>
<td>Specify if a control on a report can shrink vertically when printed to eliminate blank lines.</td>
</tr>
<tr>
<td>Left</td>
<td>The horizontal position of a control.</td>
</tr>
<tr>
<td>Top</td>
<td>The vertical position of a control.</td>
</tr>
<tr>
<td>Width</td>
<td>The width of a control.</td>
</tr>
<tr>
<td>Height</td>
<td>The height of a control.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Determines the color of a control. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Applies the specified 3-D effect to the control.</td>
</tr>
<tr>
<td>Border Style</td>
<td>Determines the line style of a control's border—select from transparent lines, solid lines, dashed lines, etc.</td>
</tr>
<tr>
<td>Border Color</td>
<td>Determines the color of a control's border.</td>
</tr>
<tr>
<td>Border Width</td>
<td>Determines the width of a control's border (in points).</td>
</tr>
<tr>
<td>Fore Color</td>
<td>Determines the color of text in a control or the fill color of a drawing object.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Determines the font used in a control (such as Arial or Times New Roman).</td>
</tr>
<tr>
<td>Font Weight</td>
<td>Determines the thickness (boldface) of text in a control.</td>
</tr>
<tr>
<td>Font Italic</td>
<td>Specify if you want the text in a control to appear in italics.</td>
</tr>
<tr>
<td>Font Underline</td>
<td>Specify if you want the text in a control to be underlined.</td>
</tr>
<tr>
<td>Alignment</td>
<td>Specify how text should be aligned in a control.</td>
</tr>
</tbody>
</table>
Chapter Three Review

Lesson Summary

Formatting Fonts with the Formatting Toolbar

- **To Change Font Size:** Select the control and select the pt. size from the `Font Size list` on the Formatting toolbar.

- **To Change Font Type:** Select the control and select the font from the `Font Style list` on the Formatting toolbar.

- **To Format Text with Bold, Italics, or Underlining:** Select the control and click the `Bold`, `Italics`, or `Underline button` on the Formatting toolbar.

Changing Text Alignment

- **To Change Text Alignment:** Select the control and click the `Align Left`, `Center`, or `Align Right button`.

Using AutoFormat

- **To Format a Form or Report with AutoFormat:** Display the form or report you want to format in Design view, click the `AutoFormat button` on the Formatting toolbar, select one of the AutoFormats from the list and click `OK`.

Changing Colors

- **To Change a Control’s Colors:** Select the control and click of the following buttons on the Formatting toolbar:
  - `Fill/Back Color`
  - `Font/Fore Color`
  - `Line/Border Color`

Applying Special Effects

- **To Apply a Special Effect to a Control:** Select the control, click the `Special Effect button arrow` and select the desired special effect.

Using the Format Painter

- **To Copy Formatting with the Format Painter:** Select the control with the formatting options you want to copy, click the `Format Painter button` on the toolbar, select the control where you want to apply the copied formatting.

- **To Copy Selected Formatting to Several Locations:** Select the control with the formatting options you want to copy, double-click the `Format Painter button`, select the controls where you want to apply the copied formatting. Click the `Format Painter button` when you're finished.
Adding Pictures and Lines

- **To Insert a Graphic:** Click the Image button on the Toolbox, move the pointer onto the form or report, then click and drag to draw a rectangle placeholder for the graphic. Select the graphic file you want to insert and click OK.

- **To Draw a Line:** Click the Line button on the Toolbox, move the pointer onto the form or report, then click and drag to draw the line.

Aligning Controls with One Another

- **To Select Multiple Controls:** Do any of the following:
  - Press and hold down the <Shift> key as you click each object that you want to select.
  - Use the arrow pointer to draw a box around the objects that you want to select.
  - If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.

- **To Align Objects with Each Other:** Follow the above steps to select the objects you want to align then select Format → Align and select an alignment option from the menu.

Changing a Control's Formatting Properties

- **To Format a Control using the Properties Dialog Box:** Display the form in Design View, select the control and click the Properties button on the toolbar, click the Format tab and make the desired formatting changes.

**Quiz**

1. Fonts are measured in points. The larger the number of points, the smaller the size of the font (True or False?)

2. You select a control and then click the Left Align button on the Formatting toolbar. What happens?
   - A. The control is aligned to the far left side of the form or report
   - B. Nothing – the Alignment button on the Formatting toolbar is used to determine the position of the form or report on the screen
   - C. The text inside the control is aligned to the left side of the control
   - D. Nothing – you must also select the control that you want to use to align the selected control with

3. AutoFormat automatically applies formatting options as you type (True or False?)

4. The Fill/Back Color button on the Formatting toolbar applies color to:
   - A. The text in the selected control
   - B. The background of the selected control
   - C. The border of the selected control
   - D. All aspects of the control
5. The Special Effect button on the Formatting toolbar does what?
   A. Applies a 3-D effect to a selected control.
   B. Allows you to select from a transitional effect for how forms open or close.
   C. Lets you add animation to your forms and reports to make them more entertaining and amusing.
   D. None of the above.

6. Which of the following are reasons why you might want to format a control using the Properties dialog box instead of the Formatting toolbar?
   A. You want to show off your Microsoft Access expertise to do things the hard way
   B. The Properties dialog box offers every formatting option available for the control—something the Formatting toolbar doesn’t have.
   C. The Properties dialog box gives you greater control over how a control is formatted.
   D. You can format an object by changing its properties.

**Homework**

1. Open the Homework database and open the Test Answers form in Design View.
2. Use AutoFormat to apply the International present formatting style to the Test Answers form.
3. Change the back color of the Grade field to light yellow.
4. Change the font size of the Grade field to 10 pt.
5. Use the Format Painter tool to copy the formatting from the Grade field and apply it to the two remaining fields on the Test Answers form.
6. Resize the controls as necessary to make room for the new font size.
7. Save the changes to the form.
8. Close the Homework database.

**Quiz Answers**

1. False. It’s true that fonts are measured in points, however the larger the number of points, the larger the size of the font.
2. C. The text inside the control is aligned to the left side of the control.
3. False. AutoFormat lets you quickly format a form or report using a set of predefined formatting options.
4. B. The Back Color button on the Formatting toolbar applies color to the background of a selected control.
5. A. The Special Effect button applies a 3-D effect to a selected control.
6. B and C. The Properties dialog box gives you more control and options over how a control is formatted.