Using the Data Menu in Excel 2000

The Richard Stockton College of New Jersey

This Course Covers:

• How to manipulate lists
• How to analyze data using Excel’s list features

The Richard Stockton College of New Jersey
Computer and Telecommunication Services
PO Box 195
Pomona, NJ 08240
(609) 652-1776
Stockton College Web Site: www.stockton.edu
Computer Services Web Site: compserv.stockton.edu
Table of Contents

Chapter One: Working with Lists ................................................................. 5
  Lesson 1-1: Creating a List ................................................................................ 6
  Lesson 1-2: Using the Data Form to Add Records ........................................... 8
  Lesson 1-3: Finding Records .......................................................................... 10
  Lesson 1-4: Deleting Records ...................................................................... 12
  Lesson 1-5: Sorting a List ........................................................................ 14
  Lesson 1-6: Filtering a List with the AutoFilter ............................................ 16
  Lesson 1-7: Creating a Custom AutoFilter ...................................................... 18
  Lesson 1-8: Filtering a List with an Advanced Filter ...................................... 20
  Lesson 1-9: Copying Filtered Records ........................................................... 22
  Lesson 1-10: Using Data Validation ............................................................... 24
  Chapter One Review ...................................................................................... 26

Chapter Two: Data Analysis and PivotTables ............................................. 31
  Lesson 2-1: Creating a PivotTable ................................................................. 32
  Lesson 2-2: Specifying the Data a PivotTable Analyzes ............................... 34
  Lesson 2-3: Modifying a PivotTable’s Structure ........................................... 36
  Lesson 2-4: Selecting What Appears in a PivotTable .................................... 37
  Lesson 2-5: Grouping Dates in a PivotTable .................................................. 38
  Lesson 2-6: Updating a PivotTable ............................................................... 39
  Lesson 2-7: Formatting and Charting a PivotTable ....................................... 40
  Lesson 2-8: Creating Subtotals ................................................................... 42
  Chapter Two Review .................................................................................... 44
Chapter One: Working with Lists

Chapter Objectives:

- Create a list
- Use the Data Form to add, find, edit, and delete records
- Sort a list
- Use the AutoFilter to filter a list
- Create a custom AutoFilter
- Create and use an advanced filter
- Use data validation when entering records to a list

Chapter Task: Create a list that tracks customers and flights

Another task Excel can perform is keeping track of information in **lists or databases**. Some examples of things you might track in a list include telephone numbers, clients, and employee rosters. Once you create a list in Excel, you can easily find, organize, and analyze its information with Excel’s rich set of list-management features.

In this chapter, you will learn how to create a list, and then add, modify, delete, and find information in it. You’ll also learn how you can use Excel’s filter commands to display specify information, such as records from a specific zip code.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to enter values and labels.
Lesson 1-1: Creating a List

We’ll start this chapter off by creating a list. Lists are organized by records. Each record contains information about a thing or person, just like an individual listing in a phone book. Records are broken up into fields, which store specific pieces of information. For example, the LastName field would contain people’s last names, and the Phone field would contain their phone numbers. In Excel, the columns contain the list’s fields, and the rows contain the list’s records. See Figure 1-2 for an example of how information is stored in columns and rows.

Creating a list in Excel is easy—almost too easy, and people often create lists without planning and thinking about how they will work with the information in the future. Think ahead when you create a list—it’s often difficult to make changes to the structure of the list once there is information in it. [Table 1-1: Guidelines for Creating Lists] for some guidance on creating list.

1. **Start Microsoft Excel.**

The first step in creating a list is entering the field names for the list. Make sure you always put the field names in the first row of the list.

2. **Type First in cell A1 and press the <Tab> key to move to the next cell.**

3. **Type the remaining field names, each in its own cell, as shown in Figure 1-1.**

Don’t worry if the field names are wider than the cells—the information is there, you just can’t see all of it. Move on to the next step to add a couple records to the list.

We’ll start this chapter off by creating a list. Lists are organized by records. Each record contains information about a thing or person, just like an individual listing in a phone book. Records are broken up into fields, which store specific pieces of information. For example, the LastName field would contain people’s last names, and the Phone field would contain their phone numbers. In Excel, the columns contain the list’s fields, and the rows contain the list’s records. See Figure 1-2 for an example of how information is stored in columns and rows.

Creating a list in Excel is easy—almost too easy, and people often create lists without planning and thinking about how they will work with the information in the future. Think ahead when you create a list—it’s often difficult to make changes to the structure of the list once there is information in it. [Table 1-1: Guidelines for Creating Lists] for some guidance on creating list.

1. **Start Microsoft Excel.**

The first step in creating a list is entering the field names for the list. Make sure you always put the field names in the first row of the list.

2. **Type First in cell A1 and press the <Tab> key to move to the next cell.**

3. **Type the remaining field names, each in its own cell, as shown in Figure 1-1.**

Don’t worry if the field names are wider than the cells—the information is there, you just can’t see all of it. Move on to the next step to add a couple records to the list.
4. Enter the information from Figure 1-2 in the second and third rows. Add an apostrophe (') before you type the Zip Codes (i.e. '55701).

The apostrophe enters the Zip Code as a label instead of a value. If you didn’t add an apostrophe, Excel would remove the leading zeros (0) from any Zip Codes beginning (0), such as 01586.

That’s all there is to creating a list. There are, however a few things you can do to the list to make working with it a little easier. First, make the field headings stand out more by making them bold.

5. Select the cell range A1:H1 and click the **Bold button** on the Formatting toolbar.

When working with lists (especially longer ones) it is usually also a good idea to split and freeze the worksheet window so the field headings always remain visible when you move through the rest of the worksheet.

6. Move the pointer over the **vertical split box**, located at the top of the vertical scroll bar. When the pointer changes to a †, drag the split box down directly beneath **row 1**, Excel splits the worksheet window vertically into two separate panes.

7. Select **Window → Freeze Panes** from the menu.

The frozen heading row will always be visible at the top of the worksheet, even if the list contains thousands of records.

---

### Table 1-1: Guidelines for Creating Lists

<table>
<thead>
<tr>
<th>Guideline</th>
<th>Why?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Only have one list on a worksheet</td>
<td>Some list management features, such as filtering, can be used on only one list at a time.</td>
</tr>
<tr>
<td>Leave at least one blank column and one blank row between the list and other data on the worksheet.</td>
<td>Excel can then more easily detect and select the list when you sort, filter, or insert automatic subtotals.</td>
</tr>
<tr>
<td>Avoid putting blank rows and columns in the list.</td>
<td>So that Microsoft Excel can more easily detect and select the list.</td>
</tr>
<tr>
<td>Create column labels in the first row of the list.</td>
<td>Excel uses the labels to create reports and to find and organize data.</td>
</tr>
<tr>
<td>Design the list so that all rows have similar items in the same column.</td>
<td>This makes the list more meaningful and organized.</td>
</tr>
<tr>
<td>Try to break up information as much as possible.</td>
<td>This gives you more power to sort, filter and manipulate the list.</td>
</tr>
<tr>
<td>Each column should contain the same type of information.</td>
<td>This will make the list easier to read and understand.</td>
</tr>
<tr>
<td>Don’t use duplicate field names.</td>
<td>Duplicate field names can cause problems when entering and sorting information.</td>
</tr>
</tbody>
</table>
Lesson 1-2: Using the Data Form to Add Records

There are two ways to add records to a list: we already covered the first method in the previous lesson—simply by entering them to the rows in the list range. Once you have entered the field names for a list, another way to add records to a list is with Excel’s Data Form dialog box, which you can find under the Data → Form menu. Actually, the Data Form can do a lot of things, including:

- Adding records
- Displaying and scrolling through records
- Editing existing records
- Deleting records
- Finding specific records

This lesson focuses on using the Data Form to display and add records to the current list—we’ll cover some of the other topics in the next few lessons.

1. **Make sure the active cell is located somewhere inside the list (the cell range A1:H3).**
   The active cell must be within the list in order to use the Data Form.

2. **Select Data → Form from the menu.**
   The Data Form dialog box appears, with the first record in the list, John Peters, displayed, as shown in Figure 1-3. One of the benefits of the Data Form is it makes it easy to display and navigate through the various records in a list.
3. **Click the **Find Next** button to move to the next record in the list.**
   The next record in the list, Mary Smith, appears in the Data Form.

4. **Click the **Find Prev** button to move to the previous record in the list.**
   The previous record, John Peters, appears in the Data Form. You can also use the Data Form to add new records.

5. **Click the **New** button.**
   A blank data form appears. Notice the text “New Record” appears where the record number counter was, indicating you are adding a new record to the list. The insertion point appears in the first field of the Data Form.

6. **Type Susan in the Last box and press <Tab> to move the insertion point to the next field.**
   Go ahead and enter the rest of the information for this record, as shown in the next step.

7. **Enter the rest of the information for Susan Ratcliff in the fields as follows:**
   - **First:** Susan
   - **Last:** Ratcliff
   - **Address:** Rt. 8, Box 109
   - **City:** Duluth
   - **State:** MN
   - **Zip:** 55801
   - **Annual Trips:** 4
   - **Income:** $40,000
   Press <Tab> after each entry to move to the next field. Go on to the next step when you’ve finished.

8. **Click the **New** button to open another blank Data Form, and enter a record for Harold Williams using the following information:**
   - **First:** Harold
   - **Last:** Williams
   - **Address:** 55 Sugar Lane
   - **City:** Duluth
   - **State:** MN
   - **Zip:** 55701
   - **Annual Trips:** 2
   - **Income:** $25,000

9. **Click **Close** when you have finished entering the information for Harold Williams.**
   The Data Form dialog box closes. Notice the records you added are placed at the end of the list.

10. **Save your worksheet as **List Practice** and then close it.**
Lesson 1-3: Finding Records

A task you will undoubtedly want to do if you work with a list is look up or find a specific record or records, such as a record for a particular client. Like so many other procedures in Excel, there are two different ways to search for records in your lists:

- Using the Edit → Find Command
- Using the Data Form dialog box

This lesson examines both methods; plus you’ll also learn how you can find and replace information. For example, if you misspell a city’s name throughout a list, you can use the Find and Replace command to replace every occurrence of the incorrect spelling with the correct spelling.

1. Open the workbook named Lesson 7 and save it as Database List.
   One method of finding a specific record in a list is to use the Data Form.

2. Make sure the active cell is located inside the list and select Data → Form from the menu.
   The Data Form appears, as shown in Figure 1-4.

3. Click the Criteria button.
   A blank data form appears. Notice the text Criteria appears where the record number counter was, indicating you are working with a Criteria Data Form. To use the Criteria Data Form, simply type what you want to look for in the appropriate fields and click the Find Next button.
4. **Click the State field**, type WI and **click Find Next**.
   The Data Form displays the first record it finds in the list that is from WI.

5. **Click Find Next to move to the next record that matches the WI criteria.**
   The Data Form moves to the next record from WI.

6. **Click Close.**
   You can also find information in a list using Excel’s standard Find function, located under Edit → Find. You can also find and replace information. You discover a mistake in the list: the Zip Codes for Chekov, MN 55411 should be 55414. Use Replace to fix the mistake.

7. **Select Edit → Replace from the menu.**
   The Replace dialog box appears, as shown in Figure 1-6. Enter the incorrect Zip Code you want to replace—55411, and the Zip Code you want to replace it with—55414.

8. **In the Find what box**, type 55411, then click the Replace with box and type 55414.
   Now you can replace all the incorrect Zip Codes with the correct Zip Codes.

9. **Click Replace All.**
   The Replace dialog box closes, and all of the 55411 Zip Code are changed to 55414.

   **NOTE:** Think before using the Replace All button—you might not want it to replace every instance of a word or value! You can find and replace each individual occurrence of a word, phrase, or value by clicking Find Next and then Replace.

10. **Save your work.**

---

**Quick Reference**

**To Find Records using the Data Form:**
1. Make sure the active cell is located inside the list and select Data → Form from the menu.
2. Click the Criteria button, enter the information you want to search for in the appropriate fields, and click either the Find Next or Find Prev button.

**To Find Records using the Edit → Find Command:**
1. Select Edit → Find from the menu.
2. Enter the information you want to search for and click the Find Next button.

**To Find and Replace Information:**
1. Select Edit → Replace from the menu.
2. Enter the text you want to search for in the Find what box, and enter the text you want to replace it with in the Replace with box.
3. Click Replace All to search and replace every occurrence of the text or click the Find Next button to verify each replacement.

---

**Other Ways to Find:**
- Press <Ctrl> + <F>.

**Other Ways to Replace:**
- Press <Ctrl> + <H>.
Lesson 1-4: Deleting Records

Deleting records is another basic list or database skill you need to know. For example, if you used a list to track membership, you keep the list up-to-date by deleting people that are no longer members. There are two ways to delete records:

• By using the Data Form dialog box.
• By deleting the row the record is stored in.

This lesson will give you some practice using each method.

1. Make sure the active cell is located inside the list and select Data → Form from the menu.

   You need to delete the record for Nancy Pauls. First, you need to find her record.

2. Click the Criteria button.

   The Criteria Data Form appears.

3. In the First field box type Nancy, click the Last field box, type Pauls, and click the Find Next button.

   The record for Nancy Pauls appears in the Data Form.

4. Click the Delete button.

   A dialog box appears, asking you to confirm the deletion, as shown in Figure 1-8.

5. Click OK to confirm the deletion of the record.

   The record for Nancy Pauls is deleted, and the next record, Peter Boggins, appears in the data form.

6. Click Close to return to the worksheet.

   Notice that there are no blank rows where the previously deleted records were. When you delete a record using the Data Form dialog box, Excel automatically moves the following rows up to replace the deleted record.

   You can also delete records by deleting the record’s row.

---

**Figure 1-7**
You can easily delete selected records in the Data Form dialog box.

**Figure 1-8**
Excel asks you to confirm a record deletion.
7. Right-click the **Row 12 Heading** and select **Delete** from the shortcut menu.

   The entire row is deleted, and the remaining rows move up to replace the deleted row.

You’re doing great! Believe it or not, you’ve already made it halfway through the chapter and are well on your way to learning everything there is to know about lists.

---

**Quick Reference**

To Delete a Record:

1. Make sure the active cell is located inside the list and select **Data → Form** from the menu.
2. Find the record you want to delete using the **Find Next, Find Prev**, or **Criteria** buttons.
3. Click **Delete** and confirm the deletion of the record.

Or...

- Delete the record’s rows or cells.
Lesson 1-5: Sorting a List

Normally, when you enter new records to a list, you add them to the end of the list, in the order you receive them. That's fine, but what if you want the list's records to appear in alphabetical order? Another of Excel's useful functions is its ability to sort information. Excel can sort records alphabetically, numerically, or chronologically (by date.) Additionally, Excel can sort information in ascending (A to Z) or descending (Z to A) order. You can sort an entire list or any portion of a list by selecting it. This lesson will show you several techniques you can use to sort information in your lists.

1. Click cell B1 to make it active.
   You want to sort the list by the last name, so you have selected the Last field.
2. Click the Sort Ascending button on the Standard toolbar.
   Excel sorts this list, ordering the records in ascending (A-Z) order by last name, as shown in Figure 1-10. You can also sort a list in descending (Z-A) order.
3. Click cell A1 to make it active, then click the **Sort Descending button** on the Standard toolbar.
   The list is sorted in descending (Z-A) order by the First field.
   So far, you have sorted the list by a single field. You can sort lists by up to three fields by using the Sort dialog box found under Data → Sort.

4. **Select Data → Sort** from the menu.
   The Sort dialog box appears, as shown in Figure 1-11. You want to sort the list by the last name and then by the first name.

5. **Select Last from the Sort by list arrow** and make sure the **Ascending option** is selected.
   The list will be sorted in ascending order (A-Z) by the last name. Next, specify the second field you want to sort the list by.

6. **Click the first Then by arrow**, select First, and make sure the **Ascending option** is selected.
   You’re ready to sort the list.

7. **Click OK**.
   The Sort dialog box closes and the list is sorted in ascending order, first by the last names, and then by first names.

8. **Save your work**.
   The information you sorted in this lesson was in a list, but you can use the same sorting techniques to sort information anywhere in a worksheet, whether it is in a list or not.

---

### Table 1-2: Sort Examples

<table>
<thead>
<tr>
<th>Order</th>
<th>Alphabetic</th>
<th>Numeric</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ascending</td>
<td>A, B, C</td>
<td>1, 2, 3</td>
<td>1/1/99, 1/15/99, 2/1/99</td>
</tr>
<tr>
<td>Descending</td>
<td>C, B, A</td>
<td>3, 2, 1</td>
<td>2/1/99, 1/15/99, 1/1/99</td>
</tr>
</tbody>
</table>

---

📖 **Quick Reference**

**To Sort a List by One Field:**

1. Move the cell pointer to the column you want to use to sort the list.
2. Click either the **Sort Ascending button** or **Sort Descending button** on the Standard toolbar.

**To Sort a List by More than One Field:**

1. Make sure the cell pointer is located within the list and select **Data → Sort** from the menu.
2. Select the first field you want to sort by from the drop-down list and specify Ascending or Descending order.
3. Repeat **Step 2** for the second and third fields you want to sort by (if desired).
Lesson 1-6: Filtering a List with the AutoFilter

Sometimes you may want to see only certain records in your lists. By filtering a list, you display only the records that meet your criteria, and hide the records that do not. For example, you could filter a client list to display only clients who live in California. There are several ways to filter your lists. In this lesson, you will learn how to use the fastest and easiest way to filter a list with Excel’s nifty AutoFilter feature.

1. **Select Data → Filter → AutoFilter from the menu.**
   List arrows appear to the right of each of the field names.

2. **Click the City list arrow.**
   An AutoFilter list containing all the cities in the column appears beneath the City field.
3. **Select Duluth from the AutoFilter list.**

Excel filters the list so that only records that contain Duluth in the City field are displayed, as shown in Figure 1-13. Notice the status bar indicates the number of records that matched the filter (5 of 17) and that the AutoFilter list arrow for the City field changes colors, indicating it is filtering the worksheet. You can filter a list by more than one field at a time.

4. **Click the Annual Trips list arrow and select 2 from the AutoFilter list.**

Excel narrows the filter so that only those records that contain *Duluth* in the City field and 2 in the Annual Trips field are displayed. Notice that the colors of the AutoFilter list arrows for both the City field and Annual Trip field are different colors, indicating they are filtering the worksheet. Here’s how to remove the current filter criteria and display all the records.

5. **Select Data → Filter → Show All from the menu.**

All the records are displayed. You can also completely remove an AutoFilter.

6. **Select Data → Filter → AutoFilter from the menu to deselect it.**

The AutoFilter is turned off, all the records are listed, and the AutoFilter arrows disappear from the right of the field headings.

The following table describes those other confusing items that appear in a field’s AutoFilter list.

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(All)</td>
<td>Display all rows.</td>
</tr>
<tr>
<td>(Top 10...)</td>
<td>Display all rows that fall within the upper or lower limits you specify, either by item or percentage; for example, the amounts within the top 10 percent of income.</td>
</tr>
<tr>
<td>(Custom...)</td>
<td>Apply two criteria values within the current column, or use comparison operators other than AND (the default operator). See the next lesson for more information on this option.</td>
</tr>
<tr>
<td>(Blanks)</td>
<td>Display only rows that contain a blank cell in the column.</td>
</tr>
<tr>
<td>(NonBlanks)</td>
<td>Display only rows that contain a value in the column.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

**To Filter a List with AutoFilter:**

1. Move the cell pointer anywhere within the list and select **Data → Filter → AutoFilter** from the menu.
2. Click one of the drop-down arrows in the field names of the header row and select an item you want to use to filter the list.

**To Remove an AutoFilter:**

- Select **Data → Filter → AutoFilter** from the menu.
Lesson 1-7: Creating a Custom AutoFilter

In the previous lesson, you learned how to use the AutoFilter feature to filter records by selecting a single value for one or more columns. When you need to filter using more complicated criteria, you have to use a Custom AutoFilter. Custom AutoFilters are more difficult to setup and create than ordinary AutoFilters, but they’re much more flexible and powerful. Custom AutoFilter can filter records based on more than one value, such as clients in a list that live in California or Oregon and can filter records based on ranges, such as clients with an income greater than $40,000.

This lesson explains how to create and use a Custom AutoFilter. First, though, we need to cover one more ordinary AutoFilter topic—how to use the Top 10 option:

1. **Select Data → Filter → AutoFilter** from the menu.
   Lists arrows appear to the right of each of the field names. You can use AutoFilter to filter records with the highest (top) or lowest (bottom) values in a list.

2. **Click the Income list arrow** and select *(Top 10…)* from the AutoFilter list.
   The Top 10 AutoFilter dialog box appears, as shown in [Figure 1-14](#).

3. **Replace the 10 in the middle box with a 5 and click OK**.
   The records for the clients with the highest five incomes is displayed. Now that you know which clients have the highest incomes, you can remove the filter.

4. **Click the Income list arrow** and select *(All)* from the AutoFilter list.
   The filter is removed and all the records are displayed.

5. **Click the City list arrow** and select *(Custom…)* from the AutoFilter list.
   The Custom AutoFilter dialog box appears, as shown in [Figure 1-15](#).

---

**Figure 1-14**
The Top 10 AutoFilter dialog box.

**Figure 1-15**
The Custom AutoFilter dialog box.
6. **Make sure the equal sign appears in the City list, then click the top comparison list arrow and select Duluth.**
   In the next step, you’ll specify that you also want to filter any records from Two Harbors as well.

7. **Click the Or option, click the bottom City list arrow and select equals, click the bottom comparison list arrow and select Two Harbors.**
   The custom AutoFilter will now display records in which the City field equals Duluth or Two Harbors. This type of search criteria is called a *Logical Condition*. You could also specify the logical condition criteria in a way so that only records from Duluth *and* that have incomes greater than $30,000 are filtered.

8. **Click OK.**
   The dialog box closes, and only the records from the city of Duluth or Two Harbors are displayed.

9. **Select Data → Filter → AutoFilter from the menu to deselect it.**
   The AutoFilter is turned off and all the records are displayed.

Custom AutoFilters are much more flexible and powerful than ordinary AutoFilters, but they still have some limitations. For example, you can’t filter lists based on more than two values (such as clients from California, Oregon, or Washington.) For really complicated filtering tasks, you’ll need to use an *advanced filter*, which is covered in the next lesson.

---

### Quick Reference

**To Use a Custom AutoFilter:**

1. Move the cell pointer anywhere within the list and select Data → Filter → AutoFilter from the menu.
2. Click one of the drop-down arrows in the field names of the header row and select Custom from the list.
3. Specify your filter criteria in the Custom AutoFilter dialog box.
Lesson 1-8: Filtering a List with an Advanced Filter

Advanced filtering is by far the most powerful and flexible way to filter your lists. It’s also by far the most difficult method, and requires a lot of work to setup and use. Advanced Filters do have several capabilities their simpler AutoFilter cousins lack, including:

- **More complex filtering criteria**: You can filter a list based on as many values in as many columns as you want.
- **The ability to extract the filtered records**: Once you have created an Advanced Filter, you can copy the filtered records to a new location. This is the main reason most people use Advanced Filters.

To create an Advanced Filter you must start by defining a criteria range. A criteria range is a cell range, located at the top of your list, which contains the filter criteria. Figure 1-16 shows an example of a worksheet with a criteria range.

1. **Select rows 1 through 4**, right-click any of the selected row number headings and select Insert from the shortcut menu.

Excel inserts 4 blank rows above the list. These blank rows will be the Criteria Range—the cell range that contains a set of search conditions you will use in your advanced filter. The next step in creating an Advanced Filter is to copy the column labels from the list you want to filter.

2. **Select the cell range A5:H5**, click the Copy button on the Standard toolbar, click cell A1, and click the Paste button on the Standard toolbar to paste the copied cells.

Next, you need to specify the criteria for the advanced filter. You want to display only those clients with incomes greater than $30,000 and that have taken more than 5 trips or those clients that have taken more than 7 trips.
3. Click cell G2, type >5, click cell H2, type >30000, and press <Enter>.
   This will filter clients that have taken more than 5 annual trips and have incomes
greater than $30,000. Next, you want to add a logical condition so that any clients who
have taken more than 7 annual trips are also selected, regardless of their income.

4. Type >7 in cell G3 and press <Enter>.
   Compare your worksheet to the one in Figure 1-16. You’re ready to filter the data.
   
   NOTE: Make sure there is always only blank row between the criteria values and the
   list. Having more than one blank row or no blank row at all will cause your
   Advanced filter not to work!

5. Click any of the cells in the list range and select Data → Filter →
   Advanced Filter from the menu.
   The Advanced Filter dialog box appears, as shown in Figure 1-17. Since you opened
   the Advanced Filter with the active cell in the list, the list range is already selected. You
   still have to specify what the criteria range is, however.

6. Click the Criteria range box and select the Criteria range—A1:A3.
   You’re ready to apply the advanced filter.
   
   NOTE: Make sure you don’t select the blank row between the criteria range and the
   list range, or the Advanced Filter won’t work!

7. Verify that the Filter the list, in-place option is selected and click OK.
   The list range is filtered to match the criteria you specified in the criteria range. Notice
   the Status bar displays how many records were found. You remove Advanced Filters
   just the same as AutoFilters.

8. Select Data → Filter → Show All from the menu.
   All the records are again displayed.

### Table 1-1: Comparison operators and Wildcards

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
</tbody>
</table>
| *       | Wildcard--any number of characters in the same position as the asterisk
| Example: | "east finds "Northeast" and "Southeast"
| ?       | Any single character in the same position as the question mark.
| Example: | "smith" finds "sm?th" and "smyth" |
Lesson 1-9: Copying Filtered Records

When you filter a list, you may want to copy or extract the records that meet your search criteria. You must use an Advanced Filter to copy filtered records to a new location. (Microsoft really should have let you to copy filtered records with the much simpler AutoFilter as well, but they didn’t so there’s no use complaining about it.)

1. **Clear the current criteria in the Criteria Range by selecting the cell range G2:H3 and pressing the <Delete> key.**
   Since you will only need one row for your criteria you’ll need to delete one of the rows in the criteria range.

2. **Right-click the Row 2 heading and select Delete from the shortcut menu.**
   Next you need to enter a new set of search criteria. This time you want to find and then extract all the records that are in the 55701 zip code.

3. **Click cell F2, type 55701 and press <Enter>.**
   You’re ready to filter the list, only this time instead of filtering the list in-place, you want to copy the filtered records to a new location in the workbook.

4. **Click any cell in the list range (A5:H27) and select Data → Filter → Advanced Filter from the menu.**
   The Advanced Filter dialog box appears, as shown in Figure 1-18. This time, instead of Filtering the list in place you want to copy it to a new location in the worksheet.
5. **Verify the List Range and Criteria Range match what is shown in Figure 1-18** then select the **Copy to another location** option in the Action section.

   The last step in extracting the records from the 55701 zip code is to specify where you want to paste the filtered records.

6. **Click the Copy to box and click cell J5.**

   This is where the filtered records—those that meet the 55701 zip code criteria you specified in the Advanced Filter—will be copied.

   **NOTE:** You can only copy filtered records to the same worksheet when you use the Advanced Filter copy to new location option. If you want to copy the filtered records to a different sheet in the workbook, or to a different workbook altogether, you have to: 1) Copy the filtered records to a location on the current sheet, and 2) Either cut or copy the filtered records to the desired location in a different worksheet or workbook.

7. **Click OK.**

   The Advanced Filter dialog box closes and Excel copies the records that meet the search criteria with the 55701 zip code to the new location.

8. **Save your work.**

   You deserve a medal if you’ve made it through the last couple lessons in one piece. Creating and working with advanced Filters are one of the most difficult procedures you can perform in Excel.

---

**Quick Reference**

**To Copy or Extract Filtered Records:**

1. Your worksheet should have at least three blank rows that can be used as a criteria range above the list.

2. Copy the column labels from the list and paste them in the first blank row of the criteria range.

3. In the rows below the criteria labels, type the criteria you want to match. Make sure there is at least one blank row between the criteria values and the list.

4. Select **Data → Filter → Advanced Filter** from the menu.

5. In the Advanced Filter dialog box, specify the list range and the criteria range.

6. Select the **Copy to another location** option.

7. Select **Copy to** box, select the cell where you want to copy the filtered records and click **OK**.
Lesson 1-10: Using Data Validation

You can help users enter accurate and appropriate information into your worksheets with Excel’s Data Validation feature. Data validation restricts the type of information that can be entered in a cell and can provide the user with instructions on entering information in a cell.

1. Click cell I5 to select it, click the Bold button and the Center button on the Formatting toolbar, type Purpose, and press <Enter>.

You have just entered a new field heading for your list.

2. Click the Column I header to select the entire column.

You want to restrict any entries to the Purpose field to a list of specific options.
3. Select **Data → Validation** from the menu and click the **Settings tab** if necessary.
   
   The Data Validation dialog box appears, as shown in [Figure 1-20](#). You want to provide the user with a list of entries they can select from for the Purpose.

4. **Click the Allow list arrow**, select **List**, then click the **Source box** and type **Business, Pleasure, Other, Not Stated**, as shown in [Figure 1-20](#). Make sure the **In-cell dropdown checkbox** is checked to display the list of valid entries whenever a cell in the Purpose column is selected.
   
   You’re ready to test your data validation rules.

5. **Click OK**, then click cell I6.
   
   Notice a dropdown list arrow appears to the right of the cell.

6. **Click the dropdown list arrow and select Pleasure from the list.**
   
   Excel enters the Pleasure option from the list. Move on to the next step to see what happens if you type an invalid entry.

7. **Make sure cell I6 is selected, type Unknown, and press <Enter>.**
   
   A warning dialog box appears, preventing you from entering invalid information.
   
   A list is just one way of validating data—there are many other ways to restrict data entry. In the next step, you will use the Validation feature to verify that entries made to the State column use two-digit state abbreviations.

8. **Click the Column E column header to select the entire column, then select Data → Validation from the menu.**
   
   The Data Validation dialog box appears. You must specify that any entries in the selected cells must contain no more or no less than two digits.

9. **Click the Allow list arrow, select Text Length, click the Minimum textbox and type 2, and then click the Maximum textbox and type 2.**
   
   You can also use the Data Validation dialog box to provide a user filling out your form with help information or feedback.

10. **Click the Input Message tab.**
    
    The Input Message tab appears, as shown in [Figure 1-21](#).

11. **Click the Input Message textbox, type Enter the client’s state of residence and click OK.**
    
    The dialog closes. Test out the data validation options for the state column.

12. **Click cell E6.**
    
    The message “Enter the client’s state of residence” you entered in the Data Validation dialog box appears next to the cell, as shown in [Figure 1-23](#).

13. **Save your work and exit Excel.**

---

**Quick Reference**

To Use Data Validation:

1. Select the cell or cell range you want to validate.
2. Select **Data → Validation** from the menu.
3. Click one or more of the three tabs and change the necessary settings.

**Setting**: Specify the type of data the cell will accept.

**Input Message**: Specify a message to appear when the cell is selected.

**Error Alert**: Specify a message that appears if invalid data is entered.
Chapter One Review

Lesson Summary

Creating a List
- To Create a List in Excel: Enter the field names as column headers and records as rows.

Using the Data Form to Add Records
- To Add Records to a List Using the Data Form: Make sure the active cell is located somewhere in the list and select Data → Form from the menu. Click New and enter the information for the record in the appropriate text boxes.

Finding Records
- To Find Records using the Data Form: Make sure the active cell is located inside the list and select Data → Form from the menu. Click the Criteria button, enter the information you want to search for in the appropriate fields, and click either the Find Next or Find Prev button.
- To Find Records using the Edit → Find Command: Select Edit → Find from the menu. Enter the information you want to search for and click the Find Next button.
- To Find and Replace Information: Select Edit → Replace from the menu. Enter the text you want to search for in the Find what box, and enter the text you want to replace it with in the Replace with box. Click Replace All to search and replace every occurrence of the text or click the Find Next.

Deleting Records
- To Delete a Record with the Data Form: Make sure the active cell is located inside the list and select Data → Form from the menu. Find the record you want to delete using the Find Next, Find Prev, or Criteria buttons, click Delete and confirm the deletion of the record.
- To Delete a Record Directly in the Worksheet: Delete the record’s rows or cells.

Sorting a List
- To Sort a List by One Field: Move the cell pointer to the column you want to use to sort the list and click either the Sort Ascending button or Sort Descending button on the Standard toolbar.
- To Sort a List by More than One Field: Make sure the cell pointer is located within the list and select Data → Sort from the menu. Select the first field you want to sort by from the drop-down list and specify Ascending or Descending order. Select the second and third fields you want to sort by (if desired).

Filtering a List with the AutoFilter
- AutoFilter displays only the records that meet your criteria, and hides the records that do not.
To Filter a List with AutoFilter: Move the cell pointer anywhere within the list, select Data → Filter → AutoFilter from the menu, and select the filter criteria from the drop-down arrows in the field names of the header row.

To Remove an AutoFilter: Select Data → Filter → AutoFilter from the menu.

Creating a Custom AutoFilter

A Custom AutoFilter allows you to filter records based on more than one value or a range.

To Use a Custom AutoFilter: Move the cell pointer anywhere within the list and select Data → Filter → AutoFilter from the menu, click one of the drop-down arrows in the field names of the header row and select Custom from the list. Specify your filter criteria in the Custom AutoFilter dialog box.

Filtering a List with an Advanced Filter

Advanced filters are difficult to setup, but they enable you to filter a list based on as many values in as many columns as you want and copy the filtered records to a new location.

To Create an Advanced Filter: Your worksheet should have at least three blank rows that can be used as a criteria range above the list. Copy the column labels from the list and paste them in the first blank row of the criteria range. In the rows below the criteria labels, type the criteria you want to match (make sure there is at least one blank row between the criteria values and the list). Select Data → Filter → Advanced Filter from the menu, specify the list range and the criteria range, make sure the Filter the list, in-place option is selected and click OK.

Copying Filtered Records

To Copy or Extract Filtered Records: Setup an Advanced Filter and enter the filter criteria. Select Data → Filter → Advanced Filter from the menu and specify the list range and the criteria range. Select the Copy to another location option, select Copy to box, select the cell where you want to copy the filtered records, and click OK.

Using Data Validation

Data Validation restricts the type of information that is entered in a cell and provides the user with feedback and instructions.

To Use Data Validation: Select the cell or cell range you want to validate and select Data → Validation from the menu. Click any or all of the tabs (Settings, Input Messages, and Error Alert) and change the settings.

Quiz

1. Which of the following statements is NOT true?
   A. To create a list, you need to enter the field names in the first row.
   B. Each record in a list is stored in a column.
   C. Selecting Data → Form from the menu opens the Data Form dialog box, which you can use to add, modify, find, and delete list records.
   D. You can add a new record to the database by entering the data as a new row in the worksheet, or by selecting Data → Form from the menu, clicking the New button, and filling out the New Record form.
2. How can you find specific information in a list? (Select all that apply).
   A. Click the Find button on the Standard toolbar.
   B. Select Edit → Find from the menu.
   C. Select Tools → Finder from the menu.
   D. Select Data → Form from the menu to open the Data Form dialog box and click the Criteria button.

3. How can delete a record? (Select all that apply).
   A. Select Data → Form from the menu to open the Data Form dialog box, find the record and click the Delete button.
   B. Click the Delete button on the Standard toolbar.
   C. Delete the cells or row that contain the record from the worksheet.
   D. Select Data → Delete Record from the menu.

4. Which of the following statements is NOT true?
   A. You can quickly sort a list by placing the cell pointer in the column/field you want to sort by and clicking either the Sort Ascending or Sort Descending button on the Standard toolbar.
   B. You can sort by up to three fields at a time by selecting Data → Sort from the menu.
   C. To display only records that meet your criteria, select Data → AutoFilter from the menu.
   D. To display only records that meet your criteria, click the AutoFilter button on the Standard toolbar.

5. You can extract filtered records from a Custom AutoFilter. (True or False?)

6. Which of the following is NOT a step in creating an Advanced filter?
   A. Add a criteria range above the list. Make sure it contains the list’s column labels.
   B. Add the criteria to the criteria range. Make sure you leave a blank row between the criteria range and the list.
   C. Select Data → Filter from the menu and specify the list and criteria ranges.
   D. Select the data you want to use to filter the list by using the field’s drop-down lists.

7. Which of the following statements is NOT true?
   A. You must protect the worksheet in order to use Excel’s data validation feature.
   B. Data Validation lets you restrict which type of information is entered in a cell.
   C. You can provide users with information and feedback using Data Validation.
   D. To use Data Validation, select Data → Validation from the menu.

Homework

1. Open the Lesson 11A workbook and save it as “Sales Data”.
2. Use the AutoFilter to display only records that are from the Minneapolis office.

3. Display all the records, then use the AutoFilter to display the top 10 total amounts.

4. Use the Data Form to add a new record with the following information:
   Date: 5/3/2000  Last: Schmidt  First: Jamie  Office: St. Paul
   Destination: New York  Amount: $700  Tickets: 1  Commission: Yes

5. Sort the list alphabetically by destination.

6. In the cells in row 2 use Excel’s Data Validation feature to enter helpful Input Messages, such as “Enter your last name” and “Enter the travel agent’s office”. Try selecting the cells when you’re finished and see if your Input Messages appear.

**Quiz Answers**

1. B. Records in a list are stored in rows, not columns.

2. B and D. You can find information in a list by selecting Edit → Find from the menu or by selecting Data → Form from the menu to open the Data Form dialog box and click the Criteria button.

3. A and C. You can delete a record by selecting Data → Form from the menu to open the Data Form dialog box, find the record and click the Delete button. You can also delete a record by deleting the cells or row that contain the record from the worksheet.

4. D. There isn’t an AutoFilter button on the Standard toolbar (although it would make a nice addition.)

5. False. You can only extract filtered records from an Advanced filter.

6. D. You specify the criteria for an Advanced filter in the criteria range—so there’s no need to select the criteria from drop-down lists.

7. A. You don’t have to protect a worksheet to use data validation.
Chapter Two: Data Analysis and PivotTables

Chapter Objectives:

- Create a PivotTable
- Change or “Pivot” a PivotTable
- Use the Page Field to filter what data is displayed in a PivotTable
- How to group information in a PivotTable by date
- Create and work with subtotals
- Use Database functions (DSUM)
- Use Lookup functions (VLOOKUP)
- Group and outline a worksheet

Chapter Task: Analyze ticket sales

Once you have created a list, there are many ways to analyze its data. You should already know some basic ways to analyze information, such as filtering records. This chapter explains more advanced and powerful methods of analyzing list information.

Creating a PivotTable feature is usually the best way to summarize and analyze list data—which is why we’ll spend more than half of the chapter discussing it. A PivotTable is a way to summarize list information. Peek at Figure 2-1 and Figure 2-2 on the next page to see how much easier it is to make sense of numbers in a list with a PivotTable. This chapter explains the ins and outs of PivotTables—how to create them, modify their structure, and edit the data a PivotTable is based on.

This chapter also includes lessons on several other ways to summarize and analyze worksheet information, such as how use Excel’s subtotal function, how to create database-specific formulas, and how to outline your worksheets.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- Create and work with a list.
- How to enter formulas.
Lesson 2-1: Creating a PivotTable

Creating a PivotTable is remarkably easy. You create PivotTables using the PivotTable Wizard, which asks which fields you want to include in the PivotTable, how you want your PivotTable organized, and which types of calculations your PivotTable should perform. PivotTables may sound confusing, but they will make a lot more sense when you’ve actually created one.
1. Open the workbook named Lesson 11A and save it as PivotTable.
   This workbook contains figures for ticket sales from a recent promotion. The list contains flight dates, agents, offices which sold the tickets, destinations, sales amounts, and if the agents received a commission or not. It's difficult to see the bottom line in a large list like this. For example, how many tickets did the Blaine office sell or how many tickets were sold to London? The PivotTable Wizard can help you summarize the list and provide you with meaningful information.

2. Make sure the cell pointer is located in the list (A1:I200) and select Data → PivotTable and PivotChart Report from the menu.
   The First Step of the PivotTable Wizard dialog box appears. Here you must specify the location of the data you want to use in your PivotTable. There are four options:
   - Microsoft Excel list or database: Creates a PivotTable from data in columns on your worksheet (the most commonly used option.)
   - External data source: Creates a PivotTable from data stored in a file or database outside of the current workbook or Microsoft Excel.
   - Multiple consolidation ranges: Creates one PivotTable from multiple cell ranges in different worksheets.
   - Another PivotTable: Creates a PivotTable from another PivotTable in the same workbook.
   You also have to specify if you want to create a PivotTable Report or a PivotTable Report along with a corresponding PivotChart report.

3. Verify that the Microsoft Excel list or database and the PivotTable options are both selected and click Next.
   Step Two of the PivotTable Wizard appears. You need to tell the PivotTable Wizard where the data you want to use in the PivotTable is located. Because the cell pointer was located inside the list when you started the PivotTable Wizard, the cell range of the list (A1:I200) is already selected.

4. Click Next.
   The third and last step of the PivotTable Wizard appears, as shown in Figure 2-4. Here’s where you tell Excel to put your PivotTable report. You can place your PivotTable report in:
   - A new worksheet
   - Embedded in an existing worksheet.

5. Verify that the New worksheet option is selected and click Finish.
   The PivotTable Wizard dialog box closes and the PivotTable appears on a new worksheet, as shown in Figure 2-5. Notice the PivotTable is empty—that’s because we haven’t specified the data we want to analyze yet—something you’ll learn in the next lesson.

Quick Reference

To Create a PivotTable:
1. Make sure the cell pointer is located in the list.
2. Select Data → PivotTable and PivotChart Report from the menu.
3. Select the location of the data you want to include in your PivotTable report and the type of report (PivotTable report or PivotTable with PivotChart report) and click Next.
4. In Step 2 make sure the list range is selected and click Next.
5. In Step 3, specify a location for the PivotTable (a new worksheet or an existing worksheet.)
6. Click Finish.
Lesson 2-2: Specifying the Data a PivotTable Analyzes

Once you’ve created your PivotTable report, you have to specify the data you want to analyze with the PivotTable. It’s easy to specify which data you want to analyze—simply drag it from the PivotTable toolbar and onto the Row, Column, or Data area on the PivotTable report. You’re not going to understand how to do this unless you try it—so let’s get started!

1. Drag the **Destination field button** from the PivotTable toolbar to the **ROW area of the PivotTable diagram**.
   The Destination field appears at the top of the ROW area in the PivotTable. Next, make the Office field the column heading for the PivotTable.

2. Drag the **Office field button** from the PivotTable toolbar to the **COLUMN area of the PivotTable diagram**, as shown in **Figure 2-6**.
   You have selected the Destination field to be the row heading and the Office field to be the column heading for your PivotTable. Now you need to select the field you want to summarize.

3. Drag the **Number of Tickets field button** from the PivotTable toolbar to the **DATA area of the PivotTable diagram**.
   Compare your dialog box with the one shown in **Figure 2-7**.
The neat thing about PivotTables is that their information is *dynamic*. What this means is once you’ve created a PivotTable, you can rearrange or “pivot” it to view its data in different ways. For example, you could rearrange the PivotTable you just created so that it summarizes the amount of the total ticket sales instead of the total number of tickets sold.

4. **Drag the Sum of Tickets field button** (located in cell A3) off the PivotTable diagram.
   The PivotTable will no longer total the number of tickets sold. You can easily summarize another field by dragging it onto the DATA area of the PivotTable diagram.

5. **Drag the Total field button** to the DATA area of the PivotTable diagram.
   You also rearrange a PivotTable’s headings.

6. **Drag the Destination field button** from the ROW area of the PivotTable diagram to the COLUMN area and drag the Office field button from the ROW area of the PivotTable diagram to the COLUMN area.
   Hopefully, you’re starting to understand the true power of PivotTables. PivotTables can usually make information stored in even the longest lists easy to understand. And once you make a PivotTable you can change the information it summarized in an instant, simply by dropping and dragging.

---

**Quick Reference**

To Create a PivotTable:

1. Make sure the cell pointer is located in the list.
2. Select *Data → Pivot Table Report* from the menu.
3. Select either the Microsoft Excel List or Database option and click Next.
4. In Step 2, make sure the list range is selected and click Next.
5. In Step 3, drag the field names you want to summarize to the appropriate section of the PivotTable diagram (Page, Column, Row, or Data) and click Next.
6. In Step 4, specify a location for the PivotTable (a new worksheet or an existing worksheet.)
7. (Optional) Click the Options button to specify any additional options for the PivotTable.
8. Click Finish.
Lesson 2-3: Modifying a PivotTable’s Structure

Quick Reference
To Change the Calculation Used in a PivotTable:
1. Make sure the cell pointer is located in the PivotTable and click the PivotTable Field button on the PivotTable toolbar.
2. Select the calculation you want to use from the Summarize by list and click OK.

1. Click cell B3 and select Window → Freeze Panes from the menu.
   Now the column and row headings to the left and above the active cell (B3) will always be visible as you scroll through the worksheet.
2. Scroll down to row 22.
   The PivotTable has created column totals, which calculates the total number of reservations made at each office.
3. Scroll to the U column.
   The PivotTable has also calculated the total number of reservations made to each destination.
4. Click the PivotTable Field button on the PivotTable toolbar.
   The PivotTable Field dialog box appears, as shown in Figure 2-8. The PivotTable Field dialog box lets you change how a PivotTable is calculated. For example, instead of totaling the ticket sales made, you could find the average:
5. Select Average from the Summarize by list and click OK.
   The PivotTable Field dialog box closes and the PivotTable displays the average ticket sales.

In the previous lesson, you learned how to change the data you want included in the PivotTable report. You can also change how a PivotTable summarizes its information. For example, you might want a PivotTable to display averages instead of totals.
Lesson 2-4: Selecting What Appears in a PivotTable

You can filter which information is summarized in a PivotTable by clicking a row or column field’s drop-down arrows and selecting the items you want to include in the PivotTable report or by adding a page field to the PivotTable. In this lesson, you’ll learn how to filter the information that is included in a PivotTable Report using both methods.

1. Click the Office field drop-down list located in cell A4.

   A drop-down list appears beneath the Office field, as shown in Figure 2-12. You can select which values appear in your PivotTable report by making sure they are checked and remove values by removing their checkmark.

2. Remove the checkmark from the Bloomington, Brainerd, Brooklyn Center, and Duluth boxes.

   The Bloomington, Brainerd, Brooklyn Center, and Duluth offices no longer appear in the PivotTable report. You can also filter the information that appears in a PivotTable report by adding a Page Field to the PivotTable.

3. Drag the Commission field button to the PAGE area of the PivotTable diagram.

   Now you will be able to filter the PivotTable using the commission field and display data for sales with commissions, sales without commissions, or both.

4. Click the Commission list arrow, located in cell B1 and select Yes.

   The PivotTable displays only information for commissioned sales.

---

Quick Reference

To Add a Page Field to a PivotTable:

1. Make sure the cell pointer is located in the PivotTable and click the PivotTable Wizard button on the PivotTable toolbar.

2. Drag the field name you want to use to filter the PivotTable to the Page Field area of a PivotTable report.

To Filter a PivotTable’s Summary Information:

- Select what you’d like to see on the PivotTable report from the Row heading, Column heading, or Page Field drop-down list.
Lesson 2-5: Grouping Dates in a PivotTable

PivotTables can usually summarize information without any outside help from you. When you want to summarize a list by dates, however, you will probably need to coach Excel and tell it how you want to group the information in the PivotTable: by days, months, quarters, or years. In this lesson, we’ll rearrange our PivotTable and summarize its information by month. First, you need to rearrange your PivotTable to summarize it by date.

1. Drag the Office field button off the PivotTable diagram and drag the Destination field button from the Column area of the PivotTable to the Row area.

Next, you need to add the Date field to the PivotTable’s Column area.

2. Drag the Date field button to the Column area of the PivotTable.

Now the PivotTable summarizes ticket sales by destination and date as shown in Figure 2-15. The only problem is that the PivotTable summarizes the dates by day—making the summary information rather meaningless. You can make the PivotTable more useful by grouping the days into months using the Group command. First you need to specify what information you want to group by—the dates.

3. Click the Date button located in cell B3 then select Data → Group and Outline → Group from the menu.

The Grouping dialog box appears, as shown in Figure 2-16. You need to select a date or time interval to group by.

4. Select Months from the By list and click OK.

The Group dialog box closes and the PivotTable groups the dates by month, as shown in Figure 2-17.
Lesson 2-6: Updating a PivotTable

If you modify the source data a PivotTable is based on, the PivotTable isn’t automatically updated. Instead you must manually refresh the PivotTable anytime you change its underlying source data. This lesson explains how to do just that.

1. Click the Promotion Sales tab.

2. Click cell G2, type 100 and press <Enter>.
   Obviously, Antonio Rommero didn’t sell 100 tickets to Boston, but this is a big enough number that you will be able see the changes in the PivotTable’s January column when you update it.

3. Click the Sheet1 tab to return to the PivotTable.
   Look at cell B5, the January column. The PivotTable does not reflect the increased ticket sales you made to the list, as shown in Figure 2-18.

4. Click anywhere in the PivotTable and click the Refresh Data button on the PivotTable toolbar.
   The PivotTable is refreshed and correctly displays the current list data, as shown in Figure 2-19.

5. Save your work and then close the Pivot Table worksheet.

That’s it—we’re finished working with PivotTables! PivotTables are the most powerful way to summarize information in a list, but they’re not the only method you can use. The remainder of this chapter explores some of the other ways to summarize list information.
Lesson 2-7: Formatting and Charting a PivotTable

First, let’s discuss how to format your PivotTable with AutoFormat. AutoFormat is a built-in collection of formats such as font sizes, patterns, and alignments you can quickly apply to a PivotTable report. AutoFormat lets you select from 20 different preset formats. AutoFormat is a great feature if you want your PivotTables to look sharp and professional but don’t have the time to format them yourself.

1. Make sure the cell pointer is located in the PivotTable report and click the Format Report button on the PivotTable toolbar.

   The AutoFormat dialog box appears, as shown in Figure 2-20. You can format your PivotTable report using a preset format.

2. Scroll down the AutoFormat dialog box, select the Table 2 format and click OK.

   The PivotTable is formatted with the preset Table 2 formatting settings.
Chapter Two: Data Analysis and PivotTables

Let’s move on to this lesson’s other topic, create a PivotChart. A PivotChart is similar to an ordinary chart created in Excel, except that it plots a PivotTable’s information. PivotCharts differ from ordinary Excel charts because they are dynamic, just like PivotTables reports. You can change a PivotChart’s structure just like you would with a PivotTable.

3. Make sure the cell pointer is located in the PivotTable report and click the Chart Wizard button on the PivotTable toolbar.

Excel creates a chart form the PivotTable and places it on a new sheet tab, labeled Chart1. You can format and work with a PivotChart just like you would with a regular chart. Since there’s so much information in our PivotTable, the PivotChart we just created looks cluttered. As with PivotTables, you can specify what items you want to appear in a PivotChart.

4. Click the Destination drop-down list located above the chart’s legend and remove the checkmarks from all the destinations except Boston, Cancun, Chicago, and Dallas.

Only the specified destinations are plotted on the PivotChart. Let’s change the chart type to make our PivotChart easier to understand.

5. Select Chart → Chart Type from the menu.

The Chart Type dialog box appears.

6. Select a Clustered Column Chart from the Chart Sub-Type list and click Finish.

The chart type is changed to a clustered column chart, as shown in Figure 2-21. Just about everything you can do to a PivotTable report you can do to a PivotChart. For example, you can easily add, change, remove, or rearrange what the PivotChart plots.

7. Drag the Average of Total field (located in the upper left corner of the chart) from the PivotChart back to the PivotTable toolbar to remove it.

Since the PivotChart has no data to plot, it displays the message “Drop Data Items Here.”

8. Drag the Tickets field from the PivotTable toolbar to the empty Data area of the PivotChart.

The PivotChart now plots the total number of tickets sold to each destination.

9. Save your work and then close the Pivot Table worksheet.

That’s it—we’re finished working with PivotTables and PivotCharts! PivotTables are the most powerful way to summarize information in a list, but they’re not the only method you can use. The remainder of this chapter explores some of the other ways to summarize list information.

Chart Wizard button

Other Ways to Insert a Chart:
- Select Insert → Chart from the menu.

Clustered Column Chart Type

Quick Reference

To Format a PivotTable:
- Make sure the cell pointer is located in the PivotTable report and click the Format Report button on the PivotTable toolbar. Select the formatting you want to apply and click OK.

To Create a PivotChart:
- Place the cell pointer anywhere in a PivotTable report and click the Chart Wizard button on the PivotTable toolbar. Select the chart type you want to apply and click OK.

Or...
- Create a PivotTable and PivotChart from scratch. See the instructions for creating a PivotTable.

To Modify a PivotChart:
- Modify a PivotChart the same as you would a PivotTable—drag and drop fields to and from the PivotTable toolbar and the PivotChart.
Lesson 2-8: Creating Subtotals

So far in this chapter, we’ve been summarizing information in a list using PivotTables. Another quick and easy way to group and summarize data is to use Excel’s subtotals feature. Usually you create subtotals with the SUM function, but you can also create subtotals using functions such as COUNT, AVERAGE, MAX, and MIN.

1. Open the workbook named Lesson 11B.
   You need to sort the list before you use the Subtotals command. You want to sort the list alphabetically by destination.
2. Click any cell in the E column and click the Sort Ascending button on the Standard toolbar.
The list is sorted alphabetically by destination. Now that the list is sorted, you can use the Subtotals command.

4. Make sure the active cell is located within the list and select Data → Subtotals from the menu.
The Subtotal dialog box appears, as shown in Figure 2-22. You want to summarize the list based on the Destination field—the field you sorted in the previous step.

5. Select Destination from the At each change in list, then select Sum from the Use function list.
This will create subtotals every time the destination changes (which is why you had to sort the list based on destination back in Step 2). Next, you need to specify that you want to add subtotals to the Annual Trips and Annual Cost of Tickets fields.

6. In the Add to subtotal to list, check the Tickets check box, and the Total check box (you may have to scroll up or down to find them.) Make sure the other check boxes in the list aren’t checked.
This will add subtotals to the Tickets and Total columns.

7. Make sure the Replace current subtotals and Summary below data check boxes are checked.
Compare your Subtotal dialog box to the one in Figure 2-22.

8. Click OK.
The dialog box closes and Excel summarizes the list and calculates the subtotals for each time the destination field changes. Notice Excel displays the outline symbols to the left of the worksheet, as shown in Figure 2-23. We’ll save outlining for another lesson. For now, try using the Outline buttons to hide the list details.

9. Click the 2 Column Level Symbol button.
Excel hides the third level of detail in the list (the employees) and now only displays the totals for each office.

10. Click the 3 Column Level Symbol button.
All the outline details are again visible. You can turn off the subtotaling now.

11. Make sure the active cell is located within the list and select Data → Subtotals from the menu, then Remove All.
The subtotals and outlining are removed from the list. You can remove Subtotals from a workbook at any time.

12. Make sure the active cell is located within the list, then select Data → Subtotals from the menu and click Remove All.
The Subtotals are removed from the worksheet.

13. Close the workbook without saving it.
Knowing how to use the Subtotals command will give you an edge many other Excel users. Most users don’t realize Excel can automatically add subtotals to their worksheets, and as a result they needlessly spend hours manually adding subtotals themselves.
Chapter Two Review

Lesson Summary

Creating a PivotTable

- A PivotTable summarizes list information dynamically, meaning once you have created a PivotTable, you can rearrange or “pivot” it to view its data in different ways.

- **To Create a PivotTable**: Make sure the cell pointer is located in the list and select **Data → PivotTable Report** from the menu. Follow the on-screen instruction to create the PivotTable.

Modifying a PivotTable’s Structure

- **To Rearrange a PivotTable**: Make sure the cell pointer is located in the PivotTable, click the **PivotTable Wizard button** on the PivotTable toolbar, and rearrange the PivotTable by dragging the field names buttons to or from the appropriate section of the PivotTable diagram.

- **To Change the Calculation Used in a PivotTable**: Make sure the cell pointer is located in the PivotTable and click the **PivotTable Field button** on the PivotTable toolbar, and select the calculation you want to use.

Adding a Page Field to a PivotTable

- A Page Field lets you filter the information in PivotTable.

- **To Add a Page Field to a PivotTable**: Make sure the cell pointer is located in the PivotTable and click the **PivotTable Wizard button** on the PivotTable toolbar. Drag the field name you want to use to filter the PivotTable to the **PAGE** section of the PivotTable diagram and click **Finish**.

- Filter a PivotTable by selecting the criteria from the PivotTable’s Page Field.

Grouping Dates in a PivotTable

- You can group information by days, months, quarters, or years.

- **To Group Information by Date or Time**: Select the row or column heading that contains the date or time value you want to group by and click the **Group button** on the PivotTable toolbar or select **Data → Group and Outline → Group** from the menu. Specify the starting and ending dates and the interval you want to group the dates or time by, then click **OK**.

Updating a PivotTable

- A PivotTable isn’t automatically updated if you modify its source data. You can refresh a PivotTable by clicking the **Refresh Data button** on the PivotTable toolbar or selecting **Data → Refresh Data** from the menu.
Chapter Two: Data Analysis and PivotTables

Formatting and Charting a PivotTable

- **To Format a PivotTable:** Make sure the cell pointer is located in the PivotTable report and click the **Format Report button** on the PivotTable toolbar. Select the formatting you want to apply and click **OK**.

- **To Create a PivotChart:** Place the cell pointer anywhere in a PivotTable report and click the **Chart Wizard button** on the PivotTable toolbar. You will probably have to change the chart type.

- **To Modify a PivotChart:** Modify a PivotChart the same as you would a PivotTable—drag and drop fields to and from the PivotTable toolbar and the PivotChart.

Creating Subtotals

- **To Calculate Subtotals:** Sort the list, select **Data \rightarrow Subtotals** from the menu, enter the appropriate information in the Subtotal dialog box and click **OK**.

- **To Remove Subtotals:** Make sure the active cell is located within the list, then select **Data \rightarrow Subtotals** from the menu and click **Remove All**.

**Quiz**

1. Which of the following statements is NOT true?
   - A. PivotTables summarize the information in a list.
   - B. You can add a PivotTable as an embedded object on a worksheet, or on its own separate worksheet.
   - C. The **Data \rightarrow Pivot Table Report command** starts the PivotTable Wizard.
   - D. You specify which fields you want to summarize in the PivotTable by dragging them to the appropriate areas of the PivotTable diagram.

2. You must create a new PivotTable if you want to summarize information from different fields (True or False?)

3. Which of the following statements is NOT true?
   - A. You can specify how dates should be grouped in a PivotTable by selecting the field that contains the date information, clicking the Group button on the PivotTable toolbar, and specifying how you want the information summarized (by days, months, quarters, or years.)
   - B. PivotTables are automatically updated whenever you change their source data.
   - C. Adding a Page Field to a PivotTable lets you filter the information the PivotTable summarizes.
   - D. You can modify the structure of a PivotTable by clicking the PivotTable Wizard button on the PivotTable toolbar.

4. You should sort a list before you group and summarize its information using the Subtotals command (True or False?)

5. Which of the following statements is NOT true?
   - A. The Subtotals command subtotals a column at each value change.
   - B. The Subtotals command displays the worksheet in outline view.
   - C. The Subtotals command summarizes the worksheet by creating a PivotTable.
   - D. You can add Subtotals to a worksheet by selecting **Data \rightarrow Subtotals** from the menu.
Homework

1. Open the Homework 11 workbook and save it as “PivotTable Practice.”
2. Select any cell; in the table then select Data → PivotTable Report from the menu.
3. Using the PivotTable Wizard, create a PivotTable report that summarizes the worksheet information like the following illustration:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Type</td>
<td>Lodging</td>
<td>Meals</td>
<td>Mileage</td>
<td>Misc</td>
<td>Office</td>
</tr>
<tr>
<td>2</td>
<td>Agent</td>
<td>56</td>
<td>276</td>
<td>69</td>
<td>44</td>
<td>120</td>
</tr>
<tr>
<td>3</td>
<td>David Lewis</td>
<td>56</td>
<td>20</td>
<td>63</td>
<td>30</td>
<td>20</td>
</tr>
<tr>
<td>4</td>
<td>Janet Smith</td>
<td>272</td>
<td>111</td>
<td>22</td>
<td>86</td>
<td>24</td>
</tr>
<tr>
<td>5</td>
<td>Juan Rodriguez</td>
<td>63</td>
<td>66</td>
<td>67</td>
<td>24</td>
<td>25</td>
</tr>
<tr>
<td>6</td>
<td>Mary Olsen</td>
<td>64</td>
<td>25</td>
<td>24</td>
<td>50</td>
<td>103</td>
</tr>
<tr>
<td>7</td>
<td>Mitch Holbrook</td>
<td>448</td>
<td>447</td>
<td>227</td>
<td>86</td>
<td>211</td>
</tr>
</tbody>
</table>

4. Modify the PivotTable’s structure so that the column summarizes by Date instead of by Type.
5. Click the Date, field and then, click the Group button on the PivotTable toolbar. Group the dates by month.
6. Modify the PivotTable’s structure by adding the Type field as the Page Field.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Type</td>
<td>Lodging</td>
<td>Meals</td>
<td>Page</td>
</tr>
<tr>
<td>2</td>
<td>Agent</td>
<td>56</td>
<td>276</td>
<td>245</td>
</tr>
<tr>
<td>3</td>
<td>David Lewis</td>
<td>56</td>
<td>20</td>
<td>245</td>
</tr>
<tr>
<td>4</td>
<td>Janet Smith</td>
<td>272</td>
<td>111</td>
<td>245</td>
</tr>
<tr>
<td>5</td>
<td>Juan Rodriguez</td>
<td>63</td>
<td>66</td>
<td>245</td>
</tr>
<tr>
<td>6</td>
<td>Mary Olsen</td>
<td>64</td>
<td>25</td>
<td>245</td>
</tr>
<tr>
<td>7</td>
<td>Mitch Holbrook</td>
<td>448</td>
<td>447</td>
<td>1710</td>
</tr>
</tbody>
</table>

7. Use the Page Field to filter the information summarized in the PivotTable by the various Types of expenses.
8. Click the Sheet 1 sheet tab and sort the A column alphabetically.
9. Use the Data → Subtotals command to subtotal the worksheet.
10. Practice expanding and collapsing the worksheet while it’s in Outline view.

Quiz Answers

1. B. PivotTables appear on their own separate worksheets.
2. False. It is incredibly easy to modify which fields a PivotTable summarizes. Just click the PivotTable Wizard button on the PivotTable toolbar and drag the fields you want to summarize to the appropriate areas of the PivotTable diagram.
3. B. PivotTables are NOT automatically updated when you change their source data. You must click the Refresh Data button on the PivotTable toolbar to update the PivotTable.
4. True. Always sort a list before using the Subtotals command.
5. C. The Subtotals command does not summarize information using a PivotTable—that’s what the PivotTable command is for!