Microsoft®

Working with Forms and Reports in Access 2002
Student Edition

The Richard Stockton College of New Jersey
CustomGuide.com granted to Computer and Telecommunication Services a license agreement to print an unlimited number of copies of the CustomGuide Courseware materials within Stockton College of New Jersey for training staff, faculty and students.

End users who receive this handout may not reproduce or distribute these materials without permission. Please refer to the copyright notice below for more information.

© 2002 by CustomGuide, Inc. 1502 Nicollet Avenue South, Suite 1; Minneapolis, MN 55403

This material is copyrighted and all rights are reserved by CustomGuide, Inc. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language or computer language, in any form or by any means, electronic, mechanical, magnetic, optical, chemical, manual, or otherwise, without the prior written permission of CustomGuide, Inc.

We make a sincere effort to ensure the accuracy of the material described herein; however, CustomGuide makes no warranty, expressed or implied, with respect to the quality, correctness, reliability, accuracy, or freedom from error of this document or the products it describes. Data used in examples and sample data files are intended to be fictional. Any resemblance to real persons or companies is entirely coincidental.

The names of software products referred to in this manual are claimed as trademarks of their respective companies. CustomGuide is a registered trademark of CustomGuide, Inc.
# Table of Contents

**Chapter One: Working with Forms**

- Lesson 1-1: Creating a Form with AutoForm ................................................................. 6
- Lesson 1-2: Modifying a Form .......................................................................................... 8
- Lesson 1-3: Adding and Deleting Fields .......................................................................... 10
- Lesson 1-4: Moving and Sizing Controls ......................................................................... 12
- Lesson 1-5: Changing the Tab Order ................................................................................ 14
- Lesson 1-6: Working with Control Properties ................................................................. 16
- Lesson 1-7: Control Property Reference ............................................................................ 18
- Lesson 1-8: Working with Form Properties ..................................................................... 20
- Lesson 1-9: Form and Report Property Reference ........................................................... 22
- Lesson 1-10: Working with Multiple Controls ................................................................. 24
- Lesson 1-11: Adding, Cutting, Copying, and Pasting Controls .......................................... 25
- Lesson 1-12: Changing a Control’s Data Source ............................................................. 26
- Lesson 1-13: Creating a Calculated Control ................................................................. 28
- Lesson 1-14: Changing a Control’s Default Value .......................................................... 29
- Lesson 1-15: Using the Control Wizard .......................................................................... 30
- Lesson 1-16: Creating a Subform .................................................................................... 32
- Lesson 1-17: Modifying and Working with Subforms ....................................................... 34

**Chapter One Review** .................................................................................................... 36

**Chapter Two: Working with Reports**

- Lesson 2-1: Creating a Report with AutoReport ............................................................. 44
- Lesson 2-2: Modifying a Report ....................................................................................... 46
- Lesson 2-3: Adding and Deleting Fields ......................................................................... 48
- Lesson 2-4: Moving and Sizing Controls ........................................................................ 50
- Lesson 2-5: Adjusting Page Margins and Orientation .................................................... 52
- Lesson 2-6: Adding Page Numbers and Dates ................................................................. 54
- Lesson 2-7: Understanding Report Sections .................................................................... 56
- Lesson 2-8: Grouping and Sorting Records .................................................................... 58
- Lesson 2-9: Creating Calculated Controls ...................................................................... 60
- Lesson 2-10: Working with Section Properties ............................................................... 62
- Lesson 2-11: Creating Charts with the Chart Wizard ....................................................... 64

**Chapter Two Review** .................................................................................................. 66

**Chapter Three: Formatting Forms and Reports**

- Lesson 3-1: Formatting Fonts with the Formatting Toolbar ................................................. 74
- Lesson 3-2: Changing Text Alignment ............................................................................. 76
- Lesson 3-3: Using AutoFormat ....................................................................................... 77
- Lesson 3-4: Changing Colors ......................................................................................... 78
- Lesson 3-5: Applying Special Effects ............................................................................. 79
- Lesson 3-6: Using the Format Painter ............................................................................. 80
- Lesson 3-7: Adding Pictures and Lines .......................................................................... 82
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lesson 3-8: Aligning Controls with One Another</td>
<td>84</td>
</tr>
<tr>
<td>Lesson 3-9: Changing a Control’s Formatting Properties</td>
<td>86</td>
</tr>
<tr>
<td>Chapter Three Review</td>
<td>88</td>
</tr>
</tbody>
</table>
Chapter One: Working with Forms

Chapter Objectives:

• Create and modify a form
• Add, delete, move, and size controls
• Change a form’s tab order
• Work with control properties and settings
• Work with form properties and settings
• Use the Control Wizard to create interactive forms
• Create subforms to display information from a one-to-many relationship

Chapter Task: Create and work with several types of forms

A form created in Access is similar to the ordinary paper forms that you fill out with a pen or pencil—only you don’t have to worry about trying to read poor penmanship. In Access, forms provide an easy way to enter and view data in a table. Here are just a few examples of how forms make working with data easier.

• Easier to View and Use: Instead of scrolling back and forth in a table’s datasheet, a form lets you focus on one record at a time.
• See Data Any Way You Want: You can design forms to present information any way you like.
• Combine Data from Linked Tables: One form can display data from several related tables or queries—and your users will never know that they are working with two sources!

And that’s just for starters. No doubt about it—forms make your database easier to use. Just like a Windows dialog box (which is really what a form is), Access forms can include fill-in-the-blank fields, check boxes, drop-down lists, and more.

This chapter explains everything you have ever wanted to know about forms—and maybe a few things you didn’t want to know.
Lesson 1-1: Creating a Form with AutoForm

The fastest and easiest way to create a form in Access is with one of the AutoForm Wizards. The AutoForm Wizard automatically creates a form by arranging all the fields from a table or query.

The AutoForm Wizards are fast and easy to use but limited: There are only five AutoForm Wizards, and each can create only one type of form, as shown in Table 1-1: Available Form Layouts. Of course, you can always modify a form created by an AutoForm Wizard.

In this lesson you will learn how to create a form using an AutoForm Wizard.

1. **Open the Lesson 7 database.**

First you need to go to the Forms icon in the Objects bar.
2. **Click the Forms icon in the Objects bar, then click the New button.**

The New Form dialog box appears, as shown in Figure 1-1. You create a form with the AutoForm Wizard by selecting one of the five AutoForm Wizards...

3. **Select AutoForm: Columnar from the list.**

... and the table or query you want to use in your form.

4. **Click the Choose the table or query where the object's data comes from: arrow and select qryCustomers from the list.**

That's all the information the AutoForm Wizard needs to create your form.

5. **Click OK to create the columnar form.**

Access takes all the fields in the qryCustomers query, arranges them, and creates a report similar to the one shown in Figure 1-2.

6. **Close the form without saving your changes.**

AutoForm Wizards forms aren’t really very pretty to look at, but they can give you a good start at creating the form you really want since it’s a lot easier to modify an existing form than it is to create one from scratch.

### Table 1-1: Available Form Layouts

<table>
<thead>
<tr>
<th>Form Type</th>
<th>Form Layout</th>
<th>Description</th>
</tr>
</thead>
</table>
| Columnar  | ![Table](image)

- **Displays only one record at a time.**
- **Data for each record is displayed vertically.**
- **Technically, Columnar form's Default View property is set to Single.**

| Tabular    | ![Table](image)

- **Displays several records at once.**
- **Data for the records is displayed horizontally.**
- **Technically, Tabular form's Default View property is set to Continuous.**

| Datasheet  | ![Table](image)

- **Displays several records at once in Datasheet View.**
- **Technically, Datasheet form's Default View property is set to Datasheet.**

| PivotTable | ![Table](image)

- **Dynamically analyzes information and summarizes it into a datasheet-like table.**

| PivotChart | ![Table](image)

- **Dynamically analyzes information and summarizes it into a chart.**

### Quick Reference

To Create a Form with AutoForm:

1. From the Database window, click the **Forms icon in the Objects bar** and click the **New button.**

2. Select one of the following:
   - **AutoForm: Columnar**
   - **AutoForm: Tabular**
   - **AutoForm: Datasheet**
   - **AutoForm: PivotTable**
   - **AutoForm: PivotChart.**

3. Click the table or query you want to use for the form from the **drop-down list.**

4. Click **OK.**
Lesson 1-2: Modifying a Form

After you create a form, you may decide to modify it to add additional features or make it easier to use. For example, you might want to add or delete a field or change the location of a field on the form. You modify a form in Design View, which you can get to in two different ways:

- **From the database window**: Click the Forms icon to list the forms in the database. Click on the form you want to modify and click the Design button.
- **From a form window**: Click the View button on the toolbar or select View → Design View from the menu.

This lesson will introduce you to form Design View.

1. From the Database window, click the Forms icon in the Objects bar if it isn’t already selected, then select the **frmCustomers form** and click the **Design button**.

   The frmCustomers form appears in Design View, as shown in Figure 1-3.

Don’t let Design View scare you. It looks more complicated than it really is. In some ways, form Design View is similar to many Paint programs. Think of the form as your canvas and the Toolbox and Field List as the paintbrushes you use to add fields, text boxes, and buttons to the form.

Any graphic object that appears on forms and reports is called a **control**. A text box used to enter and display information, a text label, and a button you click to print a report would all be examples of controls. You add controls to a form by clicking the control you want to use and then by clicking and dragging it on the form to draw the control.
To Modify a Form:
1. From the Database window, click the **Forms** icon in the Objects bar.
2. Click the form you want to modify and click **Design**. Or...
   Open the form and click the **View button** on the toolbar.

### Table 1-2: Toolbox Buttons and Controls

<table>
<thead>
<tr>
<th>Toolbox Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Select-Objects" alt="Select Objects" /></td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the <code>&lt;Shift&gt;</code> key as you click each control, or drag a rectangle around all controls you want to select.</td>
</tr>
<tr>
<td><img src="Control-Wizards" alt="Control Wizards" /></td>
<td>Click to use Control Wizards when you add controls to your form.</td>
</tr>
<tr>
<td><img src="Label" alt="Label" /></td>
<td>Creates a static text label that is the same for every record, such as a heading. Most controls already have a text label attached.</td>
</tr>
<tr>
<td><img src="Text-Box" alt="Text Box" /></td>
<td>Creates a text box that displays information from a table and query. You can also use text boxes to enter text.</td>
</tr>
<tr>
<td><img src="Option-Group" alt="Option Group" /></td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box.</td>
</tr>
<tr>
<td><img src="Toggle-Button" alt="Toggle Button" /></td>
<td>Creates a toggle button that allows you to display and enter data from a Yes/No field.</td>
</tr>
<tr>
<td><img src="Option-Button" alt="Option Button" /></td>
<td>Creates an option button (or radio button) that allows the user to make a single selection from two or more choices. Option Buttons are normally used with a Group Box control.</td>
</tr>
<tr>
<td><img src="Check-Box" alt="Check Box" /></td>
<td>Creates a box that is checked or unchecked. Use to enter data from a Yes/No field.</td>
</tr>
<tr>
<td><img src="Combo-Box" alt="Combo Box" /></td>
<td>Creates a drop-down box that lets the user enter text or select an item from a list of options.</td>
</tr>
<tr>
<td><img src="List-Box" alt="List Box" /></td>
<td>Creates a box that lets the user select an item from a list of options.</td>
</tr>
<tr>
<td><img src="Command-Button" alt="Command Button" /></td>
<td>Creates a button that runs a macro or Visual Basic function.</td>
</tr>
<tr>
<td><img src="Image" alt="Image" /></td>
<td>Displays a picture or graphic file that you specify.</td>
</tr>
<tr>
<td><img src="Unbound-Object-Frame" alt="Unbound Object Frame" /></td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td><img src="Bound-Object-Frame" alt="Bound Object Frame" /></td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database. Normally used with OLE Object fields.</td>
</tr>
<tr>
<td><img src="Page-Break" alt="Page Break" /></td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td><img src="Tab-Control" alt="Tab Control" /></td>
<td>Enables you to create tabs (like the ones found in some dialog boxes) to include more than one page of controls on the form.</td>
</tr>
<tr>
<td><img src="Subform-Subreport" alt="Subform/Subreport" /></td>
<td>Inserts another form within the main form. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td><img src="Line" alt="Line" /></td>
<td>Enables you to draw a line.</td>
</tr>
<tr>
<td><img src="Rectangle" alt="Rectangle" /></td>
<td>Enables you to draw a rectangle.</td>
</tr>
<tr>
<td><img src="More-Controls" alt="More Controls" /></td>
<td>Click to display other OLE objects.</td>
</tr>
</tbody>
</table>
Lesson 1-3: Adding and Deleting Fields

Once you have created a form, you can delete unnecessary fields or add more fields to display additional information. You add fields to a form by dragging the fields from the Field List onto the form. The Field List lists all the fields from the table or query you used to create the form.

In this lesson you will modify an existing form by adding and deleting fields.

1. **Make sure you have the frmCustomers form open in Design View.**
   First you click the control you want to delete.

   ![Figure 1-4](image)

   Deleting a control is a quick and easy process.

   ![Figure 1-5](image)

   Add a field to a form by clicking and dragging it from the Field List onto the form.

   ![Figure 1-6](image)

   The modified form.

   ![Figure 1-5](image)

   **Figure 1-5**
   1. Click the control that you want to delete...
   2. ...and press the <Delete> key

   ![Figure 1-6](image)

   Once you have created a form, you can delete unnecessary fields or add more fields to display additional information. You add fields to a form by dragging the fields from the Field List onto the form. The Field List lists all the fields from the table or query you used to create the form.

   In this lesson you will modify an existing form by adding and deleting fields.

   1. **Make sure you have the frmCustomers form open in Design View.**
      First you click the control you want to delete.
2. Click the **DOB text box** to select it.
   Handles (■) appear around the control, indicating that it is selected.
   
   **NOTE:** Selecting a label will select only the label. Selecting a text box will select both
   the text box and the corresponding label.

3. **Press the <Delete> key to delete the DOB text box.**
   Poof! The DOB text box disappears without any fuss.
   So much for deleting fields. Here’s how to add a field:

4. If the **Field List isn’t displayed**, click the **Field List button** on the toolbar.
   The Field List displays all the fields from the table or query you used to create the
   form—although you will usually have to scroll down the Field List to find the field that
   you want. Once the Field List is displayed you can click and drag the field you want to
   add from the Field List to where you want the field to appear on your form.
   Move on to the next step and add the DOB field you had previously deleted from the
   form.

5. **Scroll down the Field List until you find the DOB field.** Click and drag
   the **DOB field** just above the Phone field, as shown in Figure 1-5, then
   release the mouse button.
   The DOB field appears above the Phone field, as shown in Figure 1-6. Don’t worry if
   the DOB field isn’t positioned perfectly—you’ll learn how to move controls in the next
   lesson.
   See how your form looks in Form View.

6. **Click the View button on the toolbar to display the form in Form View.**
   Compare your form with the one in Figure 1-6.

7. **Select File → Save As** from the menu. Save the form as **frmFirstForm**.

---

**Quick Reference**

To Add a Field to a Form:
1. Display the form in **Design View** and click the **Field List button**
   on the toolbar, if necessary.
2. Find the field you want to add to the form in the **Field List**, then click and
   drag the field to the desired location on the form.

To Delete a Field or Control:
1. Click the field or control to select it.
2. Press **<Delete>**.
Lesson 1-4: Moving and Sizing Controls

To move a control, position the mouse over a border of the control until the pointer changes to a and then drag and drop the control to a new location on the form.

Most controls have a corresponding label.

It’s easy to change the location and size of a control on a form. Moving a control allows you to change the order that information appears on the form. When you size a control, you increase or decrease the amount of information the control can display. Once you have selected a control on a form, sizing handles appear around the edges of the control. Now you can drag its sizing handles to adjust the size of the control or move the control to a new location on the form.

This lesson will give you some experience moving and sizing the controls on the form you created in the previous lesson.

1. **Make sure that you have the frmFirstForm form open in Design View.**
   You need to select a control before you can move or size it.

2. **Click the Phone text box to select it.**
   Sizing handles appear around the selected Phone field. Here’s how to move a control:

3. **Position the pointer on any border of the Phone text box (but not over a sizing handle) until it changes to a.**
   When the mouse pointer changes to a, it means that you can drag and drop the control to a location.

   **NOTE:** It takes a good deal of precision to position the pointer over the tiny border of a control. Move the pointer very slowly and wait until it turns into a before you try to move the control.
4. Click and hold down the mouse button while the hand pointer is still over the border of the Phone text box. Drag the field directly to the right of the FirstName text box and directly above the SSN text box, as shown in Figure 1-7, then release the mouse button.

By simply dragging and dropping with the mouse, you can move any object on a form or report—any shapes, lines, pictures, or text boxes.

Sometimes, you may want to move the object just a smidgen. You can use the keyboard to move or nudge controls with greater precision. To move the control, simply hold down the <Ctrl> key as you press any of the arrow keys on the keyboard.

5. With the Phone field still selected, hold down the <Ctrl> + <- (left arrow) key.

The Phone field moves to the left a smidgen. Go to the next step and try moving the DOB field.

6. Follow the procedure you learned in Step 5 and move the DOB text box directly to the right of the LastName text box and directly above the Phone text box.

Don’t worry if the DOB field isn’t the same size or aligned with the other controls—we’ll fix that in a minute.

Notice that the DOB text box moves with its label control. You can move labels and controls independently of one another by dragging them by their upper left sizing handles.

7. Position the pointer over the upper left sizing handle of the DOB label until it changes to a hand.

When the mouse pointer changes to a hand, it means that you can drag and drop the text box or label independently of one another.

NOTE: Most controls have a corresponding label, as shown in Figure 1-8. Make sure that you position the mouse over the DOB label and not the DOB text box.

8. Click and hold down the mouse button while the hand pointer is still over the upper left sizing handle of the DOB label. Drag the DOB label so that the DOB label is left-aligned with the Phone label below it.

Enough about moving controls and labels—here’s how to change their size.

When you select a control, sizing handles appear around its edge. You can use these sizing handles to change the size and proportions of the selected control. Move on to the next step to see how we can reduce the size of the selected DOB label.

9. With the DOB label still selected, position the pointer over the middle-right sizing handle until it changes to a hand. Click and hold down the mouse button and drag down and to the right until the label is the same width as the other labels on the form, then release the mouse button.

As you drag a control’s sizing handle, a dotted outline appears to help you resize it.

10. Click the DOB text box. Follow the procedure you learned in Step 9 and resize the DOB text box so that it is the same width as the other text boxes in the form.

That’s all there is to moving and sizing controls on a form.

11. Click the Save button on the Form Design toolbar to save your changes.
**Lesson 1-5: Changing the Tab Order**

If you add, remove, or move fields on a form, you'll want to change the form’s tab order. A form’s tab order determines the order in which you advance from one field to the next when you press the <Tab> key. When a form is first created, the order of the fields determines the initial tab order. Even when you reposition the fields on a form, the form’s tab order remains the same. For example, the tab order shown in Figure 1-9 is from when the form was originally created. Because you have rearranged several controls, the tab order no longer reflects the order in which the fields appear on the form, as shown in Figure 1-10. This isn’t really a big problem, since it’s easy to change the tab order.

To change the tab order for a form select View → Tab Order from the menu. The Tab Order dialog box will appear, as shown in Figure 1-9. From here all you have to do is click and drag the field in the order you want. Or you can click the Auto Order button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.

1. **Make sure that you have the frmFirstForm form open.**

First let’s see the current tab order of the frmFirstForm form.
2. **Switch to Form View by clicking the View button on the Form Design toolbar.**
   Go to the next step and see what happens when you try tabbing through the fields on the form.

3. **Press the <Tab> key several times.**
   When you press the <Tab> key, the cursor jumps from the CustomerID field to the LastName field to the… Phone field? The tab order for the frmFirstForm form was determined when the form was created. You may have moved the Phone name field in the previous lesson, but its position in the tab order hasn’t changed.
   You can view and change the tab order by opening the Tab Order dialog box. First you need to be in Design View.

4. **Click the View button on the Form Design toolbar to switch to Design View.**
   Here’s how to display the Tab Order dialog box.

5. **Select View → Tab Order from the menu.**
   The Tab Order dialog box appears, as shown in Figure 1-9. The order of the fields in the list is the order in which you will advance from one field to the next when you press the <Tab> key. There are a couple of ways to change the tab order. The fast and easy way is to click the Auto Order button, which automatically rearranges the tab order to correspond with the order in which controls appear on the form.
   **NOTE:** The initial tab order of a form and the Auto Order option both create a tab order from left to right, top to bottom.

6. **Click the Auto Order button.**
   Access looks at the order in which fields appear on the form and adjusts the tab order accordingly.
   Sometimes the tab order may not be intuitive for data entry and you may want to manually change it. For example, you may want to modify the tab order so that the address, city, state, and Zip Code fields are together. Here’s how to manually change a field’s position in the tab order.

7. **Click the City row selector in the Custom Order list.**
   Now that you have selected the City row you can change its order by dragging it to a new location in the list.

8. **Drag the City row until it is below the Address row, then release the mouse button, as shown in Figure 1-11.**
   Move on to the next step and finish arranging the fields in the tab order.

9. **Drag the State row below the City row and drag the ZipCode row below the State row.**
   You’re finished changing the tab order for the frmFirstForm form.

10. **Click OK to close the Tab Order dialog box.**
    Let’s test the new tab order.

11. **Switch to Form View by clicking the View button on the Form Design toolbar.**
    Press the <Tab> key several times and notice the order in which the cursor moves from field to field.
    You’ve finished this lesson so…

12. **Save your changes and then close the frmFirstForm form.**
Lesson 1-6: Working with Control Properties

Every control on a form—every text box, every label, and every check box—has a set of properties that you can modify. A property is an attribute that defines an object's appearance, behavior, or characteristics. For example, the properties of a house would be its color, square footage, and shape. A property for a field on a form might be the number of decimal places displayed or the default value for the field. Because you can almost always change an object's properties, you can think of them as the object's settings.

Different types of controls have different properties. For example, label controls have a Caption property that determines the text that is displayed in the label, while text box controls have a Control Source property that determines which field is displayed in the control. Most controls have several dozen different properties or settings. Fortunately, Access organizes these properties into different categories, as shown in Table 1-3: Tabs in the Properties Dialog Box.

There are several ways to view the properties for any object:

- Right-click the control and select Properties from the shortcut menu.
- Select the control and click the Properties button on the toolbar.
- Select the control and select View → Properties from the menu.

This lesson explains how to view and change a control's properties.

1. **Open the frmCustomers form in Design View.**

Here’s one way to view the properties for a control:
2. Select the **LastName text box control** and display its properties by clicking the **Properties button** on the Form Design toolbar.

The Properties dialog box appears and displays the properties for the LastName text box control, as shown in Figure 1-12. To change a property, simply find and click the appropriate property box and make the changes. Some property boxes will display one of the following buttons when clicked:

- ![Click to display a list of options](button.png) Click to display a list of options to change the settings for the selected property.
- ![Click to invoke a Wizard or display a dialog box](button.png) Click to invoke a Wizard or display a dialog box that you use to change the settings for the selected property.

Move on to the next step and we’ll try changing one of the LastName text box control’s properties.

3. **Click the Format tab, if necessary, then find and click in the Back Style box, click its ![down arrow](button.png) down arrow, and select **Transparent**.**

**NOTE:** Most controls have dozens and dozens of properties. You will often have to click the appropriate tab and then do some scrolling to find the property box that you’re looking for.

The back of the LastName text box control becomes transparent and displays the gray background of the underlying form. The transparent Back Style property of the LastName text box control looks out of place, so let’s change it back.

4. **Change the Back Style property of the LastName text box control back to **Normal**.**

Once the Properties dialog box is open, you can simply click any control to display its properties.

5. **Click the LastName label (NOT the LastName text box).**

The Properties dialog box now displays the properties for the LastName label. You can tell which control’s properties are being displayed by looking at the Title bar of the Properties dialog box.

6. **Close the Properties dialog box.**

---

### Table 1-3: Tabs in the Properties Dialog Box

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Format</strong></td>
<td>Properties that determine the object’s appearance, such as color, text formatting, line and border color/thickness, and special effects. The purpose of many Formatting properties should be pretty obvious—for example, Font Size determines the font size of the control.</td>
</tr>
<tr>
<td><strong>Data</strong></td>
<td>Properties that determine where a control gets its data, its default value (if any), and data validation rules for the control.</td>
</tr>
<tr>
<td><strong>Event</strong></td>
<td>Actions to which you can assign a macro or Visual Basic procedure. For example, clicking a button or entering information in a particular field could trigger a macro to run.</td>
</tr>
<tr>
<td><strong>Other</strong></td>
<td>Miscellaneous but important properties, such as the name of the control, if tabbing to the control is allowed, and if a message should appear in the Status bar when the control is selected.</td>
</tr>
<tr>
<td><strong>All</strong></td>
<td>Displays all the properties for the control.</td>
</tr>
</tbody>
</table>

---

**Properties button**

**Other Ways to View a Control’s Properties:**

- Right-click the control and select **Properties** from the shortcut menu.
- Select the control and select **View → Properties** from the menu.

---

### Quick Reference

**To Display the Properties for Any Control:**

1. Display the form in **Design View**.
2. Select the control and click the **Properties button** on the toolbar.
   
   Or...
   
   Right-click the control and select **Properties** from the shortcut menu.
   
   Or...
   
   Select the control and select **View → Properties** from the menu.
Lesson 1-7: Control Property Reference

Every control on a form or report has dozens of different control properties or settings—so how do you keep them all straight? Here’s how—this lesson is really a cheat sheet that you can use whenever you’re not sure what exactly a particular control property is or does. The most important properties are marked with a ★.

<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption for a form or text label.</td>
</tr>
<tr>
<td>Format ★</td>
<td>Format</td>
<td>Customizes the way numbers, dates, times, and text are displayed and printed.</td>
</tr>
<tr>
<td>Decimal Places ★</td>
<td>Format</td>
<td>Determines the number of decimal places displayed.</td>
</tr>
<tr>
<td>Visible ★</td>
<td>Format</td>
<td>Show or hides a control. Useful if you want to use information on the form without it being visible. For example, you could use the value in a hidden control as the criteria for a query.</td>
</tr>
<tr>
<td>Display When</td>
<td>Format</td>
<td>Determines whether a section or control always appears or only appears when it is displayed on screen or printed.</td>
</tr>
<tr>
<td>Scroll Bars</td>
<td>Format</td>
<td>Determines whether scroll bars appear in the control.</td>
</tr>
<tr>
<td>Left ★</td>
<td>Format</td>
<td>Determines the horizontal position of the control.</td>
</tr>
<tr>
<td>Top ★</td>
<td>Format</td>
<td>Determines the vertical position of the control.</td>
</tr>
<tr>
<td>Width ★</td>
<td>Format</td>
<td>Determines the width of a control.</td>
</tr>
<tr>
<td>Height ★</td>
<td>Format</td>
<td>Determines the height of a control.</td>
</tr>
<tr>
<td>Back Style</td>
<td>Format</td>
<td>Determines whether a control is transparent or not.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Format</td>
<td>Determines the color of a control. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Format</td>
<td>Applies a 3-D effect to a control.</td>
</tr>
<tr>
<td>Border Style</td>
<td>Format</td>
<td>Determines the line style of a control’s border—select from transparent lines, solid lines, dashed lines, etc.</td>
</tr>
<tr>
<td>Border Color</td>
<td>Format</td>
<td>Determines the color of a control’s border. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Border Width</td>
<td>Format</td>
<td>Determines the width of a control’s border (in points).</td>
</tr>
<tr>
<td>Fore Color</td>
<td>Format</td>
<td>Determines the color of text in a control or the fill color of an object. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Format</td>
<td>Determines the font used in a control (such as Arial or Times New Roman).</td>
</tr>
<tr>
<td>Font Weight</td>
<td>Format</td>
<td>Determines the thickness (boldface) of text in a control.</td>
</tr>
</tbody>
</table>
### Property Table

<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font Italic</td>
<td>Format</td>
<td>Determines whether the text in a control appears in italics.</td>
</tr>
<tr>
<td>Font Underline</td>
<td>Format</td>
<td>Determines whether the text in a control is underlined.</td>
</tr>
<tr>
<td>Text Align</td>
<td>Format</td>
<td>Determines how text should be aligned in a control.</td>
</tr>
<tr>
<td>Control Source ★</td>
<td>Data</td>
<td>Determines the data that appears in the control.</td>
</tr>
<tr>
<td>Input Mask ★</td>
<td>Data</td>
<td>Limits the amount and type of information that can be entered in a field, such as (_<strong>) <strong><strong>-</strong></strong></strong> for a phone number. Click the button to create an input mask using the Input Mask Wizard.</td>
</tr>
<tr>
<td>Default Value ★</td>
<td>Data</td>
<td>Specifies a value that is automatically entered in this field for new records.</td>
</tr>
<tr>
<td>Validation Rule ★</td>
<td>Data</td>
<td>Allows you to enter an expression that is evaluated when data in the field is added or changed.</td>
</tr>
<tr>
<td>Validation Text ★</td>
<td>Data</td>
<td>Allows you to enter a message that is displayed when data doesn't meet the Validation Rule property.</td>
</tr>
<tr>
<td>Locked ★</td>
<td>Data</td>
<td>Determines whether changes can be made to a field's data.</td>
</tr>
<tr>
<td>Event Tab</td>
<td>Event</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Name ★</td>
<td>Other</td>
<td>Specifies the name of the control that identifies it in expressions, macros, and Visual Basic procedures.</td>
</tr>
<tr>
<td>Status Bar Text</td>
<td>Other</td>
<td>Specifies a message to display in the Status bar when the control is selected.</td>
</tr>
<tr>
<td>Enter Key Behavior</td>
<td>Other</td>
<td>Determines if pressing the &lt;Enter&gt; key adds a new line of text in a control or if it moves to the next field.</td>
</tr>
<tr>
<td>Allow AutoCorrect</td>
<td>Other</td>
<td>Determines if AutoCorrect (i.e., “teh” → “the”) is used in a control.</td>
</tr>
<tr>
<td>AutoTab</td>
<td>Other</td>
<td>Used with the Input Mask property. Determines whether an automatic tab to the next field occurs when the last character permitted by a text box control’s input mask is entered.</td>
</tr>
<tr>
<td>Tab Stop</td>
<td>Other</td>
<td>Determines whether users are able to tab to the control.</td>
</tr>
<tr>
<td>Tab Index</td>
<td>Other</td>
<td>Determines the tab order.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specifies a user-created shortcut menu that appears when the control is right-clicked.</td>
</tr>
<tr>
<td>ControlTip Message</td>
<td>Other</td>
<td>Specifies a brief message that appears when a user points at the control for a couple of seconds.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specifies an identifier number for a user-created Help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Specifies extra, user-defined information that is stored in the object.</td>
</tr>
</tbody>
</table>
Lesson 1-8: Working with Form Properties

In the previous few lessons, you’ve been learning how to view and change the properties for form controls. In this lesson you will learn how to view and change the properties and settings of the form itself. That’s right—just like controls, forms also have their own set of properties that you can view and manipulate. So why would you want to change a form’s properties? Modifying a form’s properties can be especially important if you are creating a database that will be used by novice users. For example, by modifying a form’s properties you can:

• Allow users to edit exiting records in a table or query—but not add any additional records.
• Display one record at a time on each form or display many records at once.
• Determine the size and location of the form.

To view the properties for a form or report, simply double-click the Form Selector, as shown in Figure 1-13. In this lesson you will learn how to work with a form’s properties.

1. **Open the frmCustomers form in Form View.**
   
   In its current state, the frmCustomers form displays one record at a time and has a rather confusing caption in the title bar: “frmCustomers.” These are form properties that you can change. You must be in Design View in order to view and change a form’s properties.

2. **Click the View button on the toolbar to switch to Design View.**
   
   To view the properties for a form, double-click the Form Selector, as shown in Figure 1-13. Move on to the next step and try it!

3. **Double-click the Form Selector.**
   
   Microsoft Access displays the properties for the form. First, let’s give the “frmCustomers” title bar a more descriptive name.
4. Click the **Format tab**, if necessary, click in the **Caption box**, and replace its text with **Customers**.

   One of the most important form properties is the **Default View** property, which determines how many records a form can display at once. Let’s take a closer look at this property…

5. Click the **Format tab**, click the **Default View box**, and click the **down arrow**.

   You have five options. They are:
   - **Single Form**: Displays one record at a time on a form.
   - **Continuous Forms**: Displays multiple records on a form. The main difference between Datasheet and Continuous Forms is that a continuous form can be customized.
   - **Datasheet**: Displays multiple records in a table, using one line per record. Tables and queries display information in datasheets.
   - **PivotTable**: Dynamically analyzes information and summarizes it into a datasheet-like table.
   - **PivotChart**: Dynamically analyzes information and summarizes it into a chart.

6. Select **Datasheet from the list**.

   That’s enough changes for now.

7. Close the **Properties dialog box**.

   Let’s see how the form looks with its new properties.

8. Click the **View button** on the toolbar to display the form.

   Access now displays the frmCustomers form in Datasheet View, and it has a new caption in the title bar.

9. Close the **frmCustomers form** without saving any changes.

   You’re probably wondering how you are going to get a handle on all these form properties. Don’t worry—you will probably never touch 95 percent of them. And when you actually do have to roll up your sleeves and tackle form properties, you’ll find the cheat sheet in the next lesson invaluable.
Lesson 1-9: Form and Report Property Reference

If you thought controls had lots of properties, wait until you see how many properties forms and reports have! Here’s another “cheat sheet” that lists the various form properties. Some of the most important properties are marked with a ★.

Table 1-5: Important Form Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caption ★</td>
<td>Format</td>
<td>Displays a descriptive caption in the form’s title bar.</td>
</tr>
<tr>
<td>Default View ★</td>
<td>Format</td>
<td>Determines the view the form is in when opened.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Single Form</strong>: Displays one record at a time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Continuous Forms</strong>: Displays multiple records in a form.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Datasheet</strong>: Displays multiple records in a Datasheet.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>PivotTable</strong>: Dynamically analyzes data, summarizes into a table.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>PivotChart</strong>: Dynamically analyzes data, summarizes into a chart.</td>
</tr>
<tr>
<td>Allow Form View</td>
<td>Format</td>
<td>Determines if users can switch to this view.</td>
</tr>
<tr>
<td>Allow Datasheet View</td>
<td>Format</td>
<td></td>
</tr>
<tr>
<td>Allow PivotTable View</td>
<td>Format</td>
<td></td>
</tr>
<tr>
<td>Allow PivotChart View</td>
<td>Format</td>
<td></td>
</tr>
<tr>
<td>Scroll Bars ★</td>
<td>Format</td>
<td>Determines whether scroll bars appear on the form.</td>
</tr>
<tr>
<td>Record Selectors ★</td>
<td>Format</td>
<td>Determines whether a form contains a record selector.</td>
</tr>
<tr>
<td>Navigation Buttons ★</td>
<td>Format</td>
<td>Determines whether a form has navigation buttons.</td>
</tr>
<tr>
<td>Dividing Lines</td>
<td>Format</td>
<td>Determines if lines appear between records in continuous forms.</td>
</tr>
<tr>
<td>Auto Resize</td>
<td>Format</td>
<td>Resizes the form automatically to display a complete record.</td>
</tr>
<tr>
<td>Border Style ★</td>
<td>Format</td>
<td>Determines the type of window the form appears in: None, Thin, Sizable, or Dialog.</td>
</tr>
<tr>
<td>Control Box</td>
<td>Format</td>
<td>Determines if a control menu appears in the form.</td>
</tr>
<tr>
<td>Min Max Buttons</td>
<td>Format</td>
<td>Determines if minimize and/or maximize buttons appear in the form.</td>
</tr>
<tr>
<td>Close Button</td>
<td>Format</td>
<td>Determines if a close button appears on the form.</td>
</tr>
<tr>
<td>Width ★</td>
<td>Format</td>
<td>Determines the width of the form.</td>
</tr>
<tr>
<td>Height ★</td>
<td>Format</td>
<td>Determines the height of the form.</td>
</tr>
<tr>
<td>Picture</td>
<td>Format</td>
<td>Adds a graphic or picture for the form or report background. Click the Build button to browse for the folder and file.</td>
</tr>
<tr>
<td>Picture Type</td>
<td>Format</td>
<td>Determines if the picture is embedded or linked.</td>
</tr>
<tr>
<td>Picture Size Mode</td>
<td>Format</td>
<td>Determines how the contents of a picture frame are displayed: Clip, Stretch, or Zoom.</td>
</tr>
<tr>
<td>Picture Alignment</td>
<td>Format</td>
<td>Determines the alignment of a picture within a frame.</td>
</tr>
<tr>
<td>Property</td>
<td>Tab</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Picture Tiling</td>
<td>Format</td>
<td>Determines whether a picture is tiled within a frame.</td>
</tr>
<tr>
<td>Grid X</td>
<td>Format</td>
<td>Determines the number of subdivisions (horizontal) in a grid.</td>
</tr>
<tr>
<td>Grid Y</td>
<td>Format</td>
<td>Determines the number of subdivisions (vertical) in a grid.</td>
</tr>
<tr>
<td>Layout for Print</td>
<td>Format</td>
<td>Determines whether the form uses printer fonts.</td>
</tr>
<tr>
<td>Palette Source</td>
<td>Format</td>
<td>Specifies the path and file name for the graphic file used as a palette.</td>
</tr>
<tr>
<td>Record Source ⭐</td>
<td>Data</td>
<td>Specifies the table or query whose data will be used in the form.</td>
</tr>
<tr>
<td>Filter</td>
<td>Data</td>
<td>Specifies a filter that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Order By</td>
<td>Data</td>
<td>Specifies a sort order that is loaded automatically with the Form/Report.</td>
</tr>
<tr>
<td>Allow Filters</td>
<td>Data</td>
<td>Determines whether filters may be applied to the form.</td>
</tr>
<tr>
<td>Allow Edits ⭐</td>
<td>Data</td>
<td>Determines whether records can be modified in the form.</td>
</tr>
<tr>
<td>Allow Deletions ⭐</td>
<td>Data</td>
<td>Determines whether records can be deleted in the form.</td>
</tr>
<tr>
<td>Allow Additions ⭐</td>
<td>Data</td>
<td>Determines whether records can be added in the form.</td>
</tr>
<tr>
<td>Data Entry ⭐</td>
<td>Data</td>
<td>Allows you to select “Yes” if you only want to use the form to add new records.</td>
</tr>
<tr>
<td>Event Tab</td>
<td>Event</td>
<td>Allows you to assign a macro or Visual Basic procedure to a specific event, such as when you click or update a control.</td>
</tr>
<tr>
<td>Pop Up</td>
<td>Other</td>
<td>Determines whether the form appears in a pop-up window that remains on top of all other windows.</td>
</tr>
<tr>
<td>Modal</td>
<td>Other</td>
<td>Determines whether the form keeps the focus (you can’t switch to any other windows or forms) until it is closed.</td>
</tr>
<tr>
<td>Cycle</td>
<td>Other</td>
<td>Determines how the tab key should cycle.</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>Other</td>
<td>Allows you to select a custom menu bar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Other</td>
<td>Allows you to select a custom toolbar that you created that should appear when the form is active.</td>
</tr>
<tr>
<td>Shortcut Menu</td>
<td>Other</td>
<td>Determines if right mouse button shortcut menus are permitted in the form.</td>
</tr>
<tr>
<td>Shortcut Menu Bar</td>
<td>Other</td>
<td>Specifies a user-created shortcut menu that appears when a user clicks the right-mouse button.</td>
</tr>
<tr>
<td>Fast Laser Printing</td>
<td>Other</td>
<td>Print the form using optimized laser-printer formatting.</td>
</tr>
<tr>
<td>Help File</td>
<td>Other</td>
<td>Specifies the name of the custom Help file for the form.</td>
</tr>
<tr>
<td>Help Context Id</td>
<td>Other</td>
<td>Specifies an identifier number for a user-created Help file that appears when the user selects the control and presses &lt;F1&gt;.</td>
</tr>
<tr>
<td>Tag</td>
<td>Other</td>
<td>Specifies extra user-defined information that is stored in the form.</td>
</tr>
<tr>
<td>Has Module</td>
<td>Other</td>
<td>Specifies if the form has Visual Basic code behind it.</td>
</tr>
</tbody>
</table>
Lesson 1-10: Working with Multiple Controls

To Select Multiple Controls:

- Press and hold down the <Shift> key as you click each control that you want to select.
- If necessary, click the Select Objects button on the Toolbox toolbar. Then use the arrow pointer to draw a box around the controls that you want to select, as shown in Figure 1-15. The disadvantage of this method is it’s not as selective as using the <Shift> + click method.
- If the controls you want to select are aligned along a horizontal line, click to the left of the objects in the vertical ruler to select every control to the right of the ruler.

1. Open the frmCustomers form in Design View.
To delete a control you have to select it and press the <Delete> key. Sometimes you will want to delete several controls; instead of selecting and deleting each individual control, you can select and delete several controls at the same time. There are several ways to select more than one control:
   - Press and hold down the <Shift> key as you click each control that you want to select.
   - If necessary, click the Select Objects button on the Toolbox toolbar. Then use the arrow pointer to draw a box around the controls that you want to select, as shown in Figure 1-15. The disadvantage of this method is it’s not as selective as using the <Shift> + click method.
   - If the controls you want to select are aligned along a horizontal line, click to the left of the objects in the vertical ruler to select every control to the right of the ruler.

2. Hold down the <Shift> key as you click the Smoker and First Class text boxes as shown in Figure 1-14.
Handles ( ■ ) appear around the controls, indicating that they are selected.

3. Press the <Delete> key to delete the selected controls.
The Smoker and First Class text box controls are both deleted.
Lesson 1-11: Adding, Cutting, Copying, and Pasting Controls

In this lesson you will learn how to add a control by clicking and dragging and by copying and pasting.

1. Click the Check Box button on the Toolbox.
   
   **NOTE:** If the Toolbox isn’t displayed, click the Toolbox button on the Form Design toolbar.

   The mouse pointer changes to a , indicating that you can click and drag a check box control on the form.

2. Place the pointer below the SSN text box. Click and drag the pointer down and to the right and release the mouse button, as shown in Figure 1-16.

   Congratulations! You’ve just added a check box control to your form.

   If your form already has a control that’s similar to the one you want to add, it’s often easier to add the new control by copying and pasting the similar control than it is to add a control using the Toolbox. Once you have pasted the control, you can easily modify its properties, such as its text label data source. Here’s how to copy a control.

3. Select the check box control you just added and click the Copy button on the Form Design toolbar.

   Access copies the selected check box control to the Windows Clipboard. You can also cut controls on a form by selecting them and clicking the Cut button on the Form Design toolbar or by pressing <Ctrl> + <X>. Now let’s paste the copied control.

4. Click the Paste button on the Form Design toolbar.

   Access pastes the copied check box onto the form as a new check box with its own name and label. We’ll modify the two new check box controls in the next lesson.
Lesson 1-12: Changing a Control’s Data Source

There are three types of controls that you can add to your forms, as illustrated in Figure 1-17. They are:

1. **Bound Controls:** Bound controls are bound or connected to an underlying field in a table or query. You use bound controls to display, enter, and update field values in your database. The fields that you can add to a form using the Field List are all examples of bound controls.

2. **Unbound Controls:** Unbound controls are not bound or connected to an underlying field in a table or query. You use unbound controls to display information. Labels, text boxes, and buttons can all be inserted on a form as unbound controls. The two check boxes you added to the form in the previous lessons are both examples of unbound controls because they aren’t connected to an underlying field in a table or query.

3. **Calculated Controls:** Calculated controls are based on an expression and are used to calculate values in a form, such as arithmetic problems. Technically, calculated controls are unbound controls because they do not update any table fields.

Figure 1-17
Examples of bound, unbound, and calculated controls.

Figure 1-18
Setting the Control Source property.

Figure 1-19
The steps in modifying a control’s text label.

1. Click the control to select it.
2. Click inside the control text label with the I pointer.
3. Edit the text label.
A control’s Control Source property determines what is displayed in a control – here’s how:

- A bound control’s Control Source property contains the name of the underlying database field to which it is bound.
- An unbound control’s Control Source property does not contain the name of an underlying database field.
- A calculated control’s Control Source property contains an expression that calculates the values displayed in the control.

This lesson explains how you can change a control’s Control Source property.

1. **Select the first check box control** you added in the previous lesson, and display its properties by clicking the Properties button on the Form Design toolbar.
   
   The Properties dialog box appears. You can find the Control Source property on the Data Tab.

2. **Click the Data tab.**
   
   The Data tab appears, as shown in Figure 1-18. You can determine what is displayed in the control by setting the Control Source property. You can bind the control to a field in the form’s underlying query or table by clicking the button, or you can type text or an expression directly into the Control Source box. We want to bind the selected check box control to the Smoker field.

3. **Click in the Control Source box, click the button, and select Smoker from the list.**
   
   The check box is now bound to the Smoker field in the tblCustomers table. Next let’s bind the other check box control you added to the First Class field.

4. **With the Properties dialog box still open, click the second check box control** you added in the previous lesson.
   
   The Properties dialog box is updated and displays the settings for the selected check box control.

5. **Click in the Control Source box, click the button, and select First Class from the list.**
   
   You’re done specifying the data sources for the two check boxes so you can close the Properties dialog box.

6. **Close the Properties dialog box.**
   
   Before we’re finished, we have to give the two check boxes more meaningful text labels. Here’s how:

7. **Position the pointer over the first check box text label, until it changes into a , and then click inside the text label.**
   
   Now you can edit the check box text label.

8. **Replace the text label text with Smoker.**
   
   Now move on to the next step and change the text label for the second check box.

9. **Following the same procedures as steps 7-9, rename the second check box text label First Class.**
   
   That’s it! You’re done binding the check boxes to two underlying database fields.

10. **Save your changes and close the frmCustomers form.**
Lesson 1-13: Creating a Calculated Control

A calculated control is an unbound control that displays totals and other arithmetic computations on a form. You create calculated controls by entering an expression (or formula) to perform the calculation in the control’s Control Source property.

In forms, expressions start with the equal sign (=), which tells Access that you want to perform a calculation. After the equal sign, you must specify two more types of information: the values you want to calculate and the arithmetic operator(s) or function name(s) you want to use to calculate the values. Expressions can contain explicit values, such as the numbers “4” or “5” or can reference the values contained in database fields. For example, the formula = [Cost]*[Commission] would multiply the values in the Cost and Commissions fields. To enter fields in an expression, type the field name in brackets ([ ]). If a field name exists in more than one table, you will need to enter the name of the table that contains the field in brackets ([tblTours]!) followed by an exclamation mark (!). For example, the formula = [tblTours]! [Cost]*0.15 would multiply the values in the Cost field in the tblTours table by 0.15.

1. Open the frmTours form in Design View.
   You want the Total text box to be a calculated control that finds the total cost of each tour by multiplying the Number of Tickets field by the Cost field.

2. Select the Total text box, click the Properties button on the Form Design toolbar, and click the Data tab.
   You need to enter the expression in the Control Source box.

3. Click in the Control Source box and type the expression
   = [Number of Tickets] * [Cost] as shown in Figure 1-22.
   Let’s see how our new calculated control works.

4. Close the Properties dialog box and click the View button on the Form Design toolbar to switch to Form View.
   The Total field displays the results of the expression you entered in Step 3.

5. Save your changes and close the frmTours form.
   Although you worked on a form in this lesson, you can also use expressions to create calculated controls and fields in queries and reports.

Quick Reference

To Create a Calculated Control:
1. Display the Form in Design View.
2. Select the control and click the Properties button on the toolbar.
3. Click the Data tab and click in the Control Source box.
4. Type the expression, using proper Access syntax.
   Or...
   Click the Build button and use the Expression Builder to create the expression.
Lesson 1-14: Changing a Control’s Default Value

You can enter a default value to specify a value that is automatically entered in a field when a new record is created. For example, if most of your clients are from Texas, you could set the default value for the State field to “TX.” When users add a record using a form, they can either accept the “TX” default value for the State field or enter their own value.

1. Open the frmCustomers form in Design View.
   Since the majority of your customers are from Minnesota, you decide to add “MN” as the default value for the State field.

2. Click the State field, display its properties by clicking the Properties button on the Form Design toolbar, and click the Data tab.
   Now you can add a default value to the State field.

3. Click the Default Value box and type MN, as shown in Figure 1-23.
   Let’s see how the new default-value property works.

4. Close the Properties dialog box and click the View button on the Form Design toolbar to switch to Form View.
   You will need to add a new record in order to see any default values.

5. Click the New Record button on the Record Navigation bar.
   Access adds a new blank record to the form. Notice that the State field already contains the “MN” default value. If the customer is from another state, you can simply replace the default value with your own data.

6. Save your changes and close the frmCustomers form.

One more important note about form control properties: Control properties in a form are inherited, or passed down, from the original properties in the underlying table or query. For example, if you set the Default Value property for a table’s State field to “TX,” the “TX” Default Value property will be passed on to a related State control on a form by default.
Lesson 1-15: Using the Control Wizard

The Control Wizard (no relation to Merlin) helps you add powerful, interactive controls to your form. Some examples include:

- List and combo box controls that can look up values in a table and then display the corresponding record on a form.
- Buttons that can open, print, or close tables, forms, queries, pages, and reports.
- Subforms, subreports, and charts that display related data from different tables.

When you add a control using the Control Wizard, you are asked a series of questions about what you want the control to do. The Control Wizard then creates the control, making the appropriate property settings and even adding several lines of Visual Basic code to the control for you.

1. **Open the frmCustomers form in Design View.**

   To use the Control Wizard, simply make sure that the Control Wizards button on the Toolbox is pressed in, and then add the control. The Control Wizard will appear anytime you try to create a list box, combo box, option group, button, chart, subreport, or subform.
2. Make sure the Control Wizards button on the Toolbox is pressed in.
The Control Wizard is so incredibly cool and useful that you are strongly
recommended to always keep it on.

NOTE: If the Toolbox isn’t displayed, click the Toolbox button on the Form
Design toolbar.

First let’s add a combo box control to the form.

3. Click the Combo Box button on the Toolbox.
The mouse pointer changes to a + , indicating that you can click and drag a combo
box control on the form.

4. Place the + pointer in the form header, about one inch to the right of the
“Customers” label. Click and drag the + pointer to the right about an
inch and release the mouse button.

Because the Control Wizard is on, the Combo Box Wizard dialog box appears, as
shown in Figure 1-26. Each type of control will have its own Control Wizard and its
own set of options. For this exercise, you want to select the third option.

5. Select the Find a record on my form based on the value I selected in
my combo box option and click Next.

Next the Control Wizard asks which values you want to add to your combo box control

6. Click the ? button three times to add the CustomerID, LastName
and FirstName fields to the combo box and click Next.

Next the Control Wizard asks how wide you want the columns in your combo box
control and if you want to hide the key column. Everything looks okay here, so…

7. Click Next.
Finally, you are asked to give your combo box a name. You can accept the default
name provided by the Control Wizard or you can provide your own name.

8. Type Lookup Name and click Finish.

Poof! The Control Wizard adds the combo box. Next let’s add a command button that
will print the current record when clicked.

9. Click the Command Button button on the Toolbox and add a button to
the right of the CustomerID text box by clicking and dragging.

Because the Control Wizard is on, the Command Button Wizard appears. Command
Buttons have lots of options that you can choose from, broken down by categories.

10. Select Record Operations from the Categories list and select Print
Record from the Actions list.

This will make the command button print the current record when clicked.

11. Click Next.
Here you can specify the text or picture that will appear in the button.

12. Click Finish.
Access adds the command button to the form.

13. Click the View button on the Form Design toolbar.
Let’s see how our new controls work.

14. Select a name from the new Lookup Name combo box.
Access finds and displays the record that you select from the combo box.

15. Save your changes and close the frmCustomers form.
Try experimenting and adding controls to your forms using the Control Wizard. You’ll be
amazed at how much you can accomplish without knowing any programming!
Lesson 1-16: Creating a Subform

A subform is a form within a form. The primary form is called the main form, and the form within the form is called the subform. Subforms are especially useful when you want to show data from tables or queries with a one-to-many relationship. For example, a Customer form might have a subform that displays each customer’s Orders. Subforms are a great way to display information from a one-to-many table relationship.

The main form and subform are linked so that the subform displays only records that are related to the current record in the main form. For example, when the main form displays a particular customer, the subform displays only orders for that customer.

1. Open the frmEmployees form in Design View.
   Usually you will want to have the Control Wizard assist you when you add a subform.

2. Make sure the Control Wizards button on the Toolbox is pressed in.
   The Control Wizard is on whenever its button is depressed.

   NOTE: If the Toolbox isn’t displayed, click the Toolbox button on the Form Design toolbar.

   Before you add a subform, make sure that you have enough room for it on the main form.

3. Resize the main-form window as needed, so that you have enough room to add the subform.
   You’re ready to add the subform! Here’s how:
4. **Click the Subform/Subreport button on the Toolbox.**
   The mouse pointer changes to a ‡, indicating that you can click and drag the subform onto the main form.

5. **Place the ‡ pointer just below the DOB field. Click and drag the ‡ pointer down and to the right, until the subform covers most of the bottom half of the main form.**
   The Subform Wizard appears and asks if you want to use an existing form for your subform or if you want to build a new form, using tables or queries. In this exercise we will have the Wizard build us a new form using tables and queries to use as our subform.

6. **Click Next.**
   The next step of the Wizard appears. Here you have to select the table or query and fields that you want to display in your subform. We want our subform to display the tours that each employee has sold, so we will select the qryCustomerTours query as the source for our subform.

7. **Select Query: qryCustomerTours from the Tables/Queries combo box.**
   Now you need to select the fields you want to appear in the subform. You must select the related field used to join the main form and subform. This related field must appear on both the main form (where it is called the parent field) and on the subform (where it is called the child field). In this exercise we will use the EmployeeID field to link the two forms.
   **NOTE:** It’s very important that the underlying tables or queries of the main form and subform have a related field and that the related field appears somewhere on both forms. See the “Understanding Table Relationships” lesson in the “Creating Relational Databases” chapter if you’re having trouble understanding this concept.

8. **Select the EmployeeID field and click the ‡ button to add the field to the Selected Fields list.**
   Now that you’ve added the most important field that will link the two forms, you can add the remaining fields that you want to appear on the subform.

9. **Add the Date, TourID, CustomerID, and Number of Tickets fields to the Selected Fields list.**
   If you’re this far, you should be a pro at adding and removing fields using the Wizard. Just make sure that you add the fields in the order specified in Steps 8 and 9.

10. **Click Next.**
    The next step in the Wizard is to define the fields that link the main form and the subform. The Subform Wizard is often smart enough to recognize the field and use it to link the two forms—as it is in this exercise. If not, you will have to click the Define my own option and select the two related fields.

11. **Click Finish.**
    Access creates the subform and adds it to the main form.

12. **Save your changes to the frmEmployees form and display it in Form View.**
    The frmEmployees form displays information on each employee and the new subform displays the tours that employee booked.

   Subforms created with the Subform Wizard are usually a little rough around the edges and will require a little clean-up work on your part. We’ll learn how to modify and work with a subform in the next lesson.
Lesson 1-17: Modifying and Working with Subforms

Subforms rarely come out the way you want them to the first time: They may be too small or too large and must be resized so that the main form and subform fit together nicely. If you’re using an existing form as a subform, you may need to change the subform layout. Subforms can be displayed using one of three different formats:

- **Single Form**: Displays one record at a time on a form.
- **Continuous Forms**: Displays multiple records on a form. The main difference between datasheets and continuous forms is that you can design and customize continuous forms.
- **Datasheet**: Displays multiple records in a table, using one line per record. Tables and queries display their data in Datasheet layout.
- **PivotTable**: Dynamically analyzes information and summarizes it into a datasheet-like table.
- **PivotChart**: Dynamically analyzes information and summarizes it into a chart.

1. **Make sure that you have the frmEmployees form you modified in the previous lesson open in Form View.**
   
   When you add records on a main form or subform, Access stores the appropriate data in each table. Usually you won’t even realize that you are working with several tables! The subform you added in the previous lesson has enlarged the main form so that it is large enough to display the subform contents. You will need to resize the form window to display the form properly.

2. **Select Window → Size to Fit Form from the menu.**
   Access resizes the window to fit the form. Let’s see how the new subform works.

3. **Click the Next Record navigation button on the main form.**
   Notice that the subform displays tours booked by the current employee.
Also, notice that the main form and sub form each have their own set of navigation buttons that you can use to add and move between records. Try adding a new record to the subform.

4. **Click the New Record button on the subform record navigation bar.**
   
The record indicator jumps to the blank row at the end of the subform datasheet and the blinking insertion point (⏐) appears in the EmployeeID field. Notice that Access has automatically filled in the EmployeeID field with the main form’s EmployeeID.

**NOTE:** If you have set referential integrity between two or more related fields in a subform’s underlying table or query, you will have to obey those referential integrity rules in order to add or edit a record in the subform. For example, you can’t enter a number in the TourID field unless that number exists in the qryCustomerTours query.

5. **Enter a new record in the subform using the following information:**
   
<table>
<thead>
<tr>
<th>EmployeeID</th>
<th>Date</th>
<th>TourID</th>
<th>CustomerID</th>
<th>Number of Tickets</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Current)</td>
<td>9/2/01</td>
<td>China</td>
<td>Ali Chien</td>
<td>2</td>
</tr>
</tbody>
</table>

   It’s easy to switch between the main form and subform: simply click a field or control in the form you want to move to or press <Ctrl> + <Shift> + <Tab>.

6. **Click any field in the main form to move to the main form.**

   Here’s how to modify a subform:

7. **Switch to Design View.**
   
   First get rid of that annoying subform label.

8. **Select the label for the subform and press <Delete>.**

   In Access 2002 you can directly modify subforms from the main form. (Previously, you had to work with subforms in a separate window.)

   First we need to resize some of the unnecessarily large fields in the subform.

9. **In the subform, resize the text fields and corresponding text labels for the TourID, CustomerID, and Number of Tickets fields. Then move the resized text fields and corresponding text labels closer together.**

   Compare your subform to the one in Figure 1-31. Now let’s resize the subform.

10. **Resize the subform window as needed, then click and drag the right edge of the subform to the left to eliminate the wasted, empty space.**

    Here’s how to change the layout of a subform:

11. **Double-click the subform’s form selector in the upper left corner of the subform.**

    The Properties dialog box appears.

12. **Click the Format tab, click in the Default View box, click the button and select Datasheet. Close the Properties dialog box.**

    Now you need to resize the subform control and the main form.

13. **Resize the subform control so that it fits nicely in the main form, and then drag the right edge of the main form to resize it as well.**

    Let’s see how our form looks.

14. **Display the frmEmployees form in Form View.**

    The subform is displayed in continuous form layout instead of Datasheet layout.

15. **Save your changes to the form and close the Lesson 7 database.**

    Whew! We just covered a lot of ground in this chapter. Try moving on to the Chapter Review to see how much you remember.
Chapter One Review

Lesson Summary

Creating a Form with AutoForm

- **To Create a Form with AutoForm:** From the Database window, click the Forms icon in the Objects bar and click the New button. Select the type of form you want to create: Columnar, Tabular, Datasheet, PivotTable, or PivotChart. Click the table or query you want to use for the form from the drop-down list and Click OK.

Modifying a Form

- **To Modify a Form:** From the Database window, click the Forms icon in the Objects bar, click the form you want to modify and click Design, or open the form and click the View button on the toolbar.

Adding and Deleting Fields

- **To Add a Field to a Form:** Display the form in Design View and click the Field List button on the toolbar if necessary, find the field you want to add to the form in the Field List, then click and drag the field to the desired location on the form.
- **To Delete a Field or Control:** Click the field or control to select it and then press <Delete>.

Moving and Sizing Controls

- **To Resize a Control:** Click the control to select it, grab one of its sizing handles, drag and then release the mouse button when the control reaches the desired size. Hold down the <Shift> key while dragging to maintain the control's proportions while resizing it.
- **To Move a Control:** Click the control and hold down the mouse button, drag the control to a new location and then release the mouse button to drop the control.
- **To Move a Text Box or Text Label Independently of Each Other:** Position the pointer over the upper left sizing handle of the control until it changes to a ▽, then click and drag the control.

Changing the Tab Order

- **To Change a Form's Tab Order:** Display the form in Design View and select View → Tab Order from the menu. Click the row selector for the control you want to move and click and drag the row selector to the desired location. Repeat as needed to change the tab order of additional controls.
- **To Automatically Change the Tab Order:** Display the form in Design View and select View → Tab Order from the menu. Click the Auto Order button to automatically reorder the form controls, based on their position in the form.
Working with Control Properties

- **To Display the Properties for Any Control:** Display the form in Design View and do any of the following:
  - Select the control and click the Properties button on the toolbar.
  - Right-click the control and select Properties from the shortcut menu.
  - Select the control and select View → Properties from the menu.

Working with Form Properties

- **To View and Change Form Properties:** Display the form in Design View and double-click the Form Selector. Click the appropriate property tab and property box and make the desired changes.

Working with Multiple Controls

- **To Select Multiple Controls:** Do any of following:
  - Press and hold down the <Shift> key as you click each control that you want to select.
  - Use the arrow pointer (↑) to draw a box around the control that you want to select.
  - If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.

Adding, Cutting, Copying, and Pasting Controls

- **To Add a Control:** Click the Toolbox button on the toolbar if necessary, click the button on the Toolbox for the type of control you want to add, in the Form window, click and drag the pointer where you want the control to appear.

- **To Cut a Control:** Select the control and:
  - Click the Cut button on the toolbar or…
  - Press <Ctrl> + <X> or…
  - Select Edit → Cut from the menu.

- **To Copy a Control:** Select the control and:
  - Click the Copy button on the toolbar or…
  - Press <Ctrl> + <C> or…
  - Select Edit → Copy from the menu.

- **To Paste a Control:** Select the control and:
  - Click the Paste button on the toolbar or…
  - Press <Ctrl> + <V> or…
  - Select Edit → Paste from the menu.

Changing a Control’s Data Source

- **To Change a Control’s Data Source:** Display the Form in Design View, select the control and click the Properties button on the toolbar, or right-click the control and select Properties from the shortcut menu, or select the control and select View → Properties from the menu. Click the Data tab, click the Control Source box, and then either click the arrow and select the field that you want to bind the control to or enter an expression. Close the Properties dialog box when you’re finished.
Creating a Calculated Control

- To Create a Calculated Control: Display the form in Design View, select the control and click the Properties button on the toolbar. Click the Data tab and click in the Control Source box, type the expression or use the Expression Builder to create the expression, and then close the Properties dialog box.

Changing a Control’s Default Value

- To Set a Control’s Default Value: Display the form in Design View, display the properties for the desired control, and click the Data tab. Click the Default Value box and type the default value you want to appear for new records. Close the Properties dialog box when you’re finished.

Using the Control Wizard

- To Create a List Box or Combo Box: Display the form in Design View, click the Toolbox button on the toolbar if necessary and make sure the Control Wizards button on the Toolbox is selected. Click the Combo Box or List Box button on the Toolbox. In the form window, click and drag where you want the control to appear. Specify whether you want the control to get its values from a table or query, or if you want the control to find a record on the form. Select the table that contains the fields you want to include in the list, click Next, select the fields you want to appear in your list and click Next. Adjust the column widths if necessary, click Next. If necessary, specify which column contains the value that will be stored and click Next. Specify whether Access should merely display the value or display it in a field. Enter a label and click Finish.

Creating a Subform

- To Create a Subform: Display the form in Design View, click the Toolbox button on the toolbar if necessary and make sure the Control Wizards button on the Toolbox is selected. Resize the form if necessary, then click the Subform/ Subreport button on the Toolbox and click and drag where you want the subform to appear in the form. Click Next and specify the table or query you want to use for the subform and select the fields you want to appear in the subform. Click Next, specify the parent and child fields that link the main form and subform if necessary, and click Finish.

Modifying and Working with Subforms

- To Modify a Subform: Display the main form in Design View and click inside the subform. Edit the subform as needed. Save your changes to both the main form and the subform.

Quiz

1. Which of the following statements about the AutoForm Wizard is NOT true?
   A. The AutoForm Wizard is the fastest and easiest way to create a form in Microsoft Access.
   B. The AutoForm Wizard can only create five types of forms: Datasheet, Columnar, Tabular, PivotTable, or PivotChart.
   C. Forms created with the AutoForm Wizard usually come out looking sharp and professional and don’t require any further clean-up work.
   D. The AutoForm Wizard can only create forms based on a single table or query.
2. Which of the following statements is NOT true?
   A. The Field List displays all the fields from a form’s underlying table or query.
   B. Click the Field List button on the Toolbar to display the Field List.
   C. You can add fields to a form by dragging them from the Field List onto the form.
   D. The Field List displays all the fields from every table in a database.

3. Controls and their corresponding text labels cannot be moved independently of one another. (True or False?)

4. If you move a control on a form, the Tab Order, in which you advance from one field to the next when you press the <Tab> key, is automatically updated. (True or False?)

5. A form that has a Datasheet Default View property would display one record at a time in the form. (True or False?)

6. A calculated field… (Select all that apply.)
   A. …is a bound control.
   B. …is a control that contains an expression.
   C. …can perform calculations on fields values, such as =[Cost]*[Commission].
   D. …can perform calculations on explicit values, such as =2+4.

7. Which of the following set of tables would benefit from a subform? (Select all that apply.)
   A. A Customer table and the Customer Orders table.
   B. A Customer table and Products table.
   C. A Customer table and Foreign Currency table.
   D. A Customer table and a Customer Contacts table.

8. When you add a subform to a main form, Access always recognizes how the two forms are related (True or False?)

Homework

1. Open the Homework database.
2. Use AutoForm to create and save a columnar form named “Customers,” using the Customers table as the underlying data source.
3. Add a text box control with today’s date in the bottom-right corner of the Customers form.
   Hint: You will need to change the text box control’s data source to the expression =Today()
4. Rearrange the control fields on the form, so that the LastName and FirstName fields appear before the SSN field.
5. Change the Customer form’s tab order to reflect the new field order.
6. Delete the DOB field control from the form.
7. Resize the Customers form as necessary, then use the SubForm Wizard to create a subform based on the Insurance Claims table.
8. Modify the Insurance Claims subform so that its Default View property is Single Form View.

9. Save your changes to the main form and the subform. Then close the form and the Homework database.

**Quiz Answers**

1. C. The AutoForm Wizard can create forms in record time, but they aren’t usually well-organized or professional looking.

2. D. The Field List only displays fields from a form’s underlying table or query.

3. False. You can click and drag the upper left sizing handle to move a label or control independently of one another.

4. False. If you add or move a control on a form, you would have to change the form’s tab order yourself—Microsoft Access won’t do it for you.

5. False. A form whose Default View property was set to Datasheet would display multiple records. A form whose Default View property was set to Single Form would display one record on the form at a time.

6. B, C, and D. All of these statements are true.

7. A and D. Because subforms are great at displaying information from one-to-many relationships, both of these tables would benefit from being displayed in a subform.

8. False. If you include the field that links the two tables, Access will automatically recognize it, if you have already joined the two tables. If the tables aren’t related, you may have to manually join the tables by connecting their related fields.
Chapter Two: Working with Reports

Chapter Objectives:
- Create and modify a report
- Add, delete, move, and size controls
- Adjust page margins and orientation
- Add page numbers and dates
- Work with report sections
- Use reports to group and sort records
- Create and work with report sections
- Add a chart to a report

Chapter Task: Create and modify a variety of reports

Prerequisites
- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify database objects.
- How to add and edit database records.

It’s easy to print a simple list of records in a table or query—just click the Print button on the toolbar. But if you want your printed hard copies to look professional and include calculations, graphics, or a customized header or footer, you’ll need to create a report. Reports present information from tables and queries in a format that looks great when printed.

Reports can also summarize and analyze the information in your database. For example, a report might tell you which of your employees had used the most sick days for the past year. Here are just a few examples of how reports work well for presenting information:

- **Attractive Formatting Options**: You can change the type, size, and color of the fonts used in a report to make it easier to read. You can also add lines, boxes, and graphics to your reports.

- **Sorting and Grouping Options**: Reports are great for summarizing and organizing information. For example, you could create a report to total sales by day, week, or month.

- **Combine Data from Linked Tables**: One report can display data from several related tables or queries.

This chapter explains all the ins and outs of creating and working with reports.
Lesson 2-1: Creating a Report with AutoReport

The fastest and easiest way to create a simple report in Access is with the AutoReport Wizard. The AutoReport Wizard can automatically create a report by arranging all the fields from a table or query into a neatly formatted report.

The AutoReport Wizard is easy to use but limited—it only works with one table or query and there are only two types of reports that it can create, as shown in Figure 2-1. Of course, you can always modify a report created by using the AutoReport Wizard.

In this lesson you will learn how to create a report using an AutoReport Wizard.

1. **Open the Lesson 8 database.**
   
   First, you need to select the Reports icon in the Objects bar in the Database window.
Chapter Two: Working with Reports

2. **Click the Reports icon in the Objects bar, then click the New button.**
   The New Report dialog box appears, as shown in Figure 2-1. You create a report with the AutoReport Wizard by selecting one of the two AutoReport Wizards…

3. **Select AutoReport: Tabular from the list.**
   … and the table or query you want to use for your report.

4. **Click the Choose the table or query where the object’s data comes from: arrow and select qryCustomers from the list.**
   That’s all the information the AutoReport Wizard needs to create your report.

5. **Click OK to create the tabular report.**
   Access takes all the fields in the qryCustomers query, arranges them, and creates a report similar to the one shown in Figure 2-2. Yuck! Ugly-looking report, isn’t it?

6. **Close the report without saving your changes.**
   The reports created by the AutoForm Wizards aren’t very pretty to look at, but they’re fast and easy to create. If you want to have more control over what appears on your report, use the Report Wizard. Either way you will probably want to do some clean-up work, such as renaming the report’s column headings and moving/resizing its controls.

Table 2-1: Available AutoReport Layouts

<table>
<thead>
<tr>
<th>Report Layout</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Columnar</strong></td>
<td>Displays each record’s data vertically. Each field of each record appears on a single line by itself.</td>
</tr>
<tr>
<td><strong>Tabular</strong></td>
<td>Displays each record’s data horizontally. Each field appears in a column.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Customers</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>LastName</strong></td>
<td><strong>FirstName</strong></td>
</tr>
<tr>
<td>Ainsley</td>
<td>Barry</td>
</tr>
<tr>
<td>Alhadeff</td>
<td>Larry</td>
</tr>
<tr>
<td>All</td>
<td>Onion</td>
</tr>
<tr>
<td>Aquino</td>
<td>Kathleen</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Quick Reference**

To Create a Report with AutoReport:

1. From the Database window, click the Reports icon in the Objects bar and click the New button.
2. Select one of the following:
   - AutoReport: Columnar
   - AutoReport: Tabular
3. Click the table or query you want to use for the report from the drop-down list.
4. Click OK.
Lesson 2-2: Modifying a Report

After you create a report (from scratch, using the Report Wizard, or using the AutoReport Wizard), you may decide to modify it to make it easier to read and understand. For example, you might want to add or delete a field, change a column heading, or change the locations of the fields in the report. You modify a report in Design View, which you can get to from:

- **The database window**: Click the Reports icon in the Objects bar to list the reports in the database. Click on the report you want to modify and click the **Design** button.

- **Any report window**: Click the View button on the toolbar or select **View → Design View** from the menu.

This lesson will introduce you to report Design View.

1. **From the Database window**, click the **Reports icon** in the Objects bar if it isn’t already selected, then select the **rptCustomers form** and click the **Design button**.

   The rptCustomers form appears in Design View, as shown in Figure 2-3.

   If you have already worked with forms in Design View, you should be in familiar territory—Design View is remarkably similar for both forms and reports. Just as it is with forms, report Design View is similar to many Paint programs: Think of the report as your canvas and the Toolbox and Field List as the paintbrushes you use to add fields, headings, and lines to the report.

   Any object that appears on a report is called a **control**. A text box used to display record information (usually fields from a table or query) or a column heading are both examples of controls. You add controls to a report by clicking the control you want to use and then clicking and dragging it on the report to draw the control.
Chapter Two: Working with Reports

### Quick Reference

**To Modify a Report:**

1. From the Database window, click the Reports icon in the Objects bar.
2. Click the report you want to modify and click Design.
   
   Or...
   
   Open the report and click the View button on the toolbar.

---

### Table 2-2: Toolbox Buttons and Controls

<table>
<thead>
<tr>
<th>Toolbox Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Select Objects" /></td>
<td>Click this button and then click the control you want to select. To select multiple controls, click this button and hold down the &lt;Shift&gt; key as you click each control, or drag a rectangle shape around all the controls you want to select.</td>
</tr>
<tr>
<td><img src="image" alt="Control Wizards" /></td>
<td>Click to use Control Wizards when you add controls to your report.</td>
</tr>
<tr>
<td><img src="image" alt="Label" /></td>
<td>Creates a text label that appears the same for every record, such as a heading. Most controls already include a text label.</td>
</tr>
<tr>
<td><img src="image" alt="Text Box" /></td>
<td>Creates a text box that displays information from tables and queries in a report.</td>
</tr>
<tr>
<td><img src="image" alt="Option Group" /></td>
<td>Creates a box around a group of option buttons so that the user is only allowed to make one selection from the group box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle Button" /></td>
<td>Creates a toggle button. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><img src="image" alt="Option Button" /></td>
<td>Creates an option button (or radio button) that displays data from two or more options. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><img src="image" alt="Check Box" /></td>
<td>Creates a box that is empty or contains a checkmark. Use to display data from a Yes/No field.</td>
</tr>
<tr>
<td><img src="image" alt="Combo Box" /></td>
<td>Creates a combo box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><img src="image" alt="List Box" /></td>
<td>Creates a list box. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><img src="image" alt="Command Button" /></td>
<td>Creates a button that runs a macro or Visual Basic function. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><img src="image" alt="Image" /></td>
<td>Displays a picture by using a graphic file that you specify.</td>
</tr>
<tr>
<td><img src="image" alt="Unbound Object Frame" /></td>
<td>Inserts an OLE object that is not bound to a field in the current database. Use an Unbound Object Frame to display information from an external source or program, such as a spreadsheet, graphic, or other file.</td>
</tr>
<tr>
<td><img src="image" alt="Bound Object Frame" /></td>
<td>Inserts an OLE object that is bound to a field in the database. Use Bound Object Frames to display pictures or other OLE information in the database.</td>
</tr>
<tr>
<td><img src="image" alt="Page Break" /></td>
<td>Inserts a page break.</td>
</tr>
<tr>
<td><img src="image" alt="Tab Control" /></td>
<td>Creates a tab control. Normally used in forms, not reports.</td>
</tr>
<tr>
<td><img src="image" alt="Subform/Subreport" /></td>
<td>Inserts another report within the main report. Use when you want to show data from a one-to-many relationship.</td>
</tr>
<tr>
<td><img src="image" alt="Line" /></td>
<td>Enables you to draw a line in the report.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle" /></td>
<td>Enables you to draw a rectangle in the report.</td>
</tr>
<tr>
<td><img src="image" alt="More Controls" /></td>
<td>Click to display other toolboxes and OLE objects.</td>
</tr>
</tbody>
</table>
Lesson 2-3: Adding and Deleting Fields

Once you have created a report, you can delete a field that you don’t need or make a report more comprehensive by adding more fields to display additional information.

In this lesson you will modify an existing report by adding and deleting fields.
1. Make sure you have the rptCustomers report open in Design View. Maximize the report window.
First, click the control you want to delete.

2. **Click the DOB text box to select it.**
Handles (■) appear around the control, indicating that the control is selected.

3. **Press the <Delete> key to delete the DOB text box.**
The DOB text box disappears from the report screen.

Unfortunately, adding fields to a report isn’t quite as easy…

4. **If the Field List isn’t displayed, click the Field List button on the toolbar.**
The Field List displays all the fields from the table or query you used to create the report—though you will often have to scroll down the Field List to find the field that you want. Once the Field List is displayed, you can click and drag the field you want to add from the Field List onto the report, as shown in Figure 2-4.

5. **Scroll down the Field List until you find the ZipCode field. Click and drag the ZipCode field to the right of the State field, as shown in Figure 2-5, then release the mouse button.**
The ZipCode field appears on the report with less than desirable results, as shown in Figure 2-5. An annoyance with adding controls to a report is that you almost always have to do some clean-up work afterwards. For example, the ZipCode field has an unneeded text label, isn’t positioned correctly, and has enlarged the Detail section of the report. Don’t worry about the positioning for now—you’ll learn how to move controls in the next lesson. We can fix some of the other problems, however, starting with getting rid of the text label.

6. **Click the ZipCode text label (NOT the actual ZipCode field or text box!) and press <Delete>.**
Before we’re finished, we have to give the ZipCode field a more meaningful text heading. Here’s how:

7. **Click the DOB text label to select it.**

8. **Position the pointer over the DOB text label until it changes into a I, and then click inside the text label.**
Now you can edit the text label.

9. **Replace the text label text with Zip Code.**
Let’s see how the modified report looks.

10. **Click the View button on the toolbar to display the report in Print Preview.**
Compare your report with the one in Figure 2-7.

11. **Save your changes by clicking the Save button on the toolbar.**
Lesson 2-4: Moving and Sizing Controls

It’s easy to change the location and size of a control on a report—and it’s something you will usually have to do whenever you add a control, since Access rarely places things exactly right in the first place. When you size a control, you increase or decrease the amount of information the control can display. When you select a control on a report, sizing handles appear around the edges of the control. Once you have selected a control, you can drag its sizing handles to adjust the size of the control or move the control to a new location on the report.

This lesson will give you some experience moving and sizing the controls on the report you created in the previous lesson.

1. **Make sure that you have the rptCustomers report open.**
   You need to be in Design View to modify a report.

2. **If you’re not in Design View, click the View button on the toolbar.**
   You need to select a control before you can move or size it.

3. **Click the ZipCode text box to select it.**
   Sizing handles appear around the selected ZipCode field. Here’s how to move a control:

4. **Position the pointer on any border of the ZipCode text box (but not over a sizing handle) until it changes to a hand.**
   When the mouse pointer changes to a hand, it means that you can drag and drop the control to a new location.

   **NOTE:** It takes a good deal of precision to position the pointer over the tiny border of a field. Move the pointer very slowly and wait until you see it turn into a hand before you try to move the control.
5. Click and hold down the mouse button while the pointer is still over the border of the ZipCode text box. Drag the field directly to the right of the State text box, as shown in Figure 2-8, then release the mouse button.

By simply dragging and dropping with the mouse, you can move any object on a report—any shapes, lines, pictures, or text boxes.

Sometimes, after moving an object, you’ll find you want to move the object just a smidgen. You can use the keyboard to move or nudge controls with greater precision. Simply hold down the <Ctrl> key as you press any of the arrow keys on the keyboard.

6. With the ZipCode text box still selected, hold down the <Ctrl> key and press the ← (left arrow) key.

The ZipCode text box moves to the left a smidgen.

7. Make sure the ZipCode text box is still selected. Position the pointer over the middle-right sizing handle until it changes to a ←. Click and hold down the mouse button and drag to the left until the label is about two-thirds of its original size, then release the mouse button.

As you drag a control’s sizing handle, a dotted outline appears to help you resize it. That’s all there is to moving and sizing controls on a report.

8. Click the Save button on the toolbar to save your changes.

Quick Reference

To Resize a Control:
- Click the control to select it, grab one of its sizing handles, drag and release the mouse button when the control reaches the desired size.
- Hold down the <Shift> key while dragging to maintain the control’s proportions while resizing it.

To Move a Control:
- Click the control and hold down the mouse button, drag the control to a new location and then release the mouse button to drop the control.

To Copy a Control using Drop and Drag:
- Follow the same procedures as moving an control, only hold down the <Ctrl> key while you drag the control.
Lesson 2-5: Adjusting Page Margins and Orientation

You’re probably already aware that margins are the empty space between the text and the left, right, top, and bottom edges of a printed page. The default margins for a report are one inch at the top, bottom, left, and right. There are many reasons to change a report’s margins: To make room for more data, to add some extra space if you’re binding a document, or to leave a blank space to write in notes. If you don’t already know how to adjust a page’s margins, you will after this lesson.

This lesson also explains how to change the page orientation. Everything you print uses one of two different types of paper orientations: portrait and landscape. In Portrait orientation, the paper is taller than it is wide—like a painting of a person’s portrait. In Landscape orientation, the paper is wider than it is tall—like a painting of a landscape.

1. Make sure that you have the rptCustomers report open in Design View.
   Here’s how to modify the page setup for a report:
2. Click **File → Page Setup** from the menu and click the **Margins tab** if it is not already in front.

   The Margins tab of the Page Setup dialog box appears, as shown in Figure 2-9. Here you can view and adjust the margin sizes for the current worksheet. Notice that there are margins settings in the Top, Bottom, Left, and Right boxes.

3. **Click the Top Margin box and type .5.**

   This will change the size of the top margin from 1.0" to 0.5".

4. **Repeat Step 2 and change the Bottom, Left, and Right margins to 0.5 inches.**

   Do you think you have a handle on changing a report’s margins? Good, because without further ado, we’ll move on to page orientation.

5. **Click the Page tab.**

   The Page tab appears, as shown in Figure 2-11.

6. **In the Orientation area, click the Landscape option button.**

   This will change the worksheet’s orientation to Landscape when it is printed.

7. **Click OK.**

   The Page Setup dialog box closes, and the report’s margins and page orientation settings are changed.

   When you change a report’s margins, you will usually want to resize the report itself—here’s how:

8. **If necessary, scroll to the right edge of the report. Click and drag the right edge of the report to the right to the 7.5 inch mark on the ruler.**

   Let’s see how the newly formatted report looks.

9. **Click the View button on the Form Design toolbar.**

   The report is previewed on the screen—and it’s easy to see the new landscape orientation. You can reduce or enlarge the display by clicking the area of the report you want to magnify with the pointer.

10. **Move the pointer over an area of the report and click the mouse button. Click the mouse button again when you have finished looking at the enlarged area.**

    Once again, Access displays the entire report.

11. **Save the changes you’ve made to the report.**

---

**Quick Reference**

To Adjust Margins:

1. Select **File → Page Setup** from the menu and click the **Margins tab.**
2. Adjust the appropriate margins.

To Change a Page’s Orientation:

1. Select **File → Page Setup** from the menu, and click the **Page tab.**
2. In the Orientation section, select either the Portrait or Landscape option.
Lesson 2-6: Adding Page Numbers and Dates

Make sure that you have the rptCustomers report open in Design View.

Select Insert → Page Numbers from the menu.

The Page Numbers dialog box appears, as shown in Figure 2-13. The Page Numbers dialog box gives you several choices for how the page numbers can be formatted:

- **Page N**: Prints only the page number (for example, “Page 5.”)
- **Page N of M**: Prints the page number and the total number of pages (for example, “Page 5 of 15.”)

Reports that are several pages long often have information such as the page number or the date located at the top (header) or bottom (footer) of every page. In this fast and easy lesson you will learn how to use the Page Number command and Date and Time command to add page numbers and/or the current date to your report.
3. **Select the Page N of M option.**
   Next you need to specify where on the page you want the page number to appear—at the top or bottom of the page—and how you want the page numbers aligned.

4. **Select the Bottom of Page option and select Right from the Alignment list.**
   That’s all there is to adding page numbers to a report.

5. **Click OK to close the Page Numbers dialog box.**
   The Page Numbers dialog box closes, and Access adds a text box with a page number expression (="Page " & [Page] & " of " & [Pages]) to the Page Footer.

6. **Select Insert → Date and Time from the menu.**
   The Date and Time dialog box appears, as shown in Figure 2-14. You can specify to add the date, time, or both to your reports. For this exercise, you only want the current date to appear on your report.

7. **Click the Include Time check box to remove its check mark.**
   Just like the Page Number dialog box, the Date and Time dialog box gives you several choices for how the date and/or time can be formatted. The currently selected date format (the first option) will work fine here so you can close the Date and Time dialog box.

8. **Click OK to close the Date and Time dialog box.**
   The Date and Time dialog box closes and Access adds a text box with a date number expression [=Date()] to the Report Header.

9. **Click and drag the Date control [=Date()] to the far right side of the report header.**
   Let’s see how our modified report looks.

10. **Click the View button on the Form Design toolbar.**
    The report is previewed on the screen, and you can see the date and, if you scroll down, the page numbering.

11. **Save the changes you’ve made and close the rptCustomers report.**

---

**Quick Reference**

**To Add Page Numbers:**

1. Display the report in Design View.
2. Select Insert → Page Numbers from the menu.
3. Select the page-number format, position, and alignment options.
4. Click OK.

**To Insert the Date and/or Time:**

1. Display the report in Design View.
2. Select Insert → Date and Time from the menu.
3. Check or uncheck the Include Date box and select a formatting option.
4. Check or uncheck the Include Time box and select a formatting option.
5. Click OK.
Lesson 2-7: Understanding Report Sections

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 2-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word-processing program to create a report for school or work, you’re familiar with the section concept—you can add headers and footers to your documents that contain such information as the report name or page number.

1. Double-click the rptAnnualSales report to open it in Print Preview.
   A report’s sections aren’t as easy to see in Print Preview, but they’re still there. Let’s examine this report, from top to bottom…
   - First notice the “Annual Sales Report” title. In this report the title appears in the Report Header section, so it will appear at the top of the first page of the report.
   - Next take a look at the column headings (“Tour,” “Date,” etc.). These column headings are in the Page Header section and will appear on top of each page.
   - Next come the tour names, which appear in the Group Header section. You use group header and group footer sections to group related records together. Reports may have more than one group section to create subgroups.
   - Here’s what the report’s all about: the Detail section. The Detail section contains the actual records shown in the report.

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 2-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word-processing program to create a report for school or work, you’re familiar with the section concept—you can add headers and footers to your documents that contain such information as the report name or page number.

1. Double-click the rptAnnualSales report to open it in Print Preview.
   A report’s sections aren’t as easy to see in Print Preview, but they’re still there. Let’s examine this report, from top to bottom…
   - First notice the “Annual Sales Report” title. In this report the title appears in the Report Header section, so it will appear at the top of the first page of the report.
   - Next take a look at the column headings (“Tour,” “Date,” etc.). These column headings are in the Page Header section and will appear on top of each page.
   - Next come the tour names, which appear in the Group Header section. You use group header and group footer sections to group related records together. Reports may have more than one group section to create subgroups.
   - Here’s what the report’s all about: the Detail section. The Detail section contains the actual records shown in the report.

As if reports weren’t confusing enough as a whole, Access breaks them up into separate parts called sections. Each section has its own specific purpose and always prints in the same order on a report. Take a look at Table 2-3: Report Sections to familiarize yourself with these sections. If you’ve ever used a word-processing program to create a report for school or work, you’re familiar with the section concept—you can add headers and footers to your documents that contain such information as the report name or page number.

1. Double-click the rptAnnualSales report to open it in Print Preview.
   A report’s sections aren’t as easy to see in Print Preview, but they’re still there. Let’s examine this report, from top to bottom…
   - First notice the “Annual Sales Report” title. In this report the title appears in the Report Header section, so it will appear at the top of the first page of the report.
   - Next take a look at the column headings (“Tour,” “Date,” etc.). These column headings are in the Page Header section and will appear on top of each page.
   - Next come the tour names, which appear in the Group Header section. You use group header and group footer sections to group related records together. Reports may have more than one group section to create subgroups.
   - Here’s what the report’s all about: the Detail section. The Detail section contains the actual records shown in the report.
• After the Detail section come the report’s footer sections. You don’t need a guided tour of the report’s footer sections, as they are really just the same as the report’s header sections, only in reverse.

It’s difficult to see and appreciate report sections in Print Preview, so move on to the next step and we’ll get a “behind the scenes look” at the report.

2. **Click the View button on the toolbar to switch to Design View.**
   Access displays the rptAnnualSales report in Design View, as shown in Figure 2-15. Now it’s easy to see the report sections—what a difference a change in perspective makes! To better illustrate how information is displayed in report sections, we will add a couple of identifying text boxes to the report.

3. **Click the Label button on the Toolbox.**
   The pointer changes to the \^A label tool. Click and drag where you want the label.

4. **Position the \^A pointer in the far-left side of the Detail section (to the left of the Date field). Click and drag the text label and type Detail.**
   Since you added the text label to the report’s Detail section, it will appear with each record. Move on to the next step and we’ll add an identifying text label to another report section. It’s often easier to copy an existing control and then modify it than it is to create a new control from scratch. Here’s how to do it:

5. **Select the Detail label, click the Copy button on the toolbar, click the TourName Footer section line and click the Paste button on the toolbar.**
   Access pastes the Detail label in the report’s TourName Group Footer.

6. **Change the copied label’s text to Group Footer.**
   Let’s see where these text labels will appear on the report.

7. **Click the View button to switch to Print Preview.**
   Access displays the report in Print Preview.

8. **Scroll down the report and notice where the Detail and Group Footer labels appear. Close the report without saving your changes when you finish.**

---

### Table 2-3: Report Sections

<table>
<thead>
<tr>
<th>Resolution</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Header</td>
<td>Contains text that appears at the top of the first page of a report, such as the name of the report.</td>
</tr>
<tr>
<td>Page Header</td>
<td>Contains text that appears at the top of each page of a report, such as the report’s column headings.</td>
</tr>
<tr>
<td>Group Header</td>
<td>Used to place text, such as a group name, at the beginning of each group of records.</td>
</tr>
<tr>
<td>Detail</td>
<td>Contains text and the actual fields that are displayed for each record. This would be equivalent to the main body in a word-processing document.</td>
</tr>
<tr>
<td>Group Footer</td>
<td>Used to place text and numeric summaries, such as totals or averages, at the end of each group of records.</td>
</tr>
<tr>
<td>Page Footer</td>
<td>Contains text that appears at the bottom of each page of a report, such as page numbers.</td>
</tr>
<tr>
<td>Report Footer</td>
<td>Contains text that appears at the end of the last page of a report. Often also contains numeric summaries for the report, such as a grand total.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To Resize a Report Section:
1. Display the report in **Design View**.
2. Click and drag the **section line** up or down.

Understanding Report Sections:
- Be familiar with the various report sections described in Table 2-3: Report Sections.
Lesson 2-8: Grouping and Sorting Records

Organizing records into logical groups often makes them easier to read and understand. For example, the second report in Figure 2-17 is grouped by the date field, so that you can quickly see how many sales occurred in a particular month. If you create a report using the Report Wizard (the preferred method), you specify which fields you want to use to group and/or sort your report by. If you're modifying an existing report or creating a report from scratch, you can use the Sorting and Grouping dialog box to create your groups. More importantly, if you use a Wizard to create a report for you, you can use the Sorting and Grouping dialog box to change the grouping and sorting options for the report.

1. Open the **rptEmployeeSales** report in Design View.
   In its current state the **rptEmployeeSales** report has Report Header, Page Header, Page Footer, and Report Footer sections, but it doesn’t have any grouping sections. To add a Group Section to a report you need to summon the Sorting and Grouping dialog box.

2. Click the **Sorting and Grouping button** on the Report Design toolbar.
   Access displays the Sorting and Grouping dialog box, which displays any fields that are currently being used for sorting or grouping your report, as shown in Figure 2-18. To add a section to group and/or sort by, select a blank row and select a field from the Field/Expression drop-down list. In this exercise you will use the Employee field to group and sort the report.

Figure 2-17
Grouping records by a specific field makes them easier to read. Compare the report that is grouped by date with the report that isn't.

Figure 2-18
The Sorting and Grouping dialog box. You can learn more about its details in Table 2-4: Sorting and Grouping Properties.

= Sorting and Grouping button =
Other Ways to Sort and Group:
- Select **View → Sorting and Grouping** from the menu.
3. **Click inside the first blank row and select Employee from the Field/Expression drop-down list.**
   You can also specify the order in which Access sorts the records by selecting the order you want to sort by (Ascending or Descending) from the Sort Order list. Since you want to sort the Employee field in Ascending order, you can leave the Sort Order alone. To make a Group Header or Group Footer, use the Group Properties settings at the bottom of the dialog box. You want to add a Group Header for the Employee field—here’s how to add one:

4. **With the Employee Field/Expression still selected, click the Group Header list near the bottom of the dialog box and select Yes from the drop-down list.**
   Access adds an Employee Group Header to the report.
   The order of the fields in the Sorting and Grouping dialog box is very important. The field in the first row is the first sorting/grouping level, the second row is the second sorting/grouping level, and so on. You want to group and sort your report by the Employee field, then by the Date field, so you will have to rearrange the field order.

5. **Click the Employee row selector, drag it above the Date row, and release the mouse button. Then close the Sorting and Grouping dialog box.**
   Now that you have created the Group Header, you need to specify what you want to appear in it—usually the field the Group Header is based on. In this report you will want to move the Employee text box control field from the Detail section to the Employee Group Header section.

6. **Cut the Employee field from the Detail section and paste it in the Employee Header section.**
   Let’s see how the modified report looks.

7. **Click the View button to switch to Print Preview.**
   Access groups and sorts the report by the Employee field.

---

<table>
<thead>
<tr>
<th>Group Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Header</td>
<td>Specify whether you want the report to contain a header section for this group.</td>
</tr>
<tr>
<td>Group Footer</td>
<td>Specify whether you want the report to contain a footer section for this group.</td>
</tr>
<tr>
<td>Group On</td>
<td>Allows you to choose the size of the group. For example, if you're using a date field to group a section, you can group each value by day, week, month, or year.</td>
</tr>
<tr>
<td>Group Interval</td>
<td>Allows you to choose the size of the interval from a drop-down list. You must have chosen an option other than Each Value from the Group On list.</td>
</tr>
<tr>
<td>Keep Together</td>
<td>No: Prints the group without keeping the group header, detail section, and group footer on the same page. Whole Page: Prints the group header, detail section, and group footer on the same page. With First Detail: Prints the group header on a page only if it can also print the first detail record.</td>
</tr>
</tbody>
</table>
Lesson 2-9: Creating Calculated Controls

Footers are most often used to summarize report information. For example, a Group Footer could total the number of harassing phone calls each telemarketer made and the Report Footer could calculate the number of harassing phone calls made by all telemarketers.

If you create a report using the Report Wizard (the preferred method), you specify which fields you want to summarize and the calculation you want to use to summarize them. Of course, you can always add your calculated control or calculated field to summarize information on an existing report. A calculated control displays totals and other arithmetic computations on a form or report. Table 2-5: Common Summary Functions describes the functions you will use most often to summarize your reports.

1. Make sure you have the modified rptEmployeeSales report you worked on in the previous lesson open in Design View.

The section footer in which you place a calculated control is very important, as each footer section calculates/summarizes records differently:

- **Group Footer**: Calculates all the records in a group.
- **Page Footer**: Calculates all the records on the page.
- **Report Footer**: Calculates all the records in the report.

You want to add a calculated control to the Report Footer that will calculate the total sales for all records. First though, you will need to resize the Report Footer so that there is enough room to add such a control. Here’s how to change the size of a section.

2. Click and drag the Report Footer section divider down a half-inch.

Now that you have enough room in the Report Footer you can add the calculated control. There are two ways to add a calculated control to a form or report:

- Click the `Text Box` control on the Toolbox and click and drag where you want to add the control.
- Copy an existing text box control, select the desired location, and paste the copied text box control.
You can use either method, but the copy and paste method is a little faster and easier because it copies formatting options and gives the new control a consistent look.

3. Select the Total text box control in the Detail section and click the Copy button on the toolbar. Click the Report Footer section divider and click the Paste button on the toolbar.
   Access pastes the copied control. Next you have to add an expression to the control.

4. With the new Total text box in the Report Footer still selected, click the Properties button on the toolbar.
   The Properties dialog box appears. You need to enter the expression in the Control Source property, which you can find on the Data tab.

5. Click the Data tab, click in the Control Source box, type =SUM([Total]), and close the Properties dialog box.
   You’re finished adding a calculated control that will total the Total fields on the report.
   Next you want to add another footer and calculated control that will total the total sales by employee. First you need to add an Employee Group Footer section to your report.

6. Click the Sorting and Grouping button on the toolbar.
   The Sorting and Grouping dialog box appears.

7. Click in the Employee Field/Expression box, click the Group Footer box, select Yes, and then close the Sorting and Grouping dialog box.
   Because the Total text box control you created in Steps 3–5 already contains the SUM expression you need, you can simply copy and paste the control in the Group Footer.

8. Copy the Total text box control in the Report Footer section, click the Employee Footer section divider, and paste the control.
   You need to add some meaningful labels to your report. Often, it’s useful to add a calculated control that mixes some text with the current value of a field to produce an informative notice for the report.

9. Copy the Total text box control in the Employee Footer section and paste it in same section. Change the Data Source property of the pasted control to ="Total for " & [Employee].
   This expression will display the text “Total for” and the employee’s name. Let’s finish tidying up the report.

10. Add a Grand Totals: text label to the Report Footer section, then click and drag the three new calculated fields and one text label so that your report looks like the one in Figure 2-20.
    Let’s see how our report looks.

11. Click the View button to switch to Print Preview. Scroll down and notice the calculated controls. When you’re finished, save your changes and close the report.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Totals all the values listed in a field.</td>
<td>Sum([InvoiceTotal])</td>
</tr>
<tr>
<td>Maximum</td>
<td>Finds and displays the largest value listed in a field.</td>
<td>Max([InvoiceTotal])</td>
</tr>
<tr>
<td>Minimum</td>
<td>Finds and displays the smallest value listed in a field.</td>
<td>Min([InvoiceTotal])</td>
</tr>
<tr>
<td>Average</td>
<td>Calculates the average of all the values listed in a field.</td>
<td>Avg([InvoiceTotal])</td>
</tr>
<tr>
<td>Count</td>
<td>Counts how many values are listed in a field.</td>
<td>Count([InvoiceTotal])</td>
</tr>
</tbody>
</table>

Quick Reference

To Create a Calculated Control:
1. Display the report in Design View.
2. Select the control and click the Properties button on the toolbar.
   Or...
   Right-click the control and select Properties from the shortcut menu.

Or...
Select the control and select View → Sorting and Grouping from the menu.

3. Click the Data tab and click in the Control Source box.
4. Type the expression in the Control Source (see Table 2-5: Common Summary Functions for some examples).
   Or...
   Click the Build button and use the Expression Builder to create the expression, then click OK when you’re finished.

5. Close the Properties dialog box.
Lesson 2-10: Working with Section Properties

When you want to fine-tune how a group or section works, there are two different places to go:

- **The Sorting and Grouping dialog box**: Contains important sorting and grouping settings, such as if you want your report to display any Group Headers and/or Footers. To display the Group Properties dialog box, click the Sorting and Grouping button on the toolbar.

- **The Section Properties dialog box**: Contains miscellaneous properties for each report section, such as the section’s background color. To display the properties or settings for a report section, click the section divider line and then the Properties button on the toolbar, or right-click the section divider line and select Properties from the shortcut menu, or double-click the section divider line.

Some of the settings you might want to adjust might be the Group Interval property (especially for sections grouped by date fields) and the Force New Page property, which tells Access to start a new page before or after each report section.

In this lesson you will learn how to tweak your report section settings.

1. **Double-click the rptSalesByMonth report to open it in Print Preview.**
   
   In this report Access uses the Date field to group records—Access creates a Date group for each Date value, or day. The report would be meaningful if Access grouped dates by month. Before we can change the report, we need to switch to Design View.

2. **Click the View button on the toolbar to switch to Design View.**
   
   You can change the grouping interval to specify how records are grouped in a report in the Sorting and Grouping dialog box.

3. **Click the Sorting and Grouping button on the toolbar.**

   The Sorting and Grouping dialog box appears, as shown in Figure 2-21. The Group On property lets you specify how you want to group records. For example, you can use the Group On property to group a Date field by year.

   Let’s change the Date Group Interval so that the report groups sales on a monthly basis.
4. Click in the Date Field/Expression box, click in the Group On box, select Month from the list, and then close the dialog box.

You won’t be able to see any of the grouping changes until you display the report in Print Preview—and we’ll do that in a minute. Every report section has its own set of properties or settings that you can view and change. You can view the properties for a report section by double-clicking the section’s divider line.

5. **Double-click the Date Header section divider line.**

Access displays the properties for the Date Header section, as shown in Figure 2-22. Table 2-6: *Important Section Properties* describes these options in more detail.

6. **Click the Format tab.**

We want to change the background color of the section. Here’s how to do it.

7. **Click the Back Color box, click the button, select a gray color and then close the dialog box.**

Let’s see how the modified report looks.

8. **Click the View button on the toolbar to display the report in Print Preview. Scroll through the report’s pages and notice how the Date Section is now grouped by month.**

9. **Save your changes and close the report.**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force New Page</td>
<td>Allows you to tell Access to start a new page before or after this section whenever the group changes.</td>
</tr>
<tr>
<td>New Row Or Col</td>
<td>Works the same as the Force New Page property when you’re printing a report in columns.</td>
</tr>
<tr>
<td>Keep Together</td>
<td>Used to specify whether you want to allow Access to put breaks when they occur naturally (No) or forces Access to keep the entire section on one page when possible (Yes).</td>
</tr>
<tr>
<td>Visible</td>
<td>Used to specify if you want to see the section (Yes) or not (No). Hiding a report's Detail Section is useful when you want to create a summary report that uses a Group Footer to total database information without displaying the individual records.</td>
</tr>
<tr>
<td>Can Grow</td>
<td>Used to specify whether the section can grow larger to accommodate more data in the last field in the section (the field control Can Grow property must also be set to Yes).</td>
</tr>
<tr>
<td>Can Shrink</td>
<td>Enables the section to grow smaller if the extra space is not needed. (Used in conjunction with the Can Shrink property for a field control.)</td>
</tr>
<tr>
<td>Repeat Section</td>
<td>When a group is split across several pages use the Repeat Sections property to specify if Access should repeat the heading on the new page.</td>
</tr>
<tr>
<td>Height</td>
<td>Access automatically sets this property as you drag the section divider up or down on the screen. You can specify an exact size (for example, if you want the section to be precisely three inches tall) by entering it here.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Used to specify the color of the section. Click the button to select the color.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Adjusts the visual effects for the section. Your choices are limited to Flat (the default setting), Raised, or Sunken.</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

To **Modify a Report’s Section and Grouping Options:**
1. Display the report in **Design View**.
2. Click the **Sorting and Grouping** button on the Report Design toolbar.

To **Modify a Section’s Properties:**
1. Display the report in **Design View**.
2. Double-click the section **line** for the section whose properties you want to view/modify.
Lesson 2-11: Creating Charts with the Chart Wizard

You already know what a chart is—charts illustrate data, relationships, or trends graphically. Like the saying “a picture is worth a thousand words,” charts are often better at presenting information than hard-to-read numbers in a datasheet. Microsoft Access comes with a great built-in program for creating charts called Microsoft Graph. You can insert charts and graphs on forms and reports, and this lesson will show you how.

1. **Click the Reports icon in the Objects bar of the Database window and click the New button.**
   The New Report dialog box appears.

2. **Select Chart Wizard from the list, select qryCustomerTours from the Table or Query drop-down list, and click OK.**
   The first screen of the Chart Wizard appears. Here you have to tell the Wizard which fields you want to display on the chart.

3. **Double-click the TourName field in the Available Fields list.**
   The TourName field appears in the Fields for Chart list.

4. **Click Next.**
   The Chart Wizard asks what type of chart you want to use to display your data, as shown in Figure 2-23. Table 2-7: Types of Charts and Graphs shows the more common charts and gives an explanation on how and when they are used.
5. Select the Pie Chart as shown in Figure 2-23 and click Next.

Next the Chart Wizard asks how you want to lay out the data in your chart. You do this by dragging and dropping the data fields to the appropriate areas on the chart. Since we chose a simple pie chart, everything is already correctly laid out for us.

6. Click Next.

You can specify a chart title if you’re not thrilled with Microsoft Access’ imaginative suggestions. You can also specify if you want to include a legend with your chart.

7. Click in the What title would you like for your chart? box and type Total Tours. Click Finish to create the pie chart.

Access creates the pie chart, shown in Figure 2-24.

NOTE: The Microsoft Graph program seems to have some bugs, so the legend of your chart may be missing some items.

8. Exit Microsoft Access without saving any changes.

Table 2-7: Types of Charts and Graphs

<table>
<thead>
<tr>
<th>Chart or Graph Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td>Column charts are used when you want to compare different values vertically side by side. Each value is represented in the chart by a vertical bar. If there are several values in an item, each value is represented by a different color.</td>
</tr>
<tr>
<td>Bar</td>
<td>Bar charts are just like column charts, except they display information in horizontal bars rather than vertical columns.</td>
</tr>
<tr>
<td>Line</td>
<td>Line charts are used to illustrate trends. Each value is plotted as a point on the chart and is connected to other values by a line. Multiple items are plotted using different lines.</td>
</tr>
<tr>
<td>Area</td>
<td>Area charts are the same as line charts, except the area beneath the lines is filled with color.</td>
</tr>
<tr>
<td>Pie</td>
<td>Pie charts are useful for showing values as a percentage of a whole. The values for each item are represented by different colors.</td>
</tr>
<tr>
<td>Scatter</td>
<td>Scatter charts are used to plot clusters of values using single points. Multiple items can be plotted by using different colored points or different point symbols.</td>
</tr>
<tr>
<td>Combination</td>
<td>Combination charts combine two different types of charts together (for example, a combination chart might contain both a column chart and a line chart).</td>
</tr>
</tbody>
</table>
Chapter Two Review

Lesson Summary

Creating a Report with AutoReport

- **To Create a Report with AutoReport:** From the Database window, click the Reports icon in the Objects bar, click the New button, and select either AutoReport: Columnar or AutoReport: Tabular. Click the table or query you want to use for the report from the drop-down list and Click OK.

Modifying a Report

- **To Modify a Report:** From the Database window, click the Reports icon in the Objects bar, click the report you want to modify and click Design, or open the form and click the View button on the toolbar.

Adding and Deleting Fields

- **To Add a Field to a Report:** Display the report in Design View and click the Field List button on the toolbar if necessary, find the field you want to add to the report in the Field List, then click and drag the field to the desired location on the report.

- **To Delete a Field or Control:** Click the field or control to select it and press <Delete>.

Moving and Sizing Controls

- **To Resize a Control:** Click the control to select it, grab one of its sizing handles, and drag and then release the mouse button when the control reaches the desired size. Hold down the <Shift> key while dragging to maintain the control's proportions while resizing it.

- **To Move a Control:** Click the control and hold down the mouse button, drag the control to a new location and then release the mouse button to drop the control.

- **To Move a Text Box or Text Label Independently of Each Other:** Position the pointer over the upper left sizing handle of the control until it changes to a ♡, then click and drag the control.

Adjusting Page Margins and Orientation

- **To Adjust Margins:** Select File → Page Setup from the menu and click the Margins tab, adjust the appropriate margins.

- **To Change a Page's Orientation:** Select File → Page Setup from the menu, and click the Page tab. In the Orientation section, select either the Portrait or Landscape option.

Adding Page Numbers and Dates

- **To Add Page Numbers:** Display the report in Design View, select Insert → Page Numbers from the menu, select the page-number format, position, and alignment options, and click OK.
To Insert the Date and/or Time: Display the report in Design View, select Insert → Date and Time from the menu, check or uncheck the Include Date box and select a formatting option. Check or uncheck the Include Time box, select a formatting option, and click OK.

Understanding Report Sections

To Resize a Report Section: Display the report in Design View, then click and drag the section line up or down.

Grouping and Sorting Records

To Group Records: Display the report in Design View, Click the Sorting and Grouping button on the Report Design toolbar. Click the Field/Expression box, click the drop-down list, and select a field for grouping records, click the corresponding Sort Order box, click the drop-down list, select the desired sort order, and select any Group Properties you want to use in the Group Properties area. Repeat these steps for each Field/Expression you want to use to group and sort your data. Close the Sorting and Grouping dialog box when you’re finished.

Creating Calculated Controls

To Create a Calculated Control: Display the form in Design View, select the control and click the Properties button on the toolbar. Click the Data tab, click in the Control Source box, type the expression, and then close the Properties dialog box.

Working with Section Properties

To Modify a Report’s Section and Grouping Options: Display the report in Design View, and then click the Sorting and Grouping button on the Report Design toolbar.

To Modify a Section’s Properties: Display the report in Design View, and then double-click the section line for the section whose properties you want to view/modify.

Creating Charts with the Chart Wizard

To Insert a Chart into a Report: Display the report in Design View, select Insert → Chart from the menu, and then drag and drop a chart on the report, which opens the Chart Wizard. Select the table or query you want to chart from the Table or Query drop-down list. Click Next to continue. Double-click each field you want to add to the chart. Click Next to continue, click the chart type you want, and click Next to continue. Make any layout modifications to the chart. Click Next to continue. If you want the chart to change from record to record, select the fields that link the document and the chart. Click Next to continue, enter a chart name, and then click Finish.

Quiz

1. Which of the following statements about the AutoReport Wizard is NOT true?

   A. The AutoReport Wizard is the fastest and easiest way to create a report in Microsoft Access.
   B. The AutoReport Wizard can only create two types of reports: Columnar and Tabular.
   C. Reports created with the AutoReport Wizard usually come out looking sharp and professional and don’t require further clean-up work.
   D. The AutoReport Wizard can only create reports based on a single table or query.
2. Which of the following statements is NOT true?
   A. The Field List displays all the fields from a report’s underlying table or query.
   B. Click the Field List button on the Toolbar to display the Field List.
   C. You can add fields to a report by dragging them from the Field List onto the report.
   D. The Field List displays all the fields from every table in a database.

3. Controls and their corresponding text labels cannot be moved independently of one another. (True or False?)

4. Which of the following statements is NOT true?
   A. You can move a control to a different location on a report by clicking, dragging, and dropping the control.
   B. To add a page number to a report, select View → Header/Footer from the menu and click the Page Number button on the Header/Footer toolbar.
   C. You can resize a report by clicking and dragging the right edge of the report.
   D. You can resize a control by clicking the control to select it, grabbing one of its sizing handles, and dragging and releasing the mouse button when the control reaches the desired size.

5. You want a report to group and total sales by month. Where would you place a calculated control containing the following expression 
   \( =\text{SUM}([\text{Sales}]) \) to calculate the totals for each month?
   A. In the Month Group Footer section.
   B. In the Page Footer section.
   C. In the Report Footer section.
   D. In the Summary section.

6. Which of the following is NOT a report section?
   A. Report Header section.
   B. Page Header section.
   C. Summary section.
   D. Detail section.

7. The only way to sort a report’s records is to base the report on a query, which actually does the work of sorting the records. (True or False?)

8. Which of the following expressions is incorrect?
   A. \( =\text{Total for}: [\text{Employee}] \).
   B. \( =[\text{InvoiceDate}]+30 \).
   C. \( =[\text{LastName}] \& " "&[\text{FirstName}] \).
   D. \( =[\text{Units}] *[\text{UnitPrice}] \).

9. You want to track the progress of the stock market on a daily basis. Which type of chart should you use?
   A. Line chart.
   B. Column chart.
   C. Row chart.
   D. Pie chart.
10. How do you adjust a page’s margins?
   A. Click and drag the edge of the page to where you want the margin set.
   B. Select Format → Page Setup from the menu, click the Margins tab, and adjust the margins.
   C. Select File → Page Setup from the menu, click the Margins tab, and adjust the margins.
   D. Click the Margins button on the Formatting toolbar.

11. How can you view a report’s sorting and grouping options?
   A. Select Format → Sorting and Grouping from the menu.
   B. By double-clicking the Report Selector box in the upper left corner of the report.
   C. Select File → Page Setup from the menu and click the Sorting and Grouping tab.
   D. Click the Sorting and Grouping button on the toolbar.

12. What is the procedure for selecting multiple controls on a report?
   A. Press and hold down the <Shift> key as you click each object that you want to select.
   B. Use the arrow pointer (↑) to draw a box around the object that you want to select.
   C. If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.
   D. All of these.

Homework

1. Start Microsoft Access, if necessary, and then open the Homework database.
2. Use AutoReport to create and save a tabular report named “Customers,” using the Customers table as the underlying data source.
3. Delete the DOB field from the report.
4. Change all of the report’s margins to a half-inch.
5. Sort the information on the report by DOB.
6. Save your changes and close the Homework database.

Quiz Answers

1. C. The AutoReport Wizard can create reports in record time, but they aren’t usually well-organized or professional looking.
2. D. The Field List only displays fields from a report’s underlying table or query.
3. False. You can click and drag the upper left sizing handle to move a label or control independently of one another.
4. B. This procedure will let you add page numbers in Microsoft Word, but not in Microsoft Access.
5. A. You would want the calculated control in the Month Group Footer section to total monthly sales.
6. C. Although you can summarize information in a report section, there isn’t actually a section called a “Summary section.”
7. False. Although you can sort a report using a query, you can also simply click the Sorting and Grouping button on the toolbar and specify the field you want to use to sort the report.

8. A. This expression is missing the quotation marks (") and the ampersand (&) symbol. The corrected expression would be ="Total for: "&[Employee].

9. A. Line charts are used to illustrate trends. If you used the other three chart types to track the stock market, there would be too many data points.

10. C. You adjust a page’s margins by selecting File → Page Setup from the menu, clicking the Margins tab, and adjusting the margins.

11. D. Click the Sorting and Grouping button on the toolbar to view a report’s sorting and grouping options.

12. D. All of these are procedures for selecting multiple controls on a report.
Chapter Three: Formatting Forms and Reports

Chapter Objectives:

- Format fonts using the Formatting toolbar
- Change text alignment
- Use AutoFormat to quickly format forms and reports
- Change the color of text, objects, and borders
- Apply 3-D effects to the controls on forms and reports
- Use the Format Painter to copy control formatting options
- Add pictures and lines to forms and reports
- Align controls with one another
- Format a control by changing its Formatting Properties

Chapter Task: Apply formatting options to existing forms and reports

Forms and reports created with a Microsoft Access Wizard are informative and functional—but they are rarely well designed. Some of the forms and reports set up by the Form Wizard or Report Wizard are even downright ugly. Don’t worry—this chapter will help you fix the design of your forms and reports.

This chapter guides you through the process of creating sharp-looking forms and reports that have colorful fonts, neat-looking borders, even controls with 3-D effects. This chapter explains how to format your forms and reports to make them more visually attractive and easier to read. You will learn how to change the appearance, size, and color of fonts and how to align text inside a control. This chapter also describes how you can add pictures and graphics to your forms and reports.

Prerequisites

- How to use menus, toolbars, dialog boxes, and shortcut keystrokes.
- How to open and modify forms and reports in Design View.
Lesson 3-1: Formatting Fonts with the Formatting Toolbar

You can emphasize text on a form or report by making the text darker and heavier (**bold**), slanted (**italics**), larger, or in a different **typeface** (or font). The Formatting toolbar makes it easy to apply character formatting. The Formatting toolbar includes buttons for applying the most common formatting options.

1. **Start Microsoft Access**, open the Lesson 9 database, click the Reports icon in the Objects bar, and double-click the rptTourSales report.
   Access displays the rptTourSales report in Print Preview. A quick look at this report is all you need to realize that the Report Wizard could use a few remedial graphical design classes. Fortunately, a little moving, resizing, and formatting will fix all of the report’s design problems.

2. **Click the View button** on the Print Preview toolbar to switch to Design View.
   In order to format a control, you must first select it. The TourName text box in the TourName Header needs to stand out a little more from the rest of the report.

3. **Click the TourName text box control** in the TourName Header to select it.
   Handles ( ■ ) appear around the text box control, indicating that the control is selected. Once you have selected a control, you can format it.

4. **Click the Font list arrow ( ▼ ) on the Formatting toolbar**, then scroll to and select Arial from the list of fonts.
   The text in the TourName text box control appears in Arial font. Arial and Times New Roman are two of the most commonly used fonts in Windows.
You can also use the Formatting toolbar to change the size of a font. Font sizes are measured in points (pt.), which are 1/72 of an inch. The larger the number of points, the larger the font.

5. With the **TourName text box** still selected, click the **Font Size list arrow** (↑) on the Formatting toolbar and select **14**, as shown in Figure 3-2.

The TourName text box appears in a larger font size (14-point type instead of the previous 11-point type). Wow! That font formatting really makes the title stand out from the rest of the report, doesn’t it?

**NOTE:** When you change a control’s font size, you will often have to resize the control so that it can properly display its contents.

All the column-heading labels in the Page Header section need to be emphasized as well. You could select and format each label individually, but it’s much faster to select and format all of them at the same time. If the controls you want to format are arranged along a horizontal line, you can click to the left of the controls, in the vertical ruler, to select all of them.

6. **Select all the labels in the Page Header section** by clicking in the **vertical ruler to the left of the TourName label**.

Access selects everything to the right of where you clicked the mouse. Let’s apply boldface formatting to the selected text labels.

7. **Click the Bold button** on the Formatting toolbar.

The selected controls appear in bold.

8. **Click the Save button** to save your changes to the report.

<table>
<thead>
<tr>
<th><strong>Table 3-1: Examples of Common Font Types and Sizes</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Common Font Types</strong></td>
</tr>
<tr>
<td>Arial</td>
</tr>
<tr>
<td>Comic Sans MS</td>
</tr>
<tr>
<td>Courier New</td>
</tr>
<tr>
<td>Times New Roman</td>
</tr>
</tbody>
</table>

---

**Quick Reference**

<table>
<thead>
<tr>
<th><strong>To Change Font Size:</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>- Select the control and select the pt. size from the <strong>Font Size list</strong> on the Formatting toolbar.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>To Change Font Type:</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>- Select the control and select the font from the <strong>Font list</strong> on the Formatting toolbar.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>To Format Text with Bold, Italics, or Underlining:</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>- Select the control and click the Bold, Italics, or Underline button on the Formatting toolbar.</td>
</tr>
</tbody>
</table>
Lesson 3-2: Changing Text Alignment

This lesson explains how to align a control’s text to the left, center, or right. Figure 3-3 gives a better idea of what the various alignments look like. Alignment only affects what’s inside of a control: If you apply center formatting to a text box, Access will center the text inside the text box—it won’t center the text box control on the form or report. If you want to align a control to the left, center, or right of a form or report, you’ll have to do it the old-fashioned way—by clicking and dragging the control.

1. **Make sure that the rptTourSales report is open in Design View.**
   Again, you first need to select the control you want to format.

2. **Select the Date text label in the Page Header and click the Center button on the Formatting toolbar.**
   Access centers the text inside the Date text label. Easy, isn’t it? Let’s try aligning one more control.

3. **Click the TourName text label in the Page Header and click the Align Right button on the Formatting toolbar.**
   Access right-aligns the text inside the TourName text label.

4. **Click the Save button to save your changes to the report.**

### Table 3-2: Alignment Formatting Buttons on the Formatting Toolbar

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Example</th>
<th>Formatting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align Left</td>
<td>Left</td>
<td>Aligns text to the left side of the control.</td>
</tr>
<tr>
<td>Center</td>
<td>Center</td>
<td>Centers text in a control.</td>
</tr>
<tr>
<td>Align Right</td>
<td>Right</td>
<td>Aligns text to the right side of the control.</td>
</tr>
</tbody>
</table>
Lesson 3-3: Using AutoFormat

You’ve just finished creating a report using the Report Wizard when you suddenly realize that you hate how it looks! Don’t worry—you can apply a new design to your forms and templates at any time with the AutoFormat command. AutoFormat is a built-in collection of formats such as font sizes, patterns, and alignments you can quickly apply to a form or report. AutoFormat is a great feature if you want your forms and reports to look sharp and professional but don’t have the time to format them yourself.

1. **Make sure the rptTourSales report is open in Design View.**

   Here’s how to format a report using AutoFormat:

2. **Click the AutoFormat button on the Report Design toolbar.**

   The AutoFormat dialog box appears, as shown in Figure 3-5. The present formats are listed in the AutoFormat list. Yep, they’re the same choices as you get in the Report or Form Wizard. You can see what a format looks like by selecting it and looking at the sample area in the dialog box.

3. **Click the Options button.**

   The AutoFormat dialog box expands to show three check boxes. You can control the type of formatting that is applied by checking or unchecking any of the boxes. If you want AutoFormat to skip one of the formatting categories, simply uncheck the appropriate box.

4. **Select the default Compact option from the Report AutoFormats list and click OK.**

   The dialog box closes, and the report is formatted with the Compact formatting option.

5. **Click the Save button to save your changes and then close the rptTourSales report.**

---

**Figure 3-5**

The AutoFormat dialog box.

**AutoFormat button**

**Quick Reference**

To Format a Form or Report with AutoFormat:

1. Display the form or report you want to format in Design View.
2. Click the AutoFormat button on the Report Design toolbar.
3. Select one of the AutoFormats from the list and click OK.
Lesson 3-4: Changing Colors

In this day of color, laser, and inkjet printers, and high-resolution 21-inch monitors, choosing an appropriate color for your report or form is an important formatting decision. If used tastefully, colors can make your forms and reports look more visually attractive. You can add color to lines, text, rectangles—even to the background of your headers and footers!

In this lesson, you will learn how to use the color buttons on the Formatting toolbar to apply color to your reports and forms.

1. **Click the Forms icon in the Objects bar and open the frmCustomers form in Design View.**

   There are three color buttons on the Formatting toolbar—each color button applies color to a different element. It can be a little confusing to figure out which color button to use at first, so you’ll want to refer to Table 3-3: *Color Buttons on the Formatting Toolbar* until you get the hang of it.

2. **Click the Customers text label in the Form Header, click the Font/Fore Color button arrow on the Formatting toolbar, and select a yellow color.**

   You can also apply color to the sections of a report or form.

3. **Click the Form Header section divider, click the Fill/Back Color button arrow on the Formatting toolbar, and select a dark blue color.**

<table>
<thead>
<tr>
<th>Table 3-3: Color Buttons on the Formatting Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color Button</strong></td>
</tr>
<tr>
<td>Fill/Back Color</td>
</tr>
<tr>
<td>Font/Fore Color</td>
</tr>
<tr>
<td>Line/Border Color</td>
</tr>
</tbody>
</table>
Lesson 3-5: Applying Special Effects

You can apply special-effect formatting to the controls in your forms and reports to give them a polished, high-tech appearance. For example, you can give a form a three-dimensional look by applying a sunken or raised effect to its controls. Applying special-effect formatting is pretty straightforward: Simply select the controls you want to format and then select one of the six special-effect options (listed in Table 3-4: Available Special-Effect Options) from the Special Effect button list.

1. **Make sure the frmCustomers form is open in Design View.**
   Normally, you will want to apply special-effect formatting to both a control and its corresponding text label, so you will have to select both controls using one of the multiple-selection techniques you’ve (hopefully) learned.

2. **Click the CustomerID text box control to select it, then hold down the <Shift> key as you click the CustomerID text label.**
   You’re ready to apply a special effect to both controls.

3. **Click the Special Effect button arrow on the Formatting toolbar and select the Raised effect.**

### Table 3-4: Available Special-Effect Options

<table>
<thead>
<tr>
<th>Special Effect</th>
<th>Example</th>
<th>Special Effect</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flat</td>
<td>Date: 5/1/1992</td>
<td>Raised</td>
<td>Date: 5/1/1992</td>
</tr>
<tr>
<td>Sunken</td>
<td>Date: 5/1/1992</td>
<td>Etched</td>
<td>Date: 5/1/1992</td>
</tr>
<tr>
<td>Shadowed</td>
<td>Date: 5/1/1992</td>
<td>Chiseled</td>
<td>Date: 5/1/1992</td>
</tr>
</tbody>
</table>
Lesson 3-6: Using the Format Painter

If you find yourself applying exactly the same formatting to several controls repeatedly, the Format Painter is the tool for you. The Format Painter allows you to copy the formatting attributes from one control and then apply them to another. Sound confusing? It won’t once you have finished this lesson.

1. Make sure the `frmCustomers` form is open in Design View.
   First you need to select the control whose formatting attributes you want to copy or else format a control so that you can copy its formatting—and that’s what we’ll do in the next steps.

   **Figure 3-8**
   Use the Format Painter to copy formatting from one control to another.

   1. Select the control whose formatting you want to copy and click or double-click the Format Painter button.
   2. Click the control where you want to paste the copied formatting attributes.
   The copied formatting is applied to the destination control.
2. **Click the LastName text box control to select it.**
   We want to format this control so that we can copy its formatting attributes and paste them to other controls on the form.

3. **Click the Font/Fore Color button arrow on the Formatting toolbar and select a red color, then click the Bold button on Formatting toolbar, and finally click the Special Effect button arrow on the Formatting toolbar and select the Raised effect.**
   The control is now formatted with bold red text and a raised effect.

   It took some work to apply that formatting, didn’t it? Now imagine you want to format all the controls on the form with the same formatting options. Instead of doing all that formatting, you can use the Format Painter tool to copy the formatting from the LastName text box control and paste or apply the copied formatting to the other controls on the form. First, you need to select the control with the formatting you want to copy and then do one of the following:
   - **Single-click the Format Painter button:** Copy and apply the formatting to a single control.
   - **Double-click the Format Painter button:** Copy and apply the formatting to multiple controls. Click the Format Painter button when you’re finished pasting the formatting.

   Since we want to paste the LastName text box control’s formatting to several controls, we’ll double-click the Format Painter button.

4. **With the LastName text box control still selected, double-click the Format Painter button on the toolbar.**
   Notice that the pointer changes to a. Next, you need to paste, or apply the copied formatting.

5. **Click the Phone text box control with the Format Painter.**
   The Format Painter applies the copied formatting to the Phone text box control, saving you some time and work from manually formatting the control. Since we double-clicked the Format Painter, the pointer remains a so that we can paste the copied formatting to multiple controls.

6. **Click the FirstName text box control with the Format Painter.**
   When you’re finished with the Format Painter, click the Format Painter button to switch the pointer back to an ordinary selection arrow.

7. **Click the Format Painter button on the Formatting toolbar to stop pasting formatting attributes.**
   You’re finished with this lesson so…

8. **Close the frmCustomers form without saving any of your changes.**
Lesson 3-7: Adding Pictures and Lines

Pictures, graphics, and illustrations can make your reports more professional looking. This lesson explains how to insert clip art and graphics in your reports. You can insert graphics and pictures created with graphics programs such as Microsoft Paint (which comes with Windows), scanned pictures, or graphics from a clip-art library.

1. Make sure that you have the rptCustomers report open in Design View.
   Here’s how to insert a picture or graphic onto a report (this works for forms too!).

2. Click the Image button on the Toolbox.
   The pointer changes to a \[ \text{Image} \] . You use this pointer to determine where you want to place the image.

Figure 3-9
Inserting a picture onto a report.

Figure 3-10
The Insert Picture dialog box.

Other Ways to Insert a Picture:
- Select Insert $\rightarrow$ Picture from the menu.

Select the graphic file you want to insert.

Select \[ \text{Preview} \] from the list to display a preview of the selected graphic file.

A preview of the selected graphic file appears here.
Chapter Three: Formatting Forms and Reports

3. **Click and drag the pointer in the Report Header section down and to the right about an inch and a half, as shown in Figure 3-9.**
   
   As soon as you finish clicking and dragging, the Insert Picture dialog box appears, as shown in Figure 3-10. You need to specify the name and location of the graphic file you want to insert.

4. **Browse to your Practice folder.**
   
   All the graphic files located in your Practice folder appear in the file window.

5. **Select the Plane file.**
   
   You can display a preview of the graphic in the right side of the Insert Picture dialog box by clicking the list and selecting Preview.

6. **Click OK to insert the Plane graphic.**
   
   Access inserts the plane picture on the report.

   Reports with lots of information can sometimes be difficult to read. You can add vertical and/or horizontal lines to make your reports more organized.

7. **Click the Line button on the Toolbox.**
   
   The pointer changes to a line-draw tool. Unless you actually want to draw a diagonal line, hold down the <Shift> key as you click and drag to draw a straight line.

8. **Position the pointer in the far left side of the top of the Detail section (just above the LastName text box). Click and hold down the <Shift> key as you drag the pointer to the far right edge of the report.**
   
   More than likely your screen will not be wide enough to display the entire report—don’t worry, simply drag the pointer past the right edge of the screen to automatically scroll to the right.

   Let’s see how our report looks.

9. **Click the View button to view the report in Print Preview.**
   
   Notice that the line you added appears not once but under every record! That’s because you added the line to the report’s Detail section, which prints for every record in the report.

10. **Save your changes and close the report.**
    
    You can also use this technique to add pictures to your forms. Here’s a list of some of the types of graphic formats that you can use in Access:

    | Format | File Size | Description |
    |--------|-----------|-------------|
    | BMP    | Large     | Also known as a bitmap, this is a generic graphics format used by Paintbrush and many other programs. |
    | CGM    | Small     | Clip-art pictures often come in Computer Graphics Metafile format. |
    | GIF    | Small     | Picture file format commonly used on the Internet. |
    | JPG    | Small     | Digital photographs are usually saved as JPEG files. Because of their small size, JPEG files are also commonly used on the Internet. |
    | WMF    | Small     | Another file format used for clip-art pictures |
    | TIF    | Large     | A file format used by scanners, fax programs, and some drawing programs. |

**Quick Reference**

**To Insert a Graphic:**
1. Click the Image button on the Toolbox.
2. Move the pointer onto the form or report, then click and drag to draw a rectangle placeholder for the graphic.
3. Select the graphic file you want to insert and click OK.

**To Draw a Line:**
1. Click the Line button on the Toolbox.
2. Move the pointer onto the form or report, then click and drag to draw the line.
3. Hold down the <Shift> key as you drag to draw a straight line.
Lesson 3-8: Aligning Controls with One Another

Forms and reports that have controls scattered randomly about them look terrible. The Align command, located under the Format menu, aligns controls relative to one another. You can align controls so that they are lined up with one another or spaced equally apart from one another. This lesson will give you some practice aligning controls with the Align command.

1. Select the controls you want to align by holding down the <Shift> key as you click each control.

2. Select Format → Align from the menu and select an alignment option.

The objects are aligned with one another.
1. **Open the rptEmployeeSales report in Design View.**

Someone sure was sloppy when creating this report—its controls are all over the place! You could manually move the controls and align them with one another by using the mouse and eyeballing it, but that would require a lot of time, and (unless you have eyes like a hawk) it would be difficult to align the controls perfectly. Instead, we’ll align the controls using the Align command.

First you need to select the controls you want to align with one another. There are three ways to select more than one control:

- Press and hold down the <Shift> key as you click each control that you want to select.
- Use the arrow pointer (↑↓) to draw a box around the controls that you want to select. Point to a location above and to the left of the controls that you want to select, and click and drag the mouse down and to the right until the box surrounds all the controls. When you release the mouse button, all the controls in the box will be selected. The disadvantage of this method is that it’s not as selective as using the <Shift> + click method.
- If the controls you want to select are aligned along a horizontal line, click to the left of the object in the vertical ruler to select every control to the right of the ruler.

2. **Hold down the <Shift> key as you select the Employee text label and Employee text box control as shown in Figure 3-11.**

Now you can align the selected controls with each another. Here’s how:

3. **Select Format → Align → Left from the menu.**

The Employee text box control is left-aligned with the Employee text label.

Next let’s try vertically aligning two controls—the procedure is almost the same.

4. **Hold down the <Shift> key as you select the Employee text box control and Date text box control.**

Now let’s vertically align the controls with each other.

5. **Select Format → Align → Top from the menu.**

Access vertically aligns the two controls with each other.

You can also quickly adjust the amount of horizontal or vertical space between controls by selecting the controls and then selecting a command from either the Horizontal Spacing or Vertical Spacing submenu under the Format menu.

Move on to the next step and we’ll adjust the amount of space between the controls on the report.

6. **Hold down the <Shift> key as you click the vertical ruler to the left of the text labels in the Page Header. Keep holding the <Shift> key and click the vertical ruler to the left of the fields in the Detail section.**

You’ve selected all the text labels in the Page Header and all the fields in the Detail section. Here’s how to adjust the spacing between the selected controls with just a few quick clicks of the mouse.

7. **Select Format → Horizontal Spacing → Make Equal from the menu.**

Access evenly distributes the selected controls.

8. **Click and drag the Page Footer divider up to reduce the amount of empty space in the Detail section.**

You’re finished!

9. **Save your changes and close the form.**

Give yourself a pat on the back when you have finished this lesson—probably less than 10 percent of all Access users know this fast and easy method of aligning controls.
Lesson 3-9: Changing a Control’s Formatting Properties

The Formatting toolbar is great for quickly applying the most common formatting options to the controls on your forms and reports, but it doesn’t offer every formatting option available. To see and/or use every possible formatting option, you need to view the control’s Formatting Properties. Each type of control has its own set of formatting properties—for example, a line control has a Border Style property, which determines if the line should be solid, dashed, or dotted.

To display the Formatting Properties for a control, do one of the following:

- Select the control and click the Properties button on the toolbar.
- Right-click the control and select Properties from the shortcut menu.
- Double-click the control.
- Select the control and select View → Properties from the menu.

...and then click the Format tab if necessary. The more common Formatting Properties are listed in Table 3-6: Common Formatting Properties. You might want to review the Working with Tables and Fields chapter as well, which contains information on formatting fields.

This lesson will give you some practice working with a control’s Formatting Properties.

1. **Make sure that you have the rptTourSales report open in Design View.**
   For this exercise, we’ll view and change the Formatting Properties of the dark red line in the report’s Page Header.

2. **Click the dark red line in the Page Header to select it, then click the Properties button on the toolbar. Click the Format tab if necessary.**
   The Formatting Properties for the red line appear, as shown in Figure 3-12. There’s not much to an ordinary line, so its Formatting Properties are rather limited. One Formatting Property that we can change is the line’s Border Style property.
3. Click in the Border Style box, click the arrow, and select Dashes from the list.

The line changes from a solid line to a dashed line. Let’s make one more formatting change while the Properties dialog box is still open.

4. With the line still selected and the Properties dialog box still open, click the Border Width button arrow and select 5 pt from the list.

The width of the line changes to three five points.

5. Exit Microsoft Access without saving any of your changes.

Table 3-6: Common Formatting Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Customizes the way numbers, dates, times, and text are displayed.</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>Determines the number of decimal places displayed (for numeric values).</td>
</tr>
<tr>
<td>Visible</td>
<td>Shows or hides a control. Useful if you want to use information on a form without it being visible.</td>
</tr>
<tr>
<td>Hide Duplicates</td>
<td>Hides a control on a report when its value is the same as in the preceding record. For example, on a report listing suppliers and their products, each supplier’s name can appear once for each group of products, rather than once for each product.</td>
</tr>
<tr>
<td>Can Grow</td>
<td>Determines if a control on a report expands vertically when printed to fit text.</td>
</tr>
<tr>
<td>Can Shrink</td>
<td>Determines if a control on a report shrinks vertically when printed to eliminate blank lines.</td>
</tr>
<tr>
<td>Left</td>
<td>Determines the horizontal position of a control.</td>
</tr>
<tr>
<td>Top</td>
<td>Determines the vertical position of a control.</td>
</tr>
<tr>
<td>Width</td>
<td>Determines the width of a control.</td>
</tr>
<tr>
<td>Height</td>
<td>Determines the height of a control.</td>
</tr>
<tr>
<td>Back Color</td>
<td>Determines the color of a control. Click the button to select a color from a palette.</td>
</tr>
<tr>
<td>Special Effect</td>
<td>Applies the specified 3-D effect to the control.</td>
</tr>
<tr>
<td>Border Style</td>
<td>Determines the line style of a control's border—select from transparent lines, solid lines, dashed lines, etc.</td>
</tr>
<tr>
<td>Border Color</td>
<td>Determines the color of a control's border.</td>
</tr>
<tr>
<td>Border Width</td>
<td>Determines the width of a control's border (in points).</td>
</tr>
<tr>
<td>Fore Color</td>
<td>Determines the color of text in a control or the fill color of a drawing object.</td>
</tr>
<tr>
<td>Font Name</td>
<td>Determines the font used in a control (such as Arial or Times New Roman).</td>
</tr>
<tr>
<td>Font Weight</td>
<td>Determines the thickness (boldface) of text in a control.</td>
</tr>
<tr>
<td>Font Italic</td>
<td>Determines whether text in a control appears in italics.</td>
</tr>
<tr>
<td>Font Underline</td>
<td>Determines whether text in a control is underlined.</td>
</tr>
<tr>
<td>Text Align</td>
<td>Determines how text should be aligned in a control.</td>
</tr>
</tbody>
</table>
Chapter Three Review

Lesson Summary

Formatting Fonts with the Formatting Toolbar
• To Change Font Size: Select the control and select the pt. size from the Font Size list on the Formatting toolbar.
• To Change Font Type: Select the control and select the font from the Font list on the Formatting toolbar.
• To Format Text with Bold, Italics, or Underlining: Select the control and click the Bold, Italics, or Underline button on the Formatting toolbar.

Changing Text Alignment
• To Change Text Alignment: Select the control and click the Align Left, Center, or Align Right button.

Using AutoFormat
• To Format a Form or Report with AutoFormat: Display the form or report you want to format in Design View, click the AutoFormat button on the Report Design toolbar, select one of the AutoFormats from the list, and click OK.

Changing Colors
• To Change a Control’s Colors: Select the control and click one of the following buttons on the Formatting toolbar:
  - Fill/Back Color
  - Font/Fore Color
  - Line/Border Color

Applying Special Effects
• To Apply a Special Effect to a Control: Select the control, click the Special Effect button arrow, and select the desired special effect.

Using the Format Painter
• To Copy Formatting with the Format Painter: Select the control with the formatting options you want to copy, click the Format Painter button on the toolbar, and select the control where you want to apply the copied formatting.
• To Copy Selected Formatting to Several Locations: Select the control with the formatting options you want to copy, double-click the Format Painter button, select the controls where you want to apply the copied formatting, Click the Format Painter button when you’re finished.
Adding Pictures and Lines

- **To Insert a Graphic:** Click the Image button on the Toolbox, move the pointer onto the form or report, then click and drag to draw a rectangle placeholder for the graphic. Select the graphic file you want to insert and click OK.

- **To Draw a Line:** Click the Line button on the Toolbox, move the pointer onto the form or report, then click and drag to draw the line. Hold down the <Shift> key as you drag to draw a straight line.

Aligning Controls with One Another

- **To Select Multiple Controls:** Do any of the following:
  - Press and hold down the <Shift> key as you click each object that you want to select.
  - Use the arrow pointer (→) to draw a box around the objects that you want to select.
  - If the controls are aligned along a horizontal or vertical line, click the horizontal or vertical ruler above or to the left of the controls.

- **To Align Objects with Each Other:** Follow the above steps to select the objects you want to align, then select Format → Align and select an alignment option from the menu.

Changing a Control’s Formatting Properties

- **To Format a Control Using the Properties Dialog Box:** Display the form in Design View, select the control and click the Properties button on the toolbar, click the Format tab and make the desired formatting changes.

### Quiz

1. Fonts are measured in points. The larger the number of points, the smaller the size of the font. (True or False?)

2. You select a control and then click the Align Left button on the Formatting toolbar. What happens?
   - A. The control is aligned to the left side of the form or report.
   - B. Nothing – the alignment buttons on the Formatting toolbar are used to determine the position of the form or report on the screen.
   - C. The text inside the control is aligned to the left side of the control.
   - D. Nothing – you must also select the control that you want to use to align the selected control with.

3. AutoFormat automatically applies formatting options as you type. (True or False?)

4. The Fill/Back Color button on the Formatting toolbar applies color to:
   - A. The text in the selected control.
   - B. The background of the selected control.
   - C. The border of the selected control.
   - D. All aspects of the control.
5. What does the Special Effect button on the Formatting toolbar do?
   A. It applies a 3-D effect to a selected control.
   B. It lets you select a transitional effect for how a form opens and closes.
   C. It lets you add animation to your forms and reports to make them more entertaining and amusing.
   D. None of the above.

6. Which of the following are reasons why you might want to format a control using the Properties dialog box instead of the Formatting toolbar? (Select all that apply.)
   A. You want to show off your Microsoft Access expertise to do things the hard way.
   B. The Properties dialog box offers every formatting option available for the control—something the Formatting toolbar doesn’t have.
   C. The Properties dialog box gives you greater control over how a control is formatted.
   D. You can change the language used in a control using the Properties dialog box. For example, you could select Spanish or French instead of English.

7. You want to insert a graphic of your company’s logo on a report. How can you do this? (Select all that apply.)
   A. You can’t—Microsoft Access won’t let you insert graphic files.
   B. Click the Image button on the Toolbox and drag on the report to draw a placeholder for the graphic.
   C. Select Insert → Picture from the menu.
   D. Select Tools → Insert Picture from the menu.

8. How can you align several controls with each other?
   A. Select the controls by holding down the <Shift> key as you click each object, then select Format → Align and select an alignment option from the menu.
   B. Select the controls by holding down the <Ctrl> key as you click each object, then select Format → Align and select an alignment option from the menu.
   C. Select the controls by holding down the <Ctrl> key as you click each object, then click the appropriate alignment button on the Drawing toolbar.
   D. Select the controls by holding down the <Shift> key as you click each object, then click the appropriate alignment button on the Drawing toolbar.

**Homework**

1. Start Microsoft Access, open the Homework database, and open the Test Answers form in Design View.
2. Use AutoFormat to apply the International preset formatting style to the Test Answers form.
3. Change the back color of the Grade field to light yellow.
4. Change the font size of the Grade field to 10 pt.
5. Use the Format Painter tool to copy the formatting from the Grade field and apply it to the two remaining fields on the Test Answers form.
6. Resize the controls as necessary to make room for the new font size.

![Image of a form with controls]

7. Save the changes to the form.


**Quiz Answers**

1. False. It’s true that fonts are measured in points; however, the larger the number of points, the larger the size of the font.

2. C. The text inside the control is aligned to the left side of the control.

3. False. AutoFormat lets you quickly format a form or report using a set of predefined formatting options.

4. B. The Fill/Back Color button on the Formatting toolbar applies color to the background of a selected control.

5. A. The Special Effect button applies a 3-D effect to a selected control.

6. B and C. The Properties dialog box gives you more control and options over how a control is formatted.

7. B and C. To insert a picture on a form or report, click the Image button on the Toolbox, and drag on the report to draw a placeholder for the graphic, or select Insert ➔ Picture from the menu.

8. A. To align several controls with each other, select the controls by holding down the <Shift> key as you click each object, then select Format ➔ Align and select an alignment option from the menu.